libcurl.so.3 or libcurl.so.4

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

libcurl.so.3 or libcurl.so.4

Ari Denison
Centos 6.2 64bit

I'm getting this while installing 9.2.1 on a fresh development server.

Is there a way to point lasso to the current (yum default) version of libcurl? Or must I jump through a few hoops to get an older version installed either as a replacement or side-by-side version?

[root@dev ~]# env LASSO9_PRINT_FAILURES=1 lassoserver
lassoserver: error while loading shared libraries: libcurl.so.3: cannot open shared object file: No such file or directory
[root@dev ~]# locate libcurl.so
/usr/lib64/libcurl.so
/usr/lib64/libcurl.so.4
/usr/lib64/libcurl.so.4.1.1


#############################################################
This message is sent to you because you are subscribed to
  the mailing list Lasso
[hidden email]
To unsubscribe, E-mail to: <[hidden email]>
Send administrative queries to  <[hidden email]>
Reply | Threaded
Open this post in threaded view
|

Re: libcurl.so.3 or libcurl.so.4

Ari Denison
Symbolic links seem to have worked.

On Jun 2, 2012, at 8:30 PM, Ari Denison wrote:

Centos 6.2 64bit

I'm getting this while installing 9.2.1 on a fresh development server.

Is there a way to point lasso to the current (yum default) version of libcurl? Or must I jump through a few hoops to get an older version installed either as a replacement or side-by-side version?

[root@dev ~]# env LASSO9_PRINT_FAILURES=1 lassoserver
lassoserver: error while loading shared libraries: libcurl.so.3: cannot open shared object file: No such file or directory
[root@dev ~]# locate libcurl.so
/usr/lib64/libcurl.so
/usr/lib64/libcurl.so.4
/usr/lib64/libcurl.so.4.1.1



#############################################################
This message is sent to you because you are subscribed to
  the mailing list Lasso
[hidden email]
To unsubscribe, E-mail to: <[hidden email]>
Send administrative queries to  <[hidden email]>
Reply | Threaded
Open this post in threaded view
|

Re: libcurl.so.3 or libcurl.so.4

Steffan A. Cline
In reply to this post by Ari Denison
Are you sure you installed the CentOS 6 version? It looks as if the
version you installed is for CentOS 5. libcurl.so.4 is the standard for
CentOS 6 and .3 is for CentOS 5.

http://centos6yum.lassosoft.com

If you are running CnetOS 6, you need to make sure you have the right
version installed.


Thanks

Steffan

---------------------------------------------------------------
T E L  6 0 2 . 7 9 3 . 0 0 1 4 | F A X  6 0 2 . 9 7 1 . 1 6 9 4
Steffan A. Cline  
[hidden email]                             Phoenix, Az
http://www.ExecuChoice.net                                  USA
AIM    : SteffanC                     Skype : steffancline
GOOGLE : [hidden email]        MSN : [hidden email]
YAHOO  : Steffan_Cline        ICQ : 57234309
---------------------------------------------------------------





On 6/2/12 6:30 PM, "Ari Denison" <[hidden email]> wrote:

>Centos 6.2 64bit
>
>I'm getting this while installing 9.2.1 on a fresh development server.
>
>Is there a way to point lasso to the current (yum default) version of
>libcurl? Or must I jump through a few hoops to get an older version
>installed either as a replacement or side-by-side version?
>
>[root@dev ~]# env LASSO9_PRINT_FAILURES=1 lassoserver
>lassoserver: error while loading shared libraries: libcurl.so.3: cannot
>open shared object file: No such file or directory
>[root@dev ~]# locate libcurl.so
>/usr/lib64/libcurl.so
>/usr/lib64/libcurl.so.4
>/usr/lib64/libcurl.so.4.1.1
>
>
>#############################################################
>This message is sent to you because you are subscribed to
>  the mailing list Lasso
>[hidden email]
>To unsubscribe, E-mail to: <[hidden email]>
>Send administrative queries to  <[hidden email]>
>


#############################################################
This message is sent to you because you are subscribed to
  the mailing list Lasso
[hidden email]
To unsubscribe, E-mail to: <[hidden email]>
Send administrative queries to  <[hidden email]>
Reply | Threaded
Open this post in threaded view
|

Re: libcurl.so.3 or libcurl.so.4

Ari Denison
Good catch! Thanks.

On Jun 3, 2012, at 9:13 AM, Steffan A. Cline wrote:

Are you sure you installed the CentOS 6 version? It looks as if the
version you installed is for CentOS 5. libcurl.so.4 is the standard for
CentOS 6 and .3 is for CentOS 5.

http://centos6yum.lassosoft.com

If you are running CnetOS 6, you need to make sure you have the right
version installed.


Thanks

Steffan

---------------------------------------------------------------
T E L  6 0 2 . 7 9 3 . 0 0 1 4 | F A X  6 0 2 . 9 7 1 . 1 6 9 4
Steffan A. Cline  
[hidden email]                             Phoenix, Az
http://www.ExecuChoice.net                                  USA
AIM    : SteffanC                     Skype : steffancline
GOOGLE : [hidden email]        MSN : [hidden email]
YAHOO  : Steffan_Cline        ICQ : 57234309
---------------------------------------------------------------





On 6/2/12 6:30 PM, "Ari Denison" <[hidden email]> wrote:

> Centos 6.2 64bit
>
> I'm getting this while installing 9.2.1 on a fresh development server.
>
> Is there a way to point lasso to the current (yum default) version of
> libcurl? Or must I jump through a few hoops to get an older version
> installed either as a replacement or side-by-side version?
>
> [root@dev ~]# env LASSO9_PRINT_FAILURES=1 lassoserver
> lassoserver: error while loading shared libraries: libcurl.so.3: cannot
> open shared object file: No such file or directory
> [root@dev ~]# locate libcurl.so
> /usr/lib64/libcurl.so
> /usr/lib64/libcurl.so.4
> /usr/lib64/libcurl.so.4.1.1
>
>
> #############################################################
> This message is sent to you because you are subscribed to
> the mailing list Lasso
> [hidden email]
> To unsubscribe, E-mail to: <[hidden email]>
> Send administrative queries to  <[hidden email]>
>


#############################################################
This message is sent to you because you are subscribed to
 the mailing list Lasso
[hidden email]
To unsubscribe, E-mail to: <[hidden email]>
Send administrative queries to  <[hidden email]>

#############################################################
This message is sent to you because you are subscribed to
  the mailing list Lasso
[hidden email]
To unsubscribe, E-mail to: <[hidden email]>
Send administrative queries to  <[hidden email]>
Reply | Threaded
Open this post in threaded view
|

Re: libcurl.so.3 or libcurl.so.4

Ari Denison
In reply to this post by Steffan A. Cline
Good catch. :)

On Jun 3, 2012, at 9:13 AM, Steffan A. Cline wrote:

Are you sure you installed the CentOS 6 version? It looks as if the
version you installed is for CentOS 5. libcurl.so.4 is the standard for
CentOS 6 and .3 is for CentOS 5.

http://centos6yum.lassosoft.com

If you are running CnetOS 6, you need to make sure you have the right
version installed.


Thanks

Steffan

---------------------------------------------------------------
T E L  6 0 2 . 7 9 3 . 0 0 1 4 | F A X  6 0 2 . 9 7 1 . 1 6 9 4
Steffan A. Cline  
[hidden email]                             Phoenix, Az
http://www.ExecuChoice.net                                  USA
AIM    : SteffanC                     Skype : steffancline
GOOGLE : [hidden email]        MSN : [hidden email]
YAHOO  : Steffan_Cline        ICQ : 57234309
---------------------------------------------------------------





On 6/2/12 6:30 PM, "Ari Denison" <[hidden email]> wrote:

> Centos 6.2 64bit
>
> I'm getting this while installing 9.2.1 on a fresh development server.
>
> Is there a way to point lasso to the current (yum default) version of
> libcurl? Or must I jump through a few hoops to get an older version
> installed either as a replacement or side-by-side version?
>
> [root@dev ~]# env LASSO9_PRINT_FAILURES=1 lassoserver
> lassoserver: error while loading shared libraries: libcurl.so.3: cannot
> open shared object file: No such file or directory
> [root@dev ~]# locate libcurl.so
> /usr/lib64/libcurl.so
> /usr/lib64/libcurl.so.4
> /usr/lib64/libcurl.so.4.1.1
>
>
> #############################################################
> This message is sent to you because you are subscribed to
> the mailing list Lasso
> [hidden email]
> To unsubscribe, E-mail to: <[hidden email]>
> Send administrative queries to  <[hidden email]>
>


#############################################################
This message is sent to you because you are subscribed to
 the mailing list Lasso
[hidden email]
To unsubscribe, E-mail to: <[hidden email]>
Send administrative queries to  <[hidden email]>

#############################################################
This message is sent to you because you are subscribed to
  the mailing list Lasso
[hidden email]
To unsubscribe, E-mail to: <[hidden email]>
Send administrative queries to  <[hidden email]>