[knop-project] Lasso 9 update FileMaker record

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

[knop-project] Lasso 9 update FileMaker record

stevepiercy
Does anyone use FileMaker with Knop and Lasso 9?

I've tried every possible combination to update a record in
FileMaker using Knop for Lasso 9's knop_database -> saverecord().

     $db -> saverecord(
         array('name'='value'),
         -keyfield='',
         -keyvalue=1234
         )

No matter what, the record does not update.  However the Lasso
error log shows this:

     knop_database _unknownTag called without corresponding
field name: _unknowntag

Which is generated by this line of code:
https://github.com/knop-project/knop/blob/master/knop9/knoplibs/knop_database.lasso#L200

Judging by the comments left in there, it looks like someone
(Jolle?) ran into similar issues and tried to debug it.

Anyone got any idea of how to debug this issue?  I'm at an utter
and complete loss.

FWIW, a regular old inline works.

     inline(
         -database='database',
         -table='table',
         -keyfield='',
         -keyvalue=1234,
         array('name'='value'),
         -update) => {}

Why -keyfield=''?  Because it's not fixed:
http://www.lassosoft.com/rhinotrac?id=7429

--steve

-- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
Steve Piercy              Website Builder              Soquel, CA
<[hidden email]>               <http://www.StevePiercy.com/>

--
You received this message because you are subscribed to the Google Groups "knop-project" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
Visit this group at http://groups.google.com/group/knop-project.
To view this discussion on the web visit https://groups.google.com/d/msgid/knop-project/r422Ps-1085i-9782D371E5504024B96D7339BC9E791D%40stevepi-mbp.local.
For more options, visit https://groups.google.com/d/optout.
Loading...