[knop-project] Knop for Lasso 9 does not work on Lasso 9.3?

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

[knop-project] Knop for Lasso 9 does not work on Lasso 9.3?

stevepiercy
I have a preliminary report that Knop for Lasso 9 does not run
on Lasso 9.3.  Can anyone confirm or refute the report?

I have not yet moved to 9.3 nor have I set up a VM sandbox to
play in.

--steve

-- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
Steve Piercy              Website Builder              Soquel, CA
<[hidden email]>               <http://www.StevePiercy.com/>

--
You received this message because you are subscribed to the Google Groups "knop-project" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
Visit this group at http://groups.google.com/group/knop-project.
To view this discussion on the web visit https://groups.google.com/d/msgid/knop-project/r422Ps-1085i-793BBA82638D478BB5BB499487036CD1%40stevepi-mbp.local.
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [knop-project] Knop for Lasso 9 does not work on Lasso 9.3?

stevepiercy
The lack of response means if I want to use Knop, then stay away from Lasso 9.3.

--steve


On 6/1/15 at 12:45 PM, [hidden email] (Steve Piercy - Website Builder) pronounced:

> I have a preliminary report that Knop for Lasso 9 does not run on Lasso 9.3.  Can
> anyone confirm or refute the report?
>
> I have not yet moved to 9.3 nor have I set up a VM sandbox to play in.
>
> --steve
>
> -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
> Steve Piercy              Website Builder              Soquel, CA
> <[hidden email]>               <http://www.StevePiercy.com/>
>

-- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
Steve Piercy              Website Builder              Soquel, CA
<[hidden email]>               <http://www.StevePiercy.com/>

--
You received this message because you are subscribed to the Google Groups "knop-project" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
Visit this group at http://groups.google.com/group/knop-project.
To view this discussion on the web visit https://groups.google.com/d/msgid/knop-project/r422Ps-1085i-D2FD6FBD78D343E98383473673381595%40stevepi-mbp.local.
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [knop-project] Knop for Lasso 9 does not work on Lasso 9.3?

Jolle Carlestam-4
I think it was up to me to give an answer. But although I use Lasso 9.3 I don’t use Knop actively anymore and thus simply don’t know.
Would not be surprised however if there are problems. Given that Lasso 9.3 tightened the acceptance of alternative signatures a lot, and that Knop for 9 uses them extensively.

Knop for 9 was, in large parts, written while Lasso was still in beta. Even while in alpha. It was also written to accommodate as many coding styles as possible with high focus on backwards compatibility.
To revisit Knop now, with the same level of ambition is simply not feasible. Nor productive.

My suggestion for anyone who wants to use Knop with 9.3 is to take a look at how the projects that are to be run on Lasso 9.3 are written and adjust a branch of Knop to that coding style. Removing all alternative signatures that are not in use.
Are the calls made using positional params, then keep that signature and remove the rest. Are you in favor of keyword params, the do the opposite.

The exercise should not be overwhelming. My guess is that one to a couple of hours of testing would find the quirks and remove them.

HDB
Jolle

5 jun 2015 kl. 13:11 skrev Steve Piercy - Website Builder <[hidden email]>:

> The lack of response means if I want to use Knop, then stay away from Lasso 9.3.
>
> --steve
>
>
> On 6/1/15 at 12:45 PM, [hidden email] (Steve Piercy - Website Builder) pronounced:
>
>> I have a preliminary report that Knop for Lasso 9 does not run on Lasso 9.3.  Can
>> anyone confirm or refute the report?
>>
>> I have not yet moved to 9.3 nor have I set up a VM sandbox to play in.
>>
>> --steve
>>
>> -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
>> Steve Piercy              Website Builder              Soquel, CA
>> <[hidden email]>               <http://www.StevePiercy.com/>
>>
>
> -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
> Steve Piercy              Website Builder              Soquel, CA
> <[hidden email]>               <http://www.StevePiercy.com/>
>
> --
> You received this message because you are subscribed to the Google Groups "knop-project" group.
> To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
> To post to this group, send email to [hidden email].
> Visit this group at http://groups.google.com/group/knop-project.
> To view this discussion on the web visit https://groups.google.com/d/msgid/knop-project/r422Ps-1085i-D2FD6FBD78D343E98383473673381595%40stevepi-mbp.local.
> For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "knop-project" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
Visit this group at http://groups.google.com/group/knop-project.
To view this discussion on the web visit https://groups.google.com/d/msgid/knop-project/5EAA7538-D550-4BB7-B2FE-E816DE7E11C8%40gmail.com.
For more options, visit https://groups.google.com/d/optout.
Loading...