getting 802 error with FileMaker 10 custom web publishing

classic Classic list List threaded Threaded
12 messages Options
Reply | Threaded
Open this post in threaded view
|

getting 802 error with FileMaker 10 custom web publishing

Tami Williams-3
Thanks in advance for any help.


Has anyone ever seen the FileMaker 802 error with custom web  
publishing?  It means "can't open database".  It can also refer to a  
permissions or security error when trying to configure a Web  
Publishing Engine.

Do you know how to solve it?  You can contact me offline at [hidden email]
  to get more info.

I have a client using Lasso that's getting this error 30-40% of the  
time.   Using FileMaker Server 10 on Mac OS X Server 10.5 and Lasso 8.5.


Here's a test URL for you to see the error in action:

http://order.imagers.com/FM_WPE_test.lasso   (I'll try to get and post  
the inline on this page soon.)


NOTE: they do NOT get this error when doing a request NOT using Lasso,  
i.e. just via FMI XML- like this

http://hostname/fmi/xml/FMPXMLRESULT.xml?-db=DBNAME&[searchqueryhere]






--
This list is a free service of LassoSoft: http://www.LassoSoft.com/
Search the list archives: http://www.ListSearch.com/Lasso/Browse/
Manage your subscription: http://www.ListSearch.com/Lasso/


Reply | Threaded
Open this post in threaded view
|

Re: getting 802 error with FileMaker 10 custom web publishing

stevepiercy
On 4/16/10 at 6:04 PM, [hidden email] (Tami Williams) pronounced:

>Here's a test URL for you to see the error in action:
>
>http://order.imagers.com/FM_WPE_test.lasso   (I'll try to get
>and post the inline on this page soon.)
>
>
>NOTE: they do NOT get this error when doing a request NOT using
>Lasso, i.e. just via FMI XML- like this
>
>http://hostname/fmi/xml/FMPXMLRESULT.xml?-db=DBNAME&[searchqueryhere]

Yay for intermittent errors!

Put the following into a Lasso page.  It will bypass any Lasso
database settings and should yield the exact same results as if
you used curl from the command line from the Lasso server.

[loop(10)]
<textarea>
[include_url('http://hostname/fmi/xml/FMPXMLRESULT.xml?-db=DBNAME&[searchqueryhere]')]
</textarea>
[/loop]

Textarea allows the XML result to be displayed inline.  Run this
N times to see whether it is intermittent.

It is possible that there is a flaky connection between the
Lasso and FM servers.

It is possible Lasso settings for the host are messed up and
need to be deleted and re-entered.

There is also the Lasso FMS9 Quick Start Guide which has some
troubleshooting tips.

--steve

-- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
-- --
Steve Piercy               Web Site Builder              
Soquel, CA
<[hidden email]>                  <http://www.StevePiercy.com/>


--
This list is a free service of LassoSoft: http://www.LassoSoft.com/
Search the list archives: http://www.ListSearch.com/Lasso/Browse/
Manage your subscription: http://www.ListSearch.com/Lasso/


Reply | Threaded
Open this post in threaded view
|

Re: getting 802 error with FileMaker 10 custom web publishing

Tami Williams-3
What SteveP suggested below is what's happening at http://print.imagers.com/FM_WPE_test.lasso 
.  You can run it and see that the error is happening 30-40% of the  
time.  That page has a 10 count loop on it, and the include_url has an  
error 3-4 times out of 10.

At this point everything in the lasso and FileMaker guides has been  
tried and has not fixed this problem.

I'm trying to see if anyone has experienced anything like this and how  
they solved it.

Its kind of a deal killer - Lasso + FileMaker wise.

NOTE: the error happens if you use a 0 millisecond sleep in the loop.  
IF you change the sleep to 15 milliseconds the error doesn't happen.  
Anyone see anything like this / have any ideas on how to fix it  
(beyond adding a 15 millisecond sleep to every search on the site)>

Thanks in advance.




On Apr 16, 2010, at 8:16 PM, Steve Piercy - Web Site Builder wrote:

> On 4/16/10 at 6:04 PM, [hidden email] (Tami Williams) pronounced:
>
>> Here's a test URL for you to see the error in action:
>>
>> http://order.imagers.com/FM_WPE_test.lasso   (I'll try to get and  
>> post the inline on this page soon.)
>>
>>
>> NOTE: they do NOT get this error when doing a request NOT using  
>> Lasso, i.e. just via FMI XML- like this
>>
>> http://hostname/fmi/xml/FMPXMLRESULT.xml?-db=DBNAME&[searchqueryhere]
>
> Yay for intermittent errors!
>
> Put the following into a Lasso page.  It will bypass any Lasso  
> database settings and should yield the exact same results as if you  
> used curl from the command line from the Lasso server.
>
> [loop(10)]
> <textarea>
> [include_url('http://hostname/fmi/xml/FMPXMLRESULT.xml?- 
> db=DBNAME&[searchqueryhere]')]
> </textarea>
> [/loop]
>
> Textarea allows the XML result to be displayed inline.  Run this N  
> times to see whether it is intermittent.
>
> It is possible that there is a flaky connection between the Lasso  
> and FM servers.
>
> It is possible Lasso settings for the host are messed up and need to  
> be deleted and re-entered.
>
> There is also the Lasso FMS9 Quick Start Guide which has some  
> troubleshooting tips.
>
> --steve
>
> -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
> Steve Piercy               Web Site Builder               Soquel, CA
> <[hidden email]>                  <http://www.StevePiercy.com/>
>
>
> --
> This list is a free service of LassoSoft: http://www.LassoSoft.com/
> Search the list archives: http://www.ListSearch.com/Lasso/Browse/
> Manage your subscription: http://www.ListSearch.com/Lasso/
>
>


--
This list is a free service of LassoSoft: http://www.LassoSoft.com/
Search the list archives: http://www.ListSearch.com/Lasso/Browse/
Manage your subscription: http://www.ListSearch.com/Lasso/


Reply | Threaded
Open this post in threaded view
|

Re: getting 802 error with FileMaker 10 custom web publishing

Tami Williams-3
CORRECTION:

If I increase the sleep between requests I get less errors (i.e. sleep  
15 milliseconds, 100 requests = 3 errors, 0 millisconds sleep, 10  
request = 3-4 errors).

But most of the time I get at least one 802 error.

(I thought 15 milliseconds worked for a sec b/c I got no errors, but  
on subsequent tests the errors re-appeared).


On Apr 19, 2010, at 8:25 PM, Tami Williams wrote:

> What SteveP suggested below is what's happening at http://print.imagers.com/FM_WPE_test.lasso 
> .  You can run it and see that the error is happening 30-40% of the  
> time.  That page has a 10 count loop on it, and the include_url has  
> an error 3-4 times out of 10.
>
> At this point everything in the lasso and FileMaker guides has been  
> tried and has not fixed this problem.
>
> I'm trying to see if anyone has experienced anything like this and  
> how they solved it.
>
> Its kind of a deal killer - Lasso + FileMaker wise.
>
> NOTE: the error happens if you use a 0 millisecond sleep in the  
> loop.  IF you change the sleep to 15 milliseconds the error doesn't  
> happen.  Anyone see anything like this / have any ideas on how to  
> fix it (beyond adding a 15 millisecond sleep to every search on the  
> site)>
>
> Thanks in advance.
>
>
>
>
> On Apr 16, 2010, at 8:16 PM, Steve Piercy - Web Site Builder wrote:
>
>> On 4/16/10 at 6:04 PM, [hidden email] (Tami Williams) pronounced:
>>
>>> Here's a test URL for you to see the error in action:
>>>
>>> http://order.imagers.com/FM_WPE_test.lasso   (I'll try to get and  
>>> post the inline on this page soon.)
>>>
>>>
>>> NOTE: they do NOT get this error when doing a request NOT using  
>>> Lasso, i.e. just via FMI XML- like this
>>>
>>> http://hostname/fmi/xml/FMPXMLRESULT.xml?- 
>>> db=DBNAME&[searchqueryhere]
>>
>> Yay for intermittent errors!
>>
>> Put the following into a Lasso page.  It will bypass any Lasso  
>> database settings and should yield the exact same results as if you  
>> used curl from the command line from the Lasso server.
>>
>> [loop(10)]
>> <textarea>
>> [include_url('http://hostname/fmi/xml/FMPXMLRESULT.xml?- 
>> db=DBNAME&[searchqueryhere]')]
>> </textarea>
>> [/loop]
>>
>> Textarea allows the XML result to be displayed inline.  Run this N  
>> times to see whether it is intermittent.
>>
>> It is possible that there is a flaky connection between the Lasso  
>> and FM servers.
>>
>> It is possible Lasso settings for the host are messed up and need  
>> to be deleted and re-entered.
>>
>> There is also the Lasso FMS9 Quick Start Guide which has some  
>> troubleshooting tips.
>>
>> --steve
>>
>> -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
>> Steve Piercy               Web Site Builder               Soquel, CA
>> <[hidden email]>                  <http://www.StevePiercy.com/>
>>
>>
>> --
>> This list is a free service of LassoSoft: http://www.LassoSoft.com/
>> Search the list archives: http://www.ListSearch.com/Lasso/Browse/
>> Manage your subscription: http://www.ListSearch.com/Lasso/
>>
>>
>
>
> --
> This list is a free service of LassoSoft: http://www.LassoSoft.com/
> Search the list archives: http://www.ListSearch.com/Lasso/Browse/
> Manage your subscription: http://www.ListSearch.com/Lasso/
>
>


--
This list is a free service of LassoSoft: http://www.LassoSoft.com/
Search the list archives: http://www.ListSearch.com/Lasso/Browse/
Manage your subscription: http://www.ListSearch.com/Lasso/


Reply | Threaded
Open this post in threaded view
|

Re: getting 802 error with FileMaker 10 custom web publishing

JP-14
Aren't strings in the database queries supposed to be in quotes?  The order number is alphanumeric.

jp


On Apr 19, 2010, at 7:35 PM, Tami Williams wrote:

> CORRECTION:
>
> If I increase the sleep between requests I get less errors (i.e. sleep 15 milliseconds, 100 requests = 3 errors, 0 millisconds sleep, 10 request = 3-4 errors).
>
> But most of the time I get at least one 802 error.
>
> (I thought 15 milliseconds worked for a sec b/c I got no errors, but on subsequent tests the errors re-appeared).
>
>
> On Apr 19, 2010, at 8:25 PM, Tami Williams wrote:
>
>> What SteveP suggested below is what's happening at http://print.imagers.com/FM_WPE_test.lasso.  You can run it and see that the error is happening 30-40% of the time.  That page has a 10 count loop on it, and the include_url has an error 3-4 times out of 10.
>>
>> At this point everything in the lasso and FileMaker guides has been tried and has not fixed this problem.
>>
>> I'm trying to see if anyone has experienced anything like this and how they solved it.
>>
>> Its kind of a deal killer - Lasso + FileMaker wise.
>>
>> NOTE: the error happens if you use a 0 millisecond sleep in the loop.  IF you change the sleep to 15 milliseconds the error doesn't happen.  Anyone see anything like this / have any ideas on how to fix it (beyond adding a 15 millisecond sleep to every search on the site)>
>>
>> Thanks in advance.
>>
>>
>>
>>
>> On Apr 16, 2010, at 8:16 PM, Steve Piercy - Web Site Builder wrote:
>>
>>> On 4/16/10 at 6:04 PM, [hidden email] (Tami Williams) pronounced:
>>>
>>>> Here's a test URL for you to see the error in action:
>>>>
>>>> http://order.imagers.com/FM_WPE_test.lasso   (I'll try to get and post the inline on this page soon.)
>>>>
>>>>
>>>> NOTE: they do NOT get this error when doing a request NOT using Lasso, i.e. just via FMI XML- like this
>>>>
>>>> http://hostname/fmi/xml/FMPXMLRESULT.xml?-db=DBNAME&[searchqueryhere]
>>>
>>> Yay for intermittent errors!
>>>
>>> Put the following into a Lasso page.  It will bypass any Lasso database settings and should yield the exact same results as if you used curl from the command line from the Lasso server.
>>>
>>> [loop(10)]
>>> <textarea>
>>> [include_url('http://hostname/fmi/xml/FMPXMLRESULT.xml?-db=DBNAME&[searchqueryhere]')]
>>> </textarea>
>>> [/loop]
>>>
>>> Textarea allows the XML result to be displayed inline.  Run this N times to see whether it is intermittent.
>>>
>>> It is possible that there is a flaky connection between the Lasso and FM servers.
>>>
>>> It is possible Lasso settings for the host are messed up and need to be deleted and re-entered.
>>>
>>> There is also the Lasso FMS9 Quick Start Guide which has some troubleshooting tips.
>>>
>>> --steve
>>>
>>> -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
>>> Steve Piercy               Web Site Builder               Soquel, CA
>>> <[hidden email]>                  <http://www.StevePiercy.com/>


--
This list is a free service of LassoSoft: http://www.LassoSoft.com/
Search the list archives: http://www.ListSearch.com/Lasso/Browse/
Manage your subscription: http://www.ListSearch.com/Lasso/


Reply | Threaded
Open this post in threaded view
|

Re: getting 802 error with FileMaker 10 custom web publishing

Ke Carlton-3
In reply to this post by Tami Williams-3
Ultimately it's not just Lasso that's affected by this - it's
everything the uses the WPE.

I ended up creating a custom container tag (fm_inline) with built in
error handling setup to automatically retry when FM choked it also
throttled the connections - maybe something like this might be an
option?

Ke

On 20 April 2010 01:35, Tami Williams <[hidden email]> wrote:

> CORRECTION:
>
> If I increase the sleep between requests I get less errors (i.e. sleep 15
> milliseconds, 100 requests = 3 errors, 0 millisconds sleep, 10 request = 3-4
> errors).
>
> But most of the time I get at least one 802 error.
>
> (I thought 15 milliseconds worked for a sec b/c I got no errors, but on
> subsequent tests the errors re-appeared).
>
>
> On Apr 19, 2010, at 8:25 PM, Tami Williams wrote:
>
>> What SteveP suggested below is what's happening at
>> http://print.imagers.com/FM_WPE_test.lasso.  You can run it and see that the
>> error is happening 30-40% of the time.  That page has a 10 count loop on it,
>> and the include_url has an error 3-4 times out of 10.
>>
>> At this point everything in the lasso and FileMaker guides has been tried
>> and has not fixed this problem.
>>
>> I'm trying to see if anyone has experienced anything like this and how
>> they solved it.
>>
>> Its kind of a deal killer - Lasso + FileMaker wise.
>>
>> NOTE: the error happens if you use a 0 millisecond sleep in the loop.  IF
>> you change the sleep to 15 milliseconds the error doesn't happen.  Anyone
>> see anything like this / have any ideas on how to fix it (beyond adding a 15
>> millisecond sleep to every search on the site)>
>>
>> Thanks in advance.
>>
>>
>>
>>
>> On Apr 16, 2010, at 8:16 PM, Steve Piercy - Web Site Builder wrote:
>>
>>> On 4/16/10 at 6:04 PM, [hidden email] (Tami Williams) pronounced:
>>>
>>>> Here's a test URL for you to see the error in action:
>>>>
>>>> http://order.imagers.com/FM_WPE_test.lasso   (I'll try to get and post
>>>> the inline on this page soon.)
>>>>
>>>>
>>>> NOTE: they do NOT get this error when doing a request NOT using Lasso,
>>>> i.e. just via FMI XML- like this
>>>>
>>>> http://hostname/fmi/xml/FMPXMLRESULT.xml?-db=DBNAME&[searchqueryhere]
>>>
>>> Yay for intermittent errors!
>>>
>>> Put the following into a Lasso page.  It will bypass any Lasso database
>>> settings and should yield the exact same results as if you used curl from
>>> the command line from the Lasso server.
>>>
>>> [loop(10)]
>>> <textarea>
>>>
>>> [include_url('http://hostname/fmi/xml/FMPXMLRESULT.xml?-db=DBNAME&[searchqueryhere]')]
>>> </textarea>
>>> [/loop]
>>>
>>> Textarea allows the XML result to be displayed inline.  Run this N times
>>> to see whether it is intermittent.
>>>
>>> It is possible that there is a flaky connection between the Lasso and FM
>>> servers.
>>>
>>> It is possible Lasso settings for the host are messed up and need to be
>>> deleted and re-entered.
>>>
>>> There is also the Lasso FMS9 Quick Start Guide which has some
>>> troubleshooting tips.
>>>
>>> --steve
>>>
>>> -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
>>> Steve Piercy               Web Site Builder               Soquel, CA
>>> <[hidden email]>                  <http://www.StevePiercy.com/>
>>>
>>>
>>> --
>>> This list is a free service of LassoSoft: http://www.LassoSoft.com/
>>> Search the list archives: http://www.ListSearch.com/Lasso/Browse/
>>> Manage your subscription: http://www.ListSearch.com/Lasso/
>>>
>>>
>>
>>
>> --
>> This list is a free service of LassoSoft: http://www.LassoSoft.com/
>> Search the list archives: http://www.ListSearch.com/Lasso/Browse/
>> Manage your subscription: http://www.ListSearch.com/Lasso/
>>
>>
>
>
> --
> This list is a free service of LassoSoft: http://www.LassoSoft.com/
> Search the list archives: http://www.ListSearch.com/Lasso/Browse/
> Manage your subscription: http://www.ListSearch.com/Lasso/
>
>
>

--
This list is a free service of LassoSoft: http://www.LassoSoft.com/
Search the list archives: http://www.ListSearch.com/Lasso/Browse/
Manage your subscription: http://www.ListSearch.com/Lasso/


Reply | Threaded
Open this post in threaded view
|

Re: getting 802 error with FileMaker 10 custom web publishing

Tami Williams-3
In reply to this post by Tami Williams-3
The saga continues.

I had the client do some more testing using the Terminal and curl  
command.    Just got the results.

Here's the curl command:

curl -v -u username:password 'http://10.0.0.11//fmi/xml/FMPXMLRESULT.xml?-db=Orders&-lay=CGI&-lop=and&imagers%20order%20number.op=bw&imagers%20order%20number=T482458&-max=50&-skip=0&-find'


Here's the results so far:

test using Terminal on 4 different machines

1: on his desktop, not running FMS or Lasso = no errors

2: on Lasso server (aka print.imagers.com)  = errors

3: on Lasso server (aka order.imagers.com) = errors

4: on FMS w/ WPE + Apache 2  = errors if  use localhost OR 10.0.0.11  
OR 127.0.0.1  in url in curl command!


ANY IDEAS?

Thanks in advance.





~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
"It's better to burn out than to fade away."

Tami Williams
Creative Computing
Let us help you make frustrating, costly, and inefficient processes  
more efficient, less costly and scalable.
FileMaker and Lasso specialists.

Tel: 770.457.3221
Fax: 770.454.7419
E-Mail: [hidden email]
Web: http://www.asktami.com/
LinkedIn: http://www.linkedin.com/in/asktami
Twitter: http://twitter.com/asktami
iChat/AIM/Skype: tamiwilliamsusa

FileMaker Solutions Alliance Associate | Lasso Professional Alliance  
Member

------

If you want to receive sporadic email from Creative Computing  
regarding news at the company and announcements about upcoming Lasso  
webinars and online classes, please opt-in at http://tinyurl.com/yj7eqlg


--
This list is a free service of LassoSoft: http://www.LassoSoft.com/
Search the list archives: http://www.ListSearch.com/Lasso/Browse/
Manage your subscription: http://www.ListSearch.com/Lasso/


Reply | Threaded
Open this post in threaded view
|

Re: getting 802 error with FileMaker 10 custom web publishing

Tim Taplin
is one of these machines actually 10.0.0.11?

Are the errors unique to this query or consistent thru a variety of queries?

on the lasso servers, are you running the curl command in terminal or thru the os_process command? or are you just referring to the test code from yesterday?

on the FMS machine, what address does not generate errors, it seems like you have covered the bases unless there is another ip on that machine. If there is another ip, is it possible to point lasso at that ip?

When I looked at your test form last night, it took 65-75 seconds or more to run even 4 or 5 queries when there weren't any errors, this seems odd to begin with. Was I just on at the wrong time or is this also part of your experience?

Tim Taplin

On Apr 20, 2010, at 2:56 PM, Tami Williams wrote:

> The saga continues.
>
> I had the client do some more testing using the Terminal and curl command.    Just got the results.
>
> Here's the curl command:
>
> curl -v -u username:password 'http://10.0.0.11//fmi/xml/FMPXMLRESULT.xml?-db=Orders&-lay=CGI&-lop=and&imagers%20order%20number.op=bw&imagers%20order%20number=T482458&-max=50&-skip=0&-find'
>
>
> Here's the results so far:
>
> test using Terminal on 4 different machines
>
> 1: on his desktop, not running FMS or Lasso = no errors
>
> 2: on Lasso server (aka print.imagers.com)  = errors
>
> 3: on Lasso server (aka order.imagers.com) = errors
>
> 4: on FMS w/ WPE + Apache 2  = errors if  use localhost OR 10.0.0.11 OR 127.0.0.1  in url in curl command!
>
>
> ANY IDEAS?
>
> Thanks in advance.
>
>
>
>
>
> ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
> "It's better to burn out than to fade away."
>
> Tami Williams
> Creative Computing
> Let us help you make frustrating, costly, and inefficient processes more efficient, less costly and scalable.
> FileMaker and Lasso specialists.
>
> Tel: 770.457.3221
> Fax: 770.454.7419
> E-Mail: [hidden email]
> Web: http://www.asktami.com/
> LinkedIn: http://www.linkedin.com/in/asktami
> Twitter: http://twitter.com/asktami
> iChat/AIM/Skype: tamiwilliamsusa
>
> FileMaker Solutions Alliance Associate | Lasso Professional Alliance Member
>
> ------
>
> If you want to receive sporadic email from Creative Computing regarding news at the company and announcements about upcoming Lasso webinars and online classes, please opt-in at http://tinyurl.com/yj7eqlg
>
>
> --
> This list is a free service of LassoSoft: http://www.LassoSoft.com/
> Search the list archives: http://www.ListSearch.com/Lasso/Browse/
> Manage your subscription: http://www.ListSearch.com/Lasso/
>
>


--
This list is a free service of LassoSoft: http://www.LassoSoft.com/
Search the list archives: http://www.ListSearch.com/Lasso/Browse/
Manage your subscription: http://www.ListSearch.com/Lasso/


Reply | Threaded
Open this post in threaded view
|

Re: getting 802 error with FileMaker 10 custom web publishing

Tami Williams-3
The FMS internal IP is 10.0.0.11.

The query is what's being used to test.  They've experienced errors  
with a variety of queries on the live web site.

The curl command is being run everywhere by opening the Terminal  
application and typing it in and hitting the return key.

On the FMS machine errors happen ALWAYS, no matter what you use:  
localhost, 10.0.0.11, or 127.0.0.1.

And, yes, sometimes it seems to be really slow to get a response back  
from the FMS.

Any ideas?  Like, why _on_the_FMS_ would you get errors doing the curl  
command?  That's just Terminal sending a command to the same machine!??

I'm going to have the client test (using the curl command) another  
query to this database and a different query to another database and  
see if the results are different.


Thanks in advance.


On Apr 20, 2010, at 5:32 PM, Tim Taplin wrote:

> is one of these machines actually 10.0.0.11?
>
> Are the errors unique to this query or consistent thru a variety of  
> queries?
>
> on the lasso servers, are you running the curl command in terminal  
> or thru the os_process command? or are you just referring to the  
> test code from yesterday?
>
> on the FMS machine, what address does not generate errors, it seems  
> like you have covered the bases unless there is another ip on that  
> machine. If there is another ip, is it possible to point lasso at  
> that ip?
>
> When I looked at your test form last night, it took 65-75 seconds or  
> more to run even 4 or 5 queries when there weren't any errors, this  
> seems odd to begin with. Was I just on at the wrong time or is this  
> also part of your experience?
>
> Tim Taplin
>
> On Apr 20, 2010, at 2:56 PM, Tami Williams wrote:
>
>> The saga continues.
>>
>> I had the client do some more testing using the Terminal and curl  
>> command.    Just got the results.
>>
>> Here's the curl command:
>>
>> curl -v -u username:password 'http://10.0.0.11//fmi/xml/FMPXMLRESULT.xml?-db=Orders&-lay=CGI&-lop=and&imagers%20order%20number.op=bw&imagers%20order%20number=T482458&-max=50&-skip=0&-find'
>>
>>
>> Here's the results so far:
>>
>> test using Terminal on 4 different machines
>>
>> 1: on his desktop, not running FMS or Lasso = no errors
>>
>> 2: on Lasso server (aka print.imagers.com)  = errors
>>
>> 3: on Lasso server (aka order.imagers.com) = errors
>>
>> 4: on FMS w/ WPE + Apache 2  = errors if  use localhost OR  
>> 10.0.0.11 OR 127.0.0.1  in url in curl command!
>>
>>
>> ANY IDEAS?
>>
>> Thanks in advance.
>>
>>
>>
>>
>>
>> ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
>> "It's better to burn out than to fade away."
>>
>> Tami Williams
>> Creative Computing
>> Let us help you make frustrating, costly, and inefficient processes  
>> more efficient, less costly and scalable.
>> FileMaker and Lasso specialists.
>>
>> Tel: 770.457.3221
>> Fax: 770.454.7419
>> E-Mail: [hidden email]
>> Web: http://www.asktami.com/
>> LinkedIn: http://www.linkedin.com/in/asktami
>> Twitter: http://twitter.com/asktami
>> iChat/AIM/Skype: tamiwilliamsusa
>>
>> FileMaker Solutions Alliance Associate | Lasso Professional  
>> Alliance Member
>>
>> ------
>>
>> If you want to receive sporadic email from Creative Computing  
>> regarding news at the company and announcements about upcoming  
>> Lasso webinars and online classes, please opt-in at http://tinyurl.com/yj7eqlg
>>
>>
>> --
>> This list is a free service of LassoSoft: http://www.LassoSoft.com/
>> Search the list archives: http://www.ListSearch.com/Lasso/Browse/
>> Manage your subscription: http://www.ListSearch.com/Lasso/
>>
>>
>
>
> --
> This list is a free service of LassoSoft: http://www.LassoSoft.com/
> Search the list archives: http://www.ListSearch.com/Lasso/Browse/
> Manage your subscription: http://www.ListSearch.com/Lasso/
>
>


--
This list is a free service of LassoSoft: http://www.LassoSoft.com/
Search the list archives: http://www.ListSearch.com/Lasso/Browse/
Manage your subscription: http://www.ListSearch.com/Lasso/


Reply | Threaded
Open this post in threaded view
|

Re: getting 802 error with FileMaker 10 custom web publishing ANSWER

Tami Williams-3
In reply to this post by Tim Taplin
Here's the answer for the archives.

Recap of original problem:

Client getting FileMaker 802 error 30-40% of the time. Using FileMaker  
Server 10 on Mac OS X Server 10.5 and Lasso 8.5.
802 means "can't open database". It can also refer to a permissions or  
security error when trying to configure a Web Publishing Engine.


Problem fixed! Here's how:

One of the very first things I had the client do was delete all  
layouts, except one (a simple one with no related fields on it), in  
the database where the error was reported when a search was done.  And  
then run the search again.

When they did that - have just one layout and do the same search - no  
errors were reported.  No matter how many times they did the search.

So, with all the layouts = error, with only 1 layout = no error.

So looking at the External Data Sources filepaths - there was an  
error. Instead of just file:FileName, there was:
fmnet:/*/FileName
file:FileName

Once the client fixed the External Data Sources filepaths (and went  
back to doing the search against a copy of the database that had all  
the layouts) the error went away.


So, it looks like a related field on one of the layouts in the  
database (that was using the bad External Data Sources filepaths) was  
causing the error.


Its been over a week since the fix and no more errors have been  
reported.


~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
"It's better to burn out than to fade away."

Tami Williams
Creative Computing
Let us help you make frustrating, costly, and inefficient processes  
more efficient, less costly and scalable.
FileMaker and Lasso specialists.

Tel: 770.457.3221
Fax: 770.454.7419
E-Mail: [hidden email]
Web: http://www.asktami.com/
LinkedIn: http://www.linkedin.com/in/asktami
Twitter: http://twitter.com/asktami
iChat/AIM/Skype: tamiwilliamsusa

FileMaker Solutions Alliance Associate | Lasso Professional Alliance  
Member

------

If you want to receive sporadic email from Creative Computing  
regarding news at the company and announcements about upcoming Lasso  
webinars and online classes, please opt-in at http://tinyurl.com/yj7eqlg


--
This list is a free service of LassoSoft: http://www.LassoSoft.com/
Search the list archives: http://www.ListSearch.com/Lasso/Browse/
Manage your subscription: http://www.ListSearch.com/Lasso/


Reply | Threaded
Open this post in threaded view
|

Re: getting 802 error with FileMaker 10 custom web publishing ANSWER

Johan Solve
Wow, thanks for sharing!

Odd file references can also be a source for performance issues, also
in the FM GUI, so it's always a good idea to make sure they are OK.

On Fri, Apr 30, 2010 at 12:12 AM, Tami Williams <[hidden email]> wrote:

> Here's the answer for the archives.
>
> Recap of original problem:
>
> Client getting FileMaker 802 error 30-40% of the time. Using FileMaker
> Server 10 on Mac OS X Server 10.5 and Lasso 8.5.
> 802 means "can't open database". It can also refer to a permissions or
> security error when trying to configure a Web Publishing Engine.
>
>
> Problem fixed! Here's how:
>
> One of the very first things I had the client do was delete all layouts,
> except one (a simple one with no related fields on it), in the database
> where the error was reported when a search was done.  And then run the
> search again.
>
> When they did that - have just one layout and do the same search - no errors
> were reported.  No matter how many times they did the search.
>
> So, with all the layouts = error, with only 1 layout = no error.
>
> So looking at the External Data Sources filepaths - there was an error.
> Instead of just file:FileName, there was:
> fmnet:/*/FileName
> file:FileName
>
> Once the client fixed the External Data Sources filepaths (and went back to
> doing the search against a copy of the database that had all the layouts)
> the error went away.
>
>
> So, it looks like a related field on one of the layouts in the database
> (that was using the bad External Data Sources filepaths) was causing the
> error.
>
>
> Its been over a week since the fix and no more errors have been reported.
>
>
> ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
> "It's better to burn out than to fade away."
>
> Tami Williams
> Creative Computing
> Let us help you make frustrating, costly, and inefficient processes more
> efficient, less costly and scalable.
> FileMaker and Lasso specialists.
>
> Tel: 770.457.3221
> Fax: 770.454.7419
> E-Mail: [hidden email]
> Web: http://www.asktami.com/
> LinkedIn: http://www.linkedin.com/in/asktami
> Twitter: http://twitter.com/asktami
> iChat/AIM/Skype: tamiwilliamsusa
>
> FileMaker Solutions Alliance Associate | Lasso Professional Alliance Member
>
> ------
>
> If you want to receive sporadic email from Creative Computing regarding news
> at the company and announcements about upcoming Lasso webinars and online
> classes, please opt-in at http://tinyurl.com/yj7eqlg
>
>
> --
> This list is a free service of LassoSoft: http://www.LassoSoft.com/
> Search the list archives: http://www.ListSearch.com/Lasso/Browse/
> Manage your subscription: http://www.ListSearch.com/Lasso/
>
>
>



--
Mvh
Johan Sölve
____________________________________
Montania System AB
Halmstad   Stockholm   Malmö
http://www.montania.se

Johan Sölve
Mobil +46 709-51 55 70
[hidden email]

Kristinebergsvägen 17, S-302 41 Halmstad, Sweden
Telefon +46 35-136800 |  Fax +46 35-136801

--
This list is a free service of LassoSoft: http://www.LassoSoft.com/
Search the list archives: http://www.ListSearch.com/Lasso/Browse/
Manage your subscription: http://www.ListSearch.com/Lasso/


Reply | Threaded
Open this post in threaded view
|

Re: getting 802 error with FileMaker 10 custom web publishing ANSWER

Ke Carlton-3
Ditto, thanks - will keep this in mind and pass this across to FM devs.

Fortunately / unfortunately we've already circumvented the WPE due to
instability and performance issues. Perhaps now and in future we have
another avenue for inquiry...

Ke

On 30 April 2010 09:17, Johan Solve <[hidden email]> wrote:
>
> Wow, thanks for sharing!

--
This list is a free service of LassoSoft: http://www.LassoSoft.com/
Search the list archives: http://www.ListSearch.com/Lasso/Browse/
Manage your subscription: http://www.ListSearch.com/Lasso/