get a lasso site pid on Mac OS X

classic Classic list List threaded Threaded
11 messages Options
Reply | Threaded
Open this post in threaded view
|

get a lasso site pid on Mac OS X

John Morris-3
Hello all,

I need to get the PID from a lasso site.
Running Mac OS 10.6.8, Lasso 8.5.6

I tried using the tag from tagswap: RD_lassoService_pid
But it's just giving me an error:  Lasso: Internal exception of unknown type.

All my lasso sites in the Activity Monitor just report: Lasso8Service
Any clues how I can get the pid of lasso site #2?

Thanks
 - John Morris

#############################################################
This message is sent to you because you are subscribed to
  the mailing list Lasso
[hidden email]
To unsubscribe, E-mail to: <[hidden email]>
Send administrative queries to  <[hidden email]>
Reply | Threaded
Open this post in threaded view
|

Re: get a lasso site pid on Mac OS X

stevepiercy
Do you have os_process installed and configured?

Try running the various commands within the tag directly in
Terminal with appropriate values.  Does that work?  If not, then
you might need to modify the command to work in your environment.

--steve


On 11/26/12 at 10:44 AM, [hidden email] (John
Morris) pronounced:

>Hello all,
>
>I need to get the PID from a lasso site.
>Running Mac OS 10.6.8, Lasso 8.5.6
>
>I tried using the tag from tagswap: RD_lassoService_pid
>But it's just giving me an error:  Lasso: Internal exception of unknown type.
>
>All my lasso sites in the Activity Monitor just report: Lasso8Service
>Any clues how I can get the pid of lasso site #2?
>
>Thanks
>- John Morris
>
>#############################################################
>This message is sent to you because you are subscribed to
>the mailing list Lasso
>[hidden email]
>To unsubscribe, E-mail to: <[hidden email]>
>Send administrative queries to  <[hidden email]>

-- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
-- --
Steve Piercy               Web Site Builder              
Soquel, CA
<[hidden email]>                  <http://www.StevePiercy.com/>

#############################################################
This message is sent to you because you are subscribed to
  the mailing list Lasso
[hidden email]
To unsubscribe, E-mail to: <[hidden email]>
Send administrative queries to  <[hidden email]>
Reply | Threaded
Open this post in threaded view
|

Re: get a lasso site pid on Mac OS X

Marc Vos
In reply to this post by John Morris-3
Maybe this is a tag you can use?

http://www.lassosoft.com/tagswap/detail/mv_findThread

- -
Regards,
Marc

Sent from my iPhone

On 26 nov. 2012, at 17:44, John Morris <[hidden email]> wrote:

> Hello all,
>
> I need to get the PID from a lasso site.
> Running Mac OS 10.6.8, Lasso 8.5.6
>
> I tried using the tag from tagswap: RD_lassoService_pid
> But it's just giving me an error:  Lasso: Internal exception of unknown type.
>
> All my lasso sites in the Activity Monitor just report: Lasso8Service
> Any clues how I can get the pid of lasso site #2?
>
> Thanks
> - John Morris
>
> #############################################################
> This message is sent to you because you are subscribed to
>  the mailing list Lasso
> [hidden email]
> To unsubscribe, E-mail to: <[hidden email]>
> Send administrative queries to  <[hidden email]>
#############################################################
This message is sent to you because you are subscribed to
  the mailing list Lasso
[hidden email]
To unsubscribe, E-mail to: <[hidden email]>
Send administrative queries to  <[hidden email]>
Reply | Threaded
Open this post in threaded view
|

Re: get a lasso site pid on Mac OS X

stevepiercy
How does your tag distinguish between various Lasso sites, e.g.
"give me the pid of Lasso Site 2"?

--steve


On 11/26/12 at 8:20 PM, [hidden email] (Marc Vos) pronounced:

>Maybe this is a tag you can use?
>
>http://www.lassosoft.com/tagswap/detail/mv_findThread
>
>- -
>Regards,
>Marc
>
>Sent from my iPhone
>
>On 26 nov. 2012, at 17:44, John Morris <[hidden email]> wrote:
>
>>Hello all,
>>
>>I need to get the PID from a lasso site.
>>Running Mac OS 10.6.8, Lasso 8.5.6
>>
>>I tried using the tag from tagswap: RD_lassoService_pid
>>But it's just giving me an error:  Lasso: Internal exception of unknown type.
>>
>>All my lasso sites in the Activity Monitor just report: Lasso8Service
>>Any clues how I can get the pid of lasso site #2?
>>
>>Thanks
>>- John Morris
>>
>>#############################################################
>>This message is sent to you because you are subscribed to
>>the mailing list Lasso
>>[hidden email]
>>To unsubscribe, E-mail to: <[hidden email]>
>>Send administrative queries to  <[hidden email]>
>#############################################################
>This message is sent to you because you are subscribed to
>the mailing list Lasso
>[hidden email]
>To unsubscribe, E-mail to: <[hidden email]>
>Send administrative queries to  <[hidden email]>

-- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
-- --
Steve Piercy               Web Site Builder              
Soquel, CA
<[hidden email]>                  <http://www.StevePiercy.com/>

#############################################################
This message is sent to you because you are subscribed to
  the mailing list Lasso
[hidden email]
To unsubscribe, E-mail to: <[hidden email]>
Send administrative queries to  <[hidden email]>
Reply | Threaded
Open this post in threaded view
|

Re: get a lasso site pid on Mac OS X

John Morris-3
In reply to this post by stevepiercy
I took the code out of the tag, and ran it in os_process buy itself.
That got me the pid I was looking for.

        os_process('/bin/bash', (:'-c', 'ps -o pid,command -au lasso | grep [l]assosite_2 | awk \'{print $1}\''))->readString;

Thanks

 - John Morris

On Nov 26, 2012, at 1:16 PM, Steve Piercy - Web Site Builder wrote:

> Do you have os_process installed and configured?
>
> Try running the various commands within the tag directly in Terminal with appropriate values.  Does that work?  If not, then you might need to modify the command to work in your environment.
>
> --steve
>
>
> On 11/26/12 at 10:44 AM, [hidden email] (John Morris) pronounced:
>
>> Hello all,
>>
>> I need to get the PID from a lasso site.
>> Running Mac OS 10.6.8, Lasso 8.5.6
>>
>> I tried using the tag from tagswap: RD_lassoService_pid
>> But it's just giving me an error:  Lasso: Internal exception of unknown type.
>>
>> All my lasso sites in the Activity Monitor just report: Lasso8Service
>> Any clues how I can get the pid of lasso site #2?
>>
>> Thanks
>> - John Morris
>>
>> #############################################################
>> This message is sent to you because you are subscribed to
>> the mailing list Lasso
>> [hidden email]
>> To unsubscribe, E-mail to: <[hidden email]>
>> Send administrative queries to  <[hidden email]>
>
> -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
> Steve Piercy               Web Site Builder               Soquel, CA
> <[hidden email]>                  <http://www.StevePiercy.com/>
>
> #############################################################
> This message is sent to you because you are subscribed to
> the mailing list Lasso
> [hidden email]
> To unsubscribe, E-mail to: <[hidden email]>
> Send administrative queries to  <[hidden email]>

#############################################################
This message is sent to you because you are subscribed to
  the mailing list Lasso
[hidden email]
To unsubscribe, E-mail to: <[hidden email]>
Send administrative queries to  <[hidden email]>
Reply | Threaded
Open this post in threaded view
|

Re: get a lasso site pid on Mac OS X

Wade Maxfield
In reply to this post by John Morris-3
On 27/11/2012, at 5:44 AM, John Morris <[hidden email]> wrote:

> Hello all,
>
> I need to get the PID from a lasso site.
> Running Mac OS 10.6.8, Lasso 8.5.6
>
> I tried using the tag from tagswap: RD_lassoService_pid
> But it's just giving me an error:  Lasso: Internal exception of unknown type.
>
> All my lasso sites in the Activity Monitor just report: Lasso8Service
> Any clues how I can get the pid of lasso site #2?
>
> Thanks
> - John Morris


It should work on your setup, I'm running it on 10.5, 10.6 and 10.7 at the moment.  I have mine installed in the main LassoStartup folder so it's available across all sites.  Did you put yours in a site specific LassoStartup folder?  

Oh, I've got a newer version that handles 8.5 or 8.6 but I don't have 8.6 installed on any of my machines.  Anyone on 8.6 available to test it for me?

 - Wade


#############################################################
This message is sent to you because you are subscribed to
  the mailing list Lasso
[hidden email]
To unsubscribe, E-mail to: <[hidden email]>
Send administrative queries to  <[hidden email]>
Reply | Threaded
Open this post in threaded view
|

Re: get a lasso site pid on Mac OS X

stevepiercy
On 11/27/12 at 12:44 PM, [hidden email] (Wade
Maxfield) pronounced:

>On 27/11/2012, at 5:44 AM, John Morris <[hidden email]> wrote:
>
>>Hello all,
>>
>>I need to get the PID from a lasso site.
>>Running Mac OS 10.6.8, Lasso 8.5.6
>>
>>I tried using the tag from tagswap: RD_lassoService_pid
>>But it's just giving me an error:  Lasso: Internal exception of unknown type.
>>
>>All my lasso sites in the Activity Monitor just report: Lasso8Service
>>Any clues how I can get the pid of lasso site #2?
>>
>>Thanks
>>- John Morris
>
>
>It should work on your setup, I'm running it on 10.5, 10.6 and
>10.7 at the moment.  I have mine installed in the main
>LassoStartup folder so it's available across all sites.  Did
>you put yours in a site specific LassoStartup folder?
>Oh, I've got a newer version that handles 8.5 or 8.6 but I
>don't have 8.6 installed on any of my machines.  Anyone on 8.6
>available to test it for me?

Yup, Marc Pinnell and I both went through this for 8.6 and there
are some differences.  He commented on your tag and I commented
on the article for monit.  CentOS, though, but that doesn't
matter too much.

http://www.lassosoft.com/Monitoring-Lasso-with-Monit
http://www.lassosoft.com/tagswap/detail/RD_lassoService_pid

--steve

-- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
-- --
Steve Piercy               Web Site Builder              
Soquel, CA
<[hidden email]>                  <http://www.StevePiercy.com/>

#############################################################
This message is sent to you because you are subscribed to
  the mailing list Lasso
[hidden email]
To unsubscribe, E-mail to: <[hidden email]>
Send administrative queries to  <[hidden email]>
Reply | Threaded
Open this post in threaded view
|

Re: get a lasso site pid on Mac OS X

John Morris-3
In reply to this post by Wade Maxfield
It's not installed in any startup folder, just defined on a page that I needed it on.
It did work in 9, but I still can't get ti to work in 8.5.

I'll be trimming it down today to see what's making it break in 8.5.6

 - John Morris

On Nov 26, 2012, at 5:44 PM, Wade Maxfield wrote:

> On 27/11/2012, at 5:44 AM, John Morris <[hidden email]> wrote:
>
>> Hello all,
>>
>> I need to get the PID from a lasso site.
>> Running Mac OS 10.6.8, Lasso 8.5.6
>>
>> I tried using the tag from tagswap: RD_lassoService_pid
>> But it's just giving me an error:  Lasso: Internal exception of unknown type.
>>
>> All my lasso sites in the Activity Monitor just report: Lasso8Service
>> Any clues how I can get the pid of lasso site #2?
>>
>> Thanks
>> - John Morris
>
>
> It should work on your setup, I'm running it on 10.5, 10.6 and 10.7 at the moment.  I have mine installed in the main LassoStartup folder so it's available across all sites.  Did you put yours in a site specific LassoStartup folder?  
>
> Oh, I've got a newer version that handles 8.5 or 8.6 but I don't have 8.6 installed on any of my machines.  Anyone on 8.6 available to test it for me?
>
> - Wade
>
>
> #############################################################
> This message is sent to you because you are subscribed to
>  the mailing list Lasso
> [hidden email]
> To unsubscribe, E-mail to: <[hidden email]>
> Send administrative queries to  <[hidden email]>

#############################################################
This message is sent to you because you are subscribed to
  the mailing list Lasso
[hidden email]
To unsubscribe, E-mail to: <[hidden email]>
Send administrative queries to  <[hidden email]>
Reply | Threaded
Open this post in threaded view
|

Re: get a lasso site pid on Mac OS X

Marc Vos
In reply to this post by stevepiercy
The idea was to use the code as a starting point.

- -
Marc

Sent from my iPhone

On 26 nov. 2012, at 20:43, Steve Piercy - Web Site Builder <[hidden email]> wrote:

> How does your tag distinguish between various Lasso sites, e.g. "give me the pid of Lasso Site 2"?
>
> --steve
>
>
> On 11/26/12 at 8:20 PM, [hidden email] (Marc Vos) pronounced:
>
>> Maybe this is a tag you can use?
>>
>> http://www.lassosoft.com/tagswap/detail/mv_findThread
>>
>> - -
>> Regards,
>> Marc
>>
>> Sent from my iPhone
>>
>> On 26 nov. 2012, at 17:44, John Morris <[hidden email]> wrote:
>>
>>> Hello all,
>>>
>>> I need to get the PID from a lasso site.
>>> Running Mac OS 10.6.8, Lasso 8.5.6
>>>
>>> I tried using the tag from tagswap: RD_lassoService_pid
>>> But it's just giving me an error:  Lasso: Internal exception of unknown type.
>>>
>>> All my lasso sites in the Activity Monitor just report: Lasso8Service
>>> Any clues how I can get the pid of lasso site #2?
>>>
>>> Thanks
>>> - John Morris
>>>
>>> #############################################################
>>> This message is sent to you because you are subscribed to
>>> the mailing list Lasso
>>> [hidden email]
>>> To unsubscribe, E-mail to: <[hidden email]>
>>> Send administrative queries to  <[hidden email]>
>> #############################################################
>> This message is sent to you because you are subscribed to
>> the mailing list Lasso
>> [hidden email]
>> To unsubscribe, E-mail to: <[hidden email]>
>> Send administrative queries to  <[hidden email]>
>
> -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
> Steve Piercy               Web Site Builder               Soquel, CA
> <[hidden email]>                  <http://www.StevePiercy.com/>
>
> #############################################################
> This message is sent to you because you are subscribed to
> the mailing list Lasso
> [hidden email]
> To unsubscribe, E-mail to: <[hidden email]>
> Send administrative queries to  <[hidden email]>
#############################################################
This message is sent to you because you are subscribed to
  the mailing list Lasso
[hidden email]
To unsubscribe, E-mail to: <[hidden email]>
Send administrative queries to  <[hidden email]>
Reply | Threaded
Open this post in threaded view
|

Re: get a lasso site pid on Mac OS X

Wade Maxfield
In reply to this post by John Morris-3
On 28/11/2012, at 2:29 AM, John Morris <[hidden email]> wrote:

> It's not installed in any startup folder, just defined on a page that I needed it on.
> It did work in 9, but I still can't get ti to work in 8.5.
>
> I'll be trimming it down today to see what's making it break in 8.5.6

It's built to live in the main LassoStartup folder.  There's no authorisation explicitly setup for the OS_Process part of it, so it inherits that when it got loaded, hence using the main LassoStartup folder for system level privileges.  Plus the .pid is useful for processes outside of Lasso and I needed those as soon as Lasso started loading, so LassoStartup folder again.  8)

 - Wade


#############################################################
This message is sent to you because you are subscribed to
  the mailing list Lasso
[hidden email]
To unsubscribe, E-mail to: <[hidden email]>
Send administrative queries to  <[hidden email]>
Reply | Threaded
Open this post in threaded view
|

Re: get a lasso site pid on Mac OS X

Wade Maxfield
In reply to this post by stevepiercy
On 27/11/2012, at 10:32 PM, Steve Piercy - Web Site Builder <[hidden email]> wrote:

> Yup, Marc Pinnell and I both went through this for 8.6 and there are some differences.  He commented on your tag and I commented on the article for monit.  CentOS, though, but that doesn't matter too much.
>
> http://www.lassosoft.com/Monitoring-Lasso-with-Monit
> http://www.lassosoft.com/tagswap/detail/RD_lassoService_pid
>

Yeah, I took the _8.6 tweak and added that to a conditional based on Lasso_Version. Should run on 8.5 or 8.6 with no need for tweaking during installation.
But I don't have 8.6 on any machine to test it with, so haven't uploaded the new version to TagSwap yet.

 - Wade


 
#############################################################
This message is sent to you because you are subscribed to
  the mailing list Lasso
[hidden email]
To unsubscribe, E-mail to: <[hidden email]>
Send administrative queries to  <[hidden email]>