Quantcast

client_url or client_ip issue

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

client_url or client_ip issue

Stephen Smiroldo-4
Have any of you experienced an error similar to the following:

error: No tag, type or constant was defined under the name "봀⯭孼䪉Дenews秜£ž at: GetArg

or…

error: No tag, type or constant was defined under the name "茐㟎孼䪉ȅ_46797 at: GetArgs


If the site experiences this problem it’s specific to the client_url or client_ip tags and will often preclude a disconnect between Lasso and MySQL. I’m on IIS 7.5 and Lasso 8.6.


Thanks,
Stephen


#############################################################

This message is sent to you because you are subscribed to
  the mailing list Lasso [hidden email]
Official list archives available at http://www.lassotalk.com
To unsubscribe, E-mail to: <[hidden email]>
Send administrative queries to  <[hidden email]>
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: client_url or client_ip issue

Marc Vos-3
I have had lots of these ...

It means that you have
a.1) to stop Lasso, because it has memory problems
a.2) remove or rename lassoerrors.txt in your instance-folder, i.e. default/
a.3) start Lasso

b) Look for jobs in Lasso's event-scheduler and:
- Run them interactively to see if there are any errors
- Get them out of there and add a 'wget'-statement to cron to run your batch-pages, or recode them in PHP (that's what I did) and add these to cron.

The less you use the event-scheduler and the less errors you have in your code, the less of these chinese-messages you'll get.

- -
Regards,
Marc


On 10-06-2016 14:50, "Stephen Smiroldo" <[hidden email] on behalf of [hidden email]> wrote:

>Have any of you experienced an error similar to the following:
>
>error: No tag, type or constant was defined under the name "봀⯭孼䪉Дenews秜£ž at: GetArg
>
>or…
>
>error: No tag, type or constant was defined under the name "茐㟎孼䪉ȅ_46797 at: GetArgs
>
>
>If the site experiences this problem it’s specific to the client_url or client_ip tags and will often preclude a disconnect between Lasso and MySQL. I’m on IIS 7.5 and Lasso 8.6.
>
>
>Thanks,
>Stephen
>
>
>#############################################################
>
>This message is sent to you because you are subscribed to
>  the mailing list Lasso [hidden email]
>Official list archives available at http://www.lassotalk.com
>To unsubscribe, E-mail to: <[hidden email]>
>Send administrative queries to  <[hidden email]>



#############################################################

This message is sent to you because you are subscribed to
  the mailing list Lasso [hidden email]
Official list archives available at http://www.lassotalk.com
To unsubscribe, E-mail to: <[hidden email]>
Send administrative queries to  <[hidden email]>
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: client_url or client_ip issue

Stephen Smiroldo-4
Thanks Marc!


> On Jun 10, 2016, at 9:27 AM, Marc Vos <[hidden email]> wrote:
>
> I have had lots of these ...
>
> It means that you have
> a.1) to stop Lasso, because it has memory problems
> a.2) remove or rename lassoerrors.txt in your instance-folder, i.e. default/
> a.3) start Lasso
>
> b) Look for jobs in Lasso's event-scheduler and:
> - Run them interactively to see if there are any errors
> - Get them out of there and add a 'wget'-statement to cron to run your batch-pages, or recode them in PHP (that's what I did) and add these to cron.
>
> The less you use the event-scheduler and the less errors you have in your code, the less of these chinese-messages you'll get.
>
> - -
> Regards,
> Marc
>
>
> On 10-06-2016 14:50, "Stephen Smiroldo" <[hidden email] on behalf of [hidden email]> wrote:
>
>> Have any of you experienced an error similar to the following:
>>
>> error: No tag, type or constant was defined under the name "봀⯭孼䪉Дenews秜£ž at: GetArg
>>
>> or…
>>
>> error: No tag, type or constant was defined under the name "茐㟎孼䪉ȅ_46797 at: GetArgs
>>
>>
>> If the site experiences this problem it’s specific to the client_url or client_ip tags and will often preclude a disconnect between Lasso and MySQL. I’m on IIS 7.5 and Lasso 8.6.
>>
>>
>> Thanks,
>> Stephen
>>
>>
>> #############################################################
>>
>> This message is sent to you because you are subscribed to
>> the mailing list Lasso [hidden email]
>> Official list archives available at http://www.lassotalk.com
>> To unsubscribe, E-mail to: <[hidden email]>
>> Send administrative queries to  <[hidden email]>
>
>
>
> #############################################################
>
> This message is sent to you because you are subscribed to
>  the mailing list Lasso [hidden email]
> Official list archives available at http://www.lassotalk.com
> To unsubscribe, E-mail to: <[hidden email]>
> Send administrative queries to  <[hidden email]>


#############################################################

This message is sent to you because you are subscribed to
  the mailing list Lasso [hidden email]
Official list archives available at http://www.lassotalk.com
To unsubscribe, E-mail to: <[hidden email]>
Send administrative queries to  <[hidden email]>
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

RE: client_url or client_ip issue

Jon Harris
We have had lots of these too.

We found the "solution" was to restart the Lasso Process.

Also, make sure you are the latest Lasso 8.6.3, which seems less prone to them.

You can restart Lasso with a simple batch file:
echo off
cls
echo Stopping Lasso Service
net stop lasso8service
Echo Starting Lasso Service
net start lasso8service



-----Original Message-----
From: [hidden email] [mailto:[hidden email]] On Behalf Of Stephen Smiroldo
Sent: 10 June 2016 15:00
To: [hidden email]
Subject: Re: client_url or client_ip issue

Thanks Marc!


> On Jun 10, 2016, at 9:27 AM, Marc Vos <[hidden email]> wrote:
>
> I have had lots of these ...
>
> It means that you have
> a.1) to stop Lasso, because it has memory problems
> a.2) remove or rename lassoerrors.txt in your instance-folder, i.e.
> default/
> a.3) start Lasso
>
> b) Look for jobs in Lasso's event-scheduler and:
> - Run them interactively to see if there are any errors
> - Get them out of there and add a 'wget'-statement to cron to run your batch-pages, or recode them in PHP (that's what I did) and add these to cron.
>
> The less you use the event-scheduler and the less errors you have in your code, the less of these chinese-messages you'll get.
>
> - -
> Regards,
> Marc
>
>
> On 10-06-2016 14:50, "Stephen Smiroldo" <[hidden email] on behalf of [hidden email]> wrote:
>
>> Have any of you experienced an error similar to the following:
>>
>> error: No tag, type or constant was defined under the name
>> "봀⯭孼䪉Дenews秜£ž at: GetArg
>>
>> or…
>>
>> error: No tag, type or constant was defined under the name
>> "茐㟎孼䪉ȅ_46797 at: GetArgs
>>
>>
>> If the site experiences this problem it’s specific to the client_url or client_ip tags and will often preclude a disconnect between Lasso and MySQL. I’m on IIS 7.5 and Lasso 8.6.
>>
>>
>> Thanks,
>> Stephen
>>
>>
>> #############################################################
>>
>> This message is sent to you because you are subscribed to the mailing
>> list Lasso [hidden email] Official list archives available
>> at http://www.lassotalk.com To unsubscribe, E-mail to:
>> <[hidden email]>
>> Send administrative queries to  <[hidden email]>
>
>
>
> #############################################################
>
> This message is sent to you because you are subscribed to  the mailing
> list Lasso [hidden email] Official list archives available
> at http://www.lassotalk.com To unsubscribe, E-mail to:
> <[hidden email]>
> Send administrative queries to  <[hidden email]>


#############################################################

This message is sent to you because you are subscribed to
  the mailing list Lasso [hidden email] Official list archives available at http://www.lassotalk.com To unsubscribe, E-mail to: <[hidden email]>
Send administrative queries to  <[hidden email]>

#############################################################

This message is sent to you because you are subscribed to
  the mailing list Lasso [hidden email]
Official list archives available at http://www.lassotalk.com
To unsubscribe, E-mail to: <[hidden email]>
Send administrative queries to  <[hidden email]>
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Client_IP behind load balancer

Roy Dacke
We are trying to use the Client_IP tag but behind an HAProxy load balancer. Maybe that’s not the right tool for this case.

Is there a way to capture the X-Forwarded-For header in Lasso 8.6.3 rather than the IP address of the load balancer?

Thanks,

Roy Dacke
[hidden email]
System Administration
Webstop


#############################################################

This message is sent to you because you are subscribed to
  the mailing list Lasso [hidden email]
Official list archives available at http://www.lassotalk.com
To unsubscribe, E-mail to: <[hidden email]>
Send administrative queries to  <[hidden email]>
Loading...