Understanding OS_Process error message (L8.6 / Win)

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Understanding OS_Process error message (L8.6 / Win)

Jim de Zwart-2
I've never used OS_Process before. I'm trying to use cURL (on Windows,
yes, it is installed, I can use it from the commandline). Lasso is
throwing me this error, and I'm not sure how to go about troubleshooting
this one:

No process is open for reading.
at: readerror

Is OS_Process having trouble connection to cURL entirely?

Some background information, I'm modifying a version of Fletcher's
Constant Contact Rest API (thanks, Fletcher!) integration, to use with a
Mashape API implementation for ShipStation.

I'm going to try some simple OS_Process tests, to gain some knowledge on
the subject, but in the mean time, I'd welcome any tips on the subject.

Thank You!

#############################################################

This message is sent to you because you are subscribed to
  the mailing list Lasso [hidden email]
Official list archives available at http://www.lassotalk.com
To unsubscribe, E-mail to: <[hidden email]>
Send administrative queries to  <[hidden email]>
Reply | Threaded
Open this post in threaded view
|

Re: Understanding OS_Process error message (L8.6 / Win)

stevepiercy
First I presume this is Lasso 8.6, correct?

Try issuing any other command, like:

echo 'moosehair'
=>
moosehair

If the output does not match, then it may be either an
installation problem or Lasso Admin security settings problem
for os_process.  Double check that you have followed the
instructions in the readme and the Language Guide.

If a simple command works, then you can try using:

     os_process->readerror

Otherwise, errors returned by os_process can be searched, like so:

     curl No process is open for reading.

Unfortunately the results are not very helpful.

--steve


On 10/17/14 at 3:09 PM, [hidden email] (Jim de Zwart) pronounced:

>I've never used OS_Process before. I'm trying to use cURL (on
>Windows, yes, it is installed, I can use it from the
>commandline). Lasso is throwing me this error, and I'm not sure
>how to go about troubleshooting this one:
>
>No process is open for reading.
>at: readerror
>
>Is OS_Process having trouble connection to cURL entirely?
>
>Some background information, I'm modifying a version of
>Fletcher's Constant Contact Rest API (thanks, Fletcher!)
>integration, to use with a Mashape API implementation for ShipStation.
>
>I'm going to try some simple OS_Process tests, to gain some
>knowledge on the subject, but in the mean time, I'd welcome any
>tips on the subject.
>
>Thank You!
>
>#############################################################
>
>This message is sent to you because you are subscribed to
>the mailing list Lasso [hidden email]
>Official list archives available at http://www.lassotalk.com
>To unsubscribe, E-mail to: <[hidden email]>
>Send administrative queries to  <[hidden email]>

-- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
Steve Piercy              Website Builder              Soquel, CA
<[hidden email]>               <http://www.StevePiercy.com/>


#############################################################

This message is sent to you because you are subscribed to
  the mailing list Lasso [hidden email]
Official list archives available at http://www.lassotalk.com
To unsubscribe, E-mail to: <[hidden email]>
Send administrative queries to  <[hidden email]>
Reply | Threaded
Open this post in threaded view
|

Re: Understanding OS_Process error message (L8.6 / Win)

Bil Corry-3
In reply to this post by Jim de Zwart-2
I suggest trying Jason Huck's shell tag:

http://www.lassosoft.com/tagswap/detail/shell

I vaguely recall having to tweak it to get it to work on Windows, but it
was a long time ago.  The shell tag will make it easy to call curl:

shell('curl --params --go --here');

Pier gave a talk about command-line, you might be interested to read
through it:

http://www.lassosoft.com/Command-Line-via-Lasso



- Bil


On Sat, Oct 18, 2014 at 12:09 AM, Jim de Zwart <[hidden email]>
wrote:

> I've never used OS_Process before. I'm trying to use cURL (on Windows,
> yes, it is installed, I can use it from the commandline). Lasso is throwing
> me this error, and I'm not sure how to go about troubleshooting this one:
>
> No process is open for reading.
> at: readerror
>
> Is OS_Process having trouble connection to cURL entirely?
>
> Some background information, I'm modifying a version of Fletcher's
> Constant Contact Rest API (thanks, Fletcher!) integration, to use with a
> Mashape API implementation for ShipStation.
>
> I'm going to try some simple OS_Process tests, to gain some knowledge on
> the subject, but in the mean time, I'd welcome any tips on the subject.
>
> Thank You!
>
> #############################################################
>
> This message is sent to you because you are subscribed to
>  the mailing list Lasso [hidden email]
> Official list archives available at http://www.lassotalk.com
> To unsubscribe, E-mail to: <[hidden email]>
> Send administrative queries to  <[hidden email]>
>

#############################################################

This message is sent to you because you are subscribed to
  the mailing list Lasso [hidden email]
Official list archives available at http://www.lassotalk.com
To unsubscribe, E-mail to: <[hidden email]>
Send administrative queries to  <[hidden email]>