Setting up a mysql datasource on Lasso Lux

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

Setting up a mysql datasource on Lasso Lux

Anibal Escobar
Hi, I’m using Lux 1.0, Lasso 9.3.1 on Linux.  I’m trying to set up a mysql datasource, but when I enter the information, which I believe to be correct in the New Host: MySQL window, I get the following error:

Connection using old (pre-4.1.1) authentication protocol refused (client option 'secure_auth' enabled)

Can anyone point me in the right direction to getting past this error?

Thanks,
Anibal Escobar
646 502 8821






#############################################################

This message is sent to you because you are subscribed to
  the mailing list Lasso [hidden email]
Official list archives available at http://www.lassotalk.com
To unsubscribe, E-mail to: <[hidden email]>
Send administrative queries to  <[hidden email]>
Reply | Threaded
Open this post in threaded view
|

Re: Setting up a mysql datasource on Lasso Lux

Anibal Escobar
I should add that this is being done on a server that is running 8.6 and 9.3 side by side.  I have the 8.6 communicating with MySQL.

Thanks,
Anibal Escobar
646 502 8821





> On Nov 29, 2015, at 4:48 PM, Anibal Escobar <[hidden email]> wrote:
>
> Hi, I’m using Lux 1.0, Lasso 9.3.1 on Linux.  I’m trying to set up a mysql datasource, but when I enter the information, which I believe to be correct in the New Host: MySQL window, I get the following error:
>
> Connection using old (pre-4.1.1) authentication protocol refused (client option 'secure_auth' enabled)
>
> Can anyone point me in the right direction to getting past this error?
>
> Thanks,
> Anibal Escobar
> 646 502 8821
>
>
>
>
>
>
> #############################################################
>
> This message is sent to you because you are subscribed to
>  the mailing list Lasso [hidden email]
> Official list archives available at http://www.lassotalk.com
> To unsubscribe, E-mail to: <[hidden email]>
> Send administrative queries to  <[hidden email]>


#############################################################

This message is sent to you because you are subscribed to
  the mailing list Lasso [hidden email]
Official list archives available at http://www.lassotalk.com
To unsubscribe, E-mail to: <[hidden email]>
Send administrative queries to  <[hidden email]>
Reply | Threaded
Open this post in threaded view
|

Re: Setting up a mysql datasource on Lasso Lux

Anibal Escobar
On last thing on this, I’m running MySQL 5.1.73 and the environmental variable secure_auth is set to OFF.

Thanks,
Anibal Escobar
646 502 8821





> On Nov 29, 2015, at 5:03 PM, Anibal Escobar <[hidden email]> wrote:
>
> I should add that this is being done on a server that is running 8.6 and 9.3 side by side.  I have the 8.6 communicating with MySQL.
>
> Thanks,
> Anibal Escobar
> 646 502 8821
>
>
>
>
>
>> On Nov 29, 2015, at 4:48 PM, Anibal Escobar <[hidden email]> wrote:
>>
>> Hi, I’m using Lux 1.0, Lasso 9.3.1 on Linux.  I’m trying to set up a mysql datasource, but when I enter the information, which I believe to be correct in the New Host: MySQL window, I get the following error:
>>
>> Connection using old (pre-4.1.1) authentication protocol refused (client option 'secure_auth' enabled)
>>
>> Can anyone point me in the right direction to getting past this error?
>>
>> Thanks,
>> Anibal Escobar
>> 646 502 8821
>>
>>
>>
>>
>>
>>
>> #############################################################
>>
>> This message is sent to you because you are subscribed to
>> the mailing list Lasso [hidden email]
>> Official list archives available at http://www.lassotalk.com
>> To unsubscribe, E-mail to: <[hidden email]>
>> Send administrative queries to  <[hidden email]>
>
>
> #############################################################
>
> This message is sent to you because you are subscribed to
>  the mailing list Lasso [hidden email]
> Official list archives available at http://www.lassotalk.com
> To unsubscribe, E-mail to: <[hidden email]>
> Send administrative queries to  <[hidden email]>


#############################################################

This message is sent to you because you are subscribed to
  the mailing list Lasso [hidden email]
Official list archives available at http://www.lassotalk.com
To unsubscribe, E-mail to: <[hidden email]>
Send administrative queries to  <[hidden email]>
Reply | Threaded
Open this post in threaded view
|

Re: Setting up a mysql datasource on Lasso Lux

Jolle Carlestam-2
In reply to this post by Anibal Escobar
29 nov 2015 kl. 22:48 skrev Anibal Escobar <[hidden email]>:
>
> Hi, I’m using Lux 1.0, Lasso 9.3.1 on Linux.  I’m trying to set up a mysql datasource, but when I enter the information, which I believe to be correct in the New Host: MySQL window, I get the following error:
>
> Connection using old (pre-4.1.1) authentication protocol refused (client option 'secure_auth' enabled)
>
> Can anyone point me in the right direction to getting past this error?

Beats me.
I’ve had no issues connecting to Mysql on Linux with 9.3 (or 9.3.1).

Did a check on my secure_auth setting and found that it on one Linux machine is set to OFF, although that machine is running 9.2. On the other Linux, running 9.3, it is set to ON.
My local OS X machine running 9.3.1 is also set to ON.

HDB
Jolle

#############################################################

This message is sent to you because you are subscribed to
  the mailing list Lasso [hidden email]
Official list archives available at http://www.lassotalk.com
To unsubscribe, E-mail to: <[hidden email]>
Send administrative queries to  <[hidden email]>
Reply | Threaded
Open this post in threaded view
|

Re: Setting up a mysql datasource on Lasso Lux

Anibal Escobar
For posterity, what happened was that mysql was saving passwords with the old hashing format, even though it's version 5.1.73.  There's an environment variable called "old passwords" which was set to ON.  Once I set it to OFF, mysql started creating passwords with the newer hash and Lux was able to connect.

Thanks,
Anibal Escobar
646 502 8821




On Nov 30, 2015, at 3:22 AM, Jolle Carlestam wrote:

> 29 nov 2015 kl. 22:48 skrev Anibal Escobar <[hidden email]>:
>>
>> Hi, I’m using Lux 1.0, Lasso 9.3.1 on Linux.  I’m trying to set up a mysql datasource, but when I enter the information, which I believe to be correct in the New Host: MySQL window, I get the following error:
>>
>> Connection using old (pre-4.1.1) authentication protocol refused (client option 'secure_auth' enabled)
>>
>> Can anyone point me in the right direction to getting past this error?
>
> Beats me.
> I’ve had no issues connecting to Mysql on Linux with 9.3 (or 9.3.1).
>
> Did a check on my secure_auth setting and found that it on one Linux machine is set to OFF, although that machine is running 9.2. On the other Linux, running 9.3, it is set to ON.
> My local OS X machine running 9.3.1 is also set to ON.
>
> HDB
> Jolle
>
> #############################################################
>
> This message is sent to you because you are subscribed to
>  the mailing list Lasso [hidden email]
> Official list archives available at http://www.lassotalk.com
> To unsubscribe, E-mail to: <[hidden email]>
> Send administrative queries to  <[hidden email]>


#############################################################

This message is sent to you because you are subscribed to
  the mailing list Lasso [hidden email]
Official list archives available at http://www.lassotalk.com
To unsubscribe, E-mail to: <[hidden email]>
Send administrative queries to  <[hidden email]>