SSL issue

classic Classic list List threaded Threaded
12 messages Options
Reply | Threaded
Open this post in threaded view
|

SSL issue

Randy Zumwalde
Hi all,

I have a domain (pggalleria.com) that we don't have a ssl certificate
for. Our certificate is for secure1.ehowe.com. I have an index file in
pggalleria that redirects to our secure site (secure1.ehowe.com/galleria)

The problem my boss found today is that if you go to pggalleria.com
their browser tells them their connection is not private and attackers
might be trying to steal your information and the  site is not to be
trusted.
It seems like the browser is checking for a certificate for
pggalleria.com before it lets the redirect happen. This doesn't happen
with my browser so I've never noticed it. It would always redirect
successfully for me but now my boss believes it is turning people away
from our site.

Is there another way I can accomplish this where a trust message wont
pop up?

This is what I have in the index file for pggalleria.com

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN">
<html>
<head>
<title>P&G Galleria</title>
<meta http-equiv="REFRESH"
content="0;url=http://secure1.ehowe.com/galleria/store/home.lasso"></HEAD>
<BODY>

</BODY>
</HTML>
--


#############################################################

This message is sent to you because you are subscribed to
  the mailing list Lasso [hidden email]
Official list archives available at http://www.lassotalk.com
To unsubscribe, E-mail to: <[hidden email]>
Send administrative queries to  <[hidden email]>
Reply | Threaded
Open this post in threaded view
|

Re: SSL issue

Bil Corry-3
You redirect from http://pggalleria.com to https://pggalleria.com.

Either redirect from http://pggalleria.com directly to the secure1 site, or
buy a SSL cert for pggalleria.


- Bil


On Thu, Jan 22, 2015 at 7:28 PM, Randy Zumwalde <[hidden email]>
wrote:

> Hi all,
>
> I have a domain (pggalleria.com) that we don't have a ssl certificate
> for. Our certificate is for secure1.ehowe.com. I have an index file in
> pggalleria that redirects to our secure site (secure1.ehowe.com/galleria)
>
> The problem my boss found today is that if you go to pggalleria.com their
> browser tells them their connection is not private and attackers might be
> trying to steal your information and the  site is not to be trusted.
> It seems like the browser is checking for a certificate for pggalleria.com
> before it lets the redirect happen. This doesn't happen with my browser so
> I've never noticed it. It would always redirect successfully for me but now
> my boss believes it is turning people away from our site.
>
> Is there another way I can accomplish this where a trust message wont pop
> up?
>
> This is what I have in the index file for pggalleria.com
>
> <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN">
> <html>
> <head>
> <title>P&G Galleria</title>
> <meta http-equiv="REFRESH" content="0;url=http://secure1.
> ehowe.com/galleria/store/home.lasso"></HEAD>
> <BODY>
>
> </BODY>
> </HTML>
> --
>
>
> #############################################################
>
> This message is sent to you because you are subscribed to
>  the mailing list Lasso [hidden email]
> Official list archives available at http://www.lassotalk.com
> To unsubscribe, E-mail to: <[hidden email]>
> Send administrative queries to  <[hidden email]>
>

#############################################################

This message is sent to you because you are subscribed to
  the mailing list Lasso [hidden email]
Official list archives available at http://www.lassotalk.com
To unsubscribe, E-mail to: <[hidden email]>
Send administrative queries to  <[hidden email]>
Reply | Threaded
Open this post in threaded view
|

Re: SSL issue

Randy Zumwalde
I thought I was redirecting directly to the secure site.
pggalleria.com/index.html redirects to
https://secure1.ehowe.com/galleria/store/home.lasso

It seems it works properly if you enter www.pggalleria.com but does not
if entering just pggalleria.com
Why would that be?

On 1/22/15 1:35 PM, Bil Corry wrote:

> You redirect from http://pggalleria.com to https://pggalleria.com.
>
> Either redirect from http://pggalleria.com directly to the secure1 site, or
> buy a SSL cert for pggalleria.
>
>
> - Bil
>
>
> On Thu, Jan 22, 2015 at 7:28 PM, Randy Zumwalde <[hidden email]>
> wrote:
>
>> Hi all,
>>
>> I have a domain (pggalleria.com) that we don't have a ssl certificate
>> for. Our certificate is for secure1.ehowe.com. I have an index file in
>> pggalleria that redirects to our secure site (secure1.ehowe.com/galleria)
>>
>> The problem my boss found today is that if you go to pggalleria.com their
>> browser tells them their connection is not private and attackers might be
>> trying to steal your information and the  site is not to be trusted.
>> It seems like the browser is checking for a certificate for pggalleria.com
>> before it lets the redirect happen. This doesn't happen with my browser so
>> I've never noticed it. It would always redirect successfully for me but now
>> my boss believes it is turning people away from our site.
>>
>> Is there another way I can accomplish this where a trust message wont pop
>> up?
>>
>> This is what I have in the index file for pggalleria.com
>>
>> <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN">
>> <html>
>> <head>
>> <title>P&G Galleria</title>
>> <meta http-equiv="REFRESH" content="0;url=https://secure1.
>> ehowe.com/galleria/store/home.lasso"></HEAD>
>> <BODY>
>>
>> </BODY>
>> </HTML>
>> --
>>
>>
>> #############################################################
>>
>> This message is sent to you because you are subscribed to
>>   the mailing list Lasso [hidden email]
>> Official list archives available at http://www.lassotalk.com
>> To unsubscribe, E-mail to: <[hidden email]>
>> Send administrative queries to  <[hidden email]>
>>
> #############################################################
>
> This message is sent to you because you are subscribed to
>    the mailing list Lasso [hidden email]
> Official list archives available at http://www.lassotalk.com
> To unsubscribe, E-mail to: <[hidden email]>
> Send administrative queries to  <[hidden email]>
>


#############################################################

This message is sent to you because you are subscribed to
  the mailing list Lasso [hidden email]
Official list archives available at http://www.lassotalk.com
To unsubscribe, E-mail to: <[hidden email]>
Send administrative queries to  <[hidden email]>
Reply | Threaded
Open this post in threaded view
|

RE: SSL issue

Rick Draper-2
> It seems it works properly if you enter www.pggalleria.com but does not if
entering just pggalleria.com Why would that be?

Likely the absence of a suitable rule???

ServerName www.pggalleria.com
ServerAlias pggalleria.com
     
Redirect permanent / https://secure1.ehowe.com/galleria/store/


VBR

Rick



#############################################################

This message is sent to you because you are subscribed to
  the mailing list Lasso [hidden email]
Official list archives available at http://www.lassotalk.com
To unsubscribe, E-mail to: <[hidden email]>
Send administrative queries to  <[hidden email]>
Reply | Threaded
Open this post in threaded view
|

Re: SSL issue

Randy Zumwalde
Is this supposed to entered in my web server somewhere. I'm not real
versed with this stuff.  I'm using Apple Server.

Thanks,
Randy
On 1/22/15 2:52 PM, Rick Draper wrote:

>> It seems it works properly if you enter www.pggalleria.com but does not if
> entering just pggalleria.com Why would that be?
>
> Likely the absence of a suitable rule???
>
> ServerName www.pggalleria.com
> ServerAlias pggalleria.com
>        
> Redirect permanent / https://secure1.ehowe.com/galleria/store/
>
>
> VBR
>
> Rick
>
>
>
> #############################################################
>
> This message is sent to you because you are subscribed to
>    the mailing list Lasso [hidden email]
> Official list archives available at http://www.lassotalk.com
> To unsubscribe, E-mail to: <[hidden email]>
> Send administrative queries to  <[hidden email]>
>


#############################################################

This message is sent to you because you are subscribed to
  the mailing list Lasso [hidden email]
Official list archives available at http://www.lassotalk.com
To unsubscribe, E-mail to: <[hidden email]>
Send administrative queries to  <[hidden email]>
Reply | Threaded
Open this post in threaded view
|

RE: SSL issue

Rick Draper-2
Hi Randy,

You will have an Apache Config somewhere that will have a redirect in place
that you see working.  Others on this list are much better verses than
myself to suggest where you look on an Apple server, but it will be a file
that defined your VirtualHost and the redirect you actually see working for
www.

Sorry I can't be of more assistance.

VBR

Rick




#############################################################

This message is sent to you because you are subscribed to
  the mailing list Lasso [hidden email]
Official list archives available at http://www.lassotalk.com
To unsubscribe, E-mail to: <[hidden email]>
Send administrative queries to  <[hidden email]>
Reply | Threaded
Open this post in threaded view
|

Re: SSL issue

Randy Zumwalde
In reply to this post by Randy Zumwalde
I found the settings to change on my server and all is well now.
Thanks for helping me with my non-lasso issue. Working as a one man show
as well as working from home I feel as though I have no one to turn to
besides this list. Thanks again!

__Randy
_<http://ehowe.mypromohq.com>_
On 1/22/15 3:00 PM, Randy Zumwalde wrote:

> Is this supposed to entered in my web server somewhere. I'm not real
> versed with this stuff.  I'm using Apple Server.
>
> Thanks,
> Randy
> On 1/22/15 2:52 PM, Rick Draper wrote:
>>> It seems it works properly if you enter www.pggalleria.com but does
>>> not if
>> entering just pggalleria.com Why would that be?
>>
>> Likely the absence of a suitable rule???
>>
>> ServerName www.pggalleria.com
>> ServerAlias pggalleria.com
>>        Redirect permanent / https://secure1.ehowe.com/galleria/store/
>>
>>
>> VBR
>>
>> Rick
>>
>>
>>
>> #############################################################
>>
>> This message is sent to you because you are subscribed to
>>    the mailing list Lasso [hidden email]
>> Official list archives available at http://www.lassotalk.com
>> To unsubscribe, E-mail to: <[hidden email]>
>> Send administrative queries to <[hidden email]>
>>
>
>
> #############################################################
>
> This message is sent to you because you are subscribed to
>  the mailing list Lasso [hidden email]
> Official list archives available at http://www.lassotalk.com
> To unsubscribe, E-mail to: <[hidden email]>
> Send administrative queries to <[hidden email]>
>


#############################################################

This message is sent to you because you are subscribed to
  the mailing list Lasso [hidden email]
Official list archives available at http://www.lassotalk.com
To unsubscribe, E-mail to: <[hidden email]>
Send administrative queries to  <[hidden email]>
Reply | Threaded
Open this post in threaded view
|

Re: SSL issue

stevepiercy
In reply to this post by Randy Zumwalde
Yes.

Your web server is Apache.  Your GUI Admin interface to Apache
is Apple's.

Also you should not use a redirect in HTML:

<meta http-equiv="REFRESH" content="0;url=http://secure1.ehowe.com/galleria/store/home.lasso"></HEAD>

By the time the page is served, it is too late.  That's why you
set up the redirect in Apache, before the page is served.

--steve


On 1/22/15 at 3:00 PM, [hidden email] (Randy Zumwalde) pronounced:

>Is this supposed to entered in my web server somewhere. I'm not
>real versed with this stuff.  I'm using Apple Server.
>
>Thanks,
>Randy
>On 1/22/15 2:52 PM, Rick Draper wrote:
>>>It seems it works properly if you enter www.pggalleria.com but does not if
>>entering just pggalleria.com Why would that be?
>>
>>Likely the absence of a suitable rule???
>>
>>ServerName www.pggalleria.com
>>ServerAlias pggalleria.com
>>Redirect permanent / https://secure1.ehowe.com/galleria/store/
>>
>>
>>VBR
>>
>>Rick
>>
>>
>>
>>#############################################################
>>
>>This message is sent to you because you are subscribed to
>>the mailing list Lasso [hidden email]
>>Official list archives available at http://www.lassotalk.com
>>To unsubscribe, E-mail to: <[hidden email]>
>>Send administrative queries to  <[hidden email]>
>>
>
>
>#############################################################
>
>This message is sent to you because you are subscribed to
>the mailing list Lasso [hidden email]
>Official list archives available at http://www.lassotalk.com
>To unsubscribe, E-mail to: <[hidden email]>
>Send administrative queries to  <[hidden email]>

-- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
Steve Piercy              Website Builder              Soquel, CA
<[hidden email]>               <http://www.StevePiercy.com/>


#############################################################

This message is sent to you because you are subscribed to
  the mailing list Lasso [hidden email]
Official list archives available at http://www.lassotalk.com
To unsubscribe, E-mail to: <[hidden email]>
Send administrative queries to  <[hidden email]>
Reply | Threaded
Open this post in threaded view
|

Re: SSL issue

Randy Zumwalde
Thanks Steve,
I did go ahead and set up a redirect in the GUI. All seems well now.
*Randy Zumwalde* • Tel: 513.651.1888 • Mobile/Direct 859.801.1419
The John K. Howe Company, Inc.
7188 Main Street | Cincinnati, OH 45244

Be sure to visit us online at http://www.ehowe.com
Like us on Facebook at _https://www.facebook.com/howemarketing_
Looking for product ideas? visit _http://ehowe.mypromohq.com_

On 1/22/15 3:40 PM, Steve Piercy - Website Builder wrote:

> Yes.
>
> Your web server is Apache.  Your GUI Admin interface to Apache is
> Apple's.
>
> Also you should not use a redirect in HTML:
>
> <meta http-equiv="REFRESH"
> content="0;url=http://secure1.ehowe.com/galleria/store/home.lasso"></HEAD>
>
> By the time the page is served, it is too late.  That's why you set up
> the redirect in Apache, before the page is served.
>
> --steve
>
>
> On 1/22/15 at 3:00 PM, [hidden email] (Randy Zumwalde) pronounced:
>
>> Is this supposed to entered in my web server somewhere. I'm not real
>> versed with this stuff.  I'm using Apple Server.
>>
>> Thanks,
>> Randy
>> On 1/22/15 2:52 PM, Rick Draper wrote:
>>>> It seems it works properly if you enter www.pggalleria.com but does
>>>> not if
>>> entering just pggalleria.com Why would that be?
>>>
>>> Likely the absence of a suitable rule???
>>>
>>> ServerName www.pggalleria.com
>>> ServerAlias pggalleria.com
>>> Redirect permanent / https://secure1.ehowe.com/galleria/store/
>>>
>>>
>>> VBR
>>>
>>> Rick
>>>
>>>
>>>
>>> #############################################################
>>>
>>> This message is sent to you because you are subscribed to
>>> the mailing list Lasso [hidden email]
>>> Official list archives available at http://www.lassotalk.com
>>> To unsubscribe, E-mail to: <[hidden email]>
>>> Send administrative queries to <[hidden email]>
>>>
>>
>>
>> #############################################################
>>
>> This message is sent to you because you are subscribed to
>> the mailing list Lasso [hidden email]
>> Official list archives available at http://www.lassotalk.com
>> To unsubscribe, E-mail to: <[hidden email]>
>> Send administrative queries to <[hidden email]>
>
> -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
> Steve Piercy              Website Builder              Soquel, CA
> <[hidden email]> <http://www.StevePiercy.com/>
>
>
> #############################################################
>
> This message is sent to you because you are subscribed to
>  the mailing list Lasso [hidden email]
> Official list archives available at http://www.lassotalk.com
> To unsubscribe, E-mail to: <[hidden email]>
> Send administrative queries to <[hidden email]>
>


#############################################################

This message is sent to you because you are subscribed to
  the mailing list Lasso [hidden email]
Official list archives available at http://www.lassotalk.com
To unsubscribe, E-mail to: <[hidden email]>
Send administrative queries to  <[hidden email]>
Reply | Threaded
Open this post in threaded view
|

Re: SSL issue

Jussi Hirvi-2
In reply to this post by Randy Zumwalde
On 22.1.2015 20.28, Randy Zumwalde wrote:
> <meta http-equiv="REFRESH"
> content="0;url=http://secure1.ehowe.com/galleria/store/home.lasso">

I think nobody commented on the missing "s" in the redirect link cited
above. It should be https, not http. However, I am glad that the issue
is solved.

- Jussi

#############################################################

This message is sent to you because you are subscribed to
  the mailing list Lasso [hidden email]
Official list archives available at http://www.lassotalk.com
To unsubscribe, E-mail to: <[hidden email]>
Send administrative queries to  <[hidden email]>
Reply | Threaded
Open this post in threaded view
|

Re: SSL issue

stevepiercy
On 1/23/15 at 7:51 AM, [hidden email] (Jussi Hirvi) pronounced:

>On 22.1.2015 20.28, Randy Zumwalde wrote:
>><meta http-equiv="REFRESH"
>>content="0;url=http://secure1.ehowe.com/galleria/store/home.lasso">
>
>I think nobody commented on the missing "s" in the redirect
>link cited above. It should be https, not http. However, I am
>glad that the issue is solved.

I didn't mention it because this method should not be used.  
Redirects should not be performed on the client side if you want
them to work reliably.  Of course, if you want your web app to
be unreliable, then by all means go for it.

--steve

-- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
Steve Piercy              Website Builder              Soquel, CA
<[hidden email]>               <http://www.StevePiercy.com/>


#############################################################

This message is sent to you because you are subscribed to
  the mailing list Lasso [hidden email]
Official list archives available at http://www.lassotalk.com
To unsubscribe, E-mail to: <[hidden email]>
Send administrative queries to  <[hidden email]>
Reply | Threaded
Open this post in threaded view
|

Re: SSL issue

Jussi Hirvi-2
On 23.1.2015 8.15, Steve Piercy - Website Builder wrote:
> Of course, if you want your web app to be unreliable, then by all means
> go for it.

I was not suggesting that that method should be used.
- Jussi

#############################################################

This message is sent to you because you are subscribed to
  the mailing list Lasso [hidden email]
Official list archives available at http://www.lassotalk.com
To unsubscribe, E-mail to: <[hidden email]>
Send administrative queries to  <[hidden email]>