Problems running from command line

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Problems running from command line

Dave Bruhn
Hey, everyone,

I'm attempting to run Lasso from the command line, but I'm running into an error.  Whenever I call "lcapi_loadModules," I get the following:

Using ImageMagick 6.6.6-10 2011-07-07 Q16 http://www.imagemagick.org
MySQLConnector using MySQL client: 5.5.8
SQLAPIDS: Oracle datasource disabled due to missing DBMS client libraries.
SQLAPIDS: SQLServer datasource disabled due to missing DBMS client libraries.
SQLAPIDS: Using PostgreSQL client API version: 0.0
SQLAPIDS: Using ODBC client API version: 0.0
SQLAPIDS: Sybase datasource disabled due to missing DBMS client libraries.
SQLAPIDS: DB2 datasource disabled due to missing DBMS client libraries.
SQLiteConnector using SQLite: 3.7.3
2 OS error: 2 No such file or directory

What gives?  Any ideas?

This is Lasso 9.2.7 running on Mac OS X Server 10.7.

Thanks,
Dave
---
Dave Bruhn
Senior Systems Analyst
North Carolina Hospital Association
PO Box 4449
Cary, NC 27519-4449
919-677-4145 (office)
[hidden email]
http://www.ncha.org


#############################################################

This message is sent to you because you are subscribed to
  the mailing list Lasso [hidden email]
Official list archives available at http://www.lassotalk.com
To unsubscribe, E-mail to: <[hidden email]>
Send administrative queries to  <[hidden email]>
Reply | Threaded
Open this post in threaded view
|

Re: Problems running from command line

Brad Lindsay
Dave,

Are you running from a script? Have you tried a script with just
`lcapi_loadModules` in it? Can you try loading just the modules you
need? Here’s an example for loading MySQL:

lcapi_loadModule((sys_masterHomePath || sys_homePath) +
'/LassoModules/MySQLConnector.' + sys_dll_ext)

Might have some more ideas if you can give me a reproducible set of
instructions.

Brad



On June 15, 2016 at 2:40:04 PM, Dave Bruhn ([hidden email]) wrote:

> Hey, everyone,
>
> I'm attempting to run Lasso from the command line, but I'm running into an error. Whenever
> I call "lcapi_loadModules," I get the following:
>
> Using ImageMagick 6.6.6-10 2011-07-07 Q16 http://www.imagemagick.org
> MySQLConnector using MySQL client: 5.5.8
> SQLAPIDS: Oracle datasource disabled due to missing DBMS client libraries.
> SQLAPIDS: SQLServer datasource disabled due to missing DBMS client libraries.
> SQLAPIDS: Using PostgreSQL client API version: 0.0
> SQLAPIDS: Using ODBC client API version: 0.0
> SQLAPIDS: Sybase datasource disabled due to missing DBMS client libraries.
> SQLAPIDS: DB2 datasource disabled due to missing DBMS client libraries.
> SQLiteConnector using SQLite: 3.7.3
> 2 OS error: 2 No such file or directory
>
> What gives? Any ideas?
>
> This is Lasso 9.2.7 running on Mac OS X Server 10.7.
>
> Thanks,
> Dave
> ---
> Dave Bruhn
> Senior Systems Analyst
> North Carolina Hospital Association
> PO Box 4449
> Cary, NC 27519-4449
> 919-677-4145 (office)
> [hidden email]
> http://www.ncha.org
>
>
> #############################################################
>
> This message is sent to you because you are subscribed to
> the mailing list Lasso [hidden email]
> Official list archives available at http://www.lassotalk.com
> To unsubscribe, E-mail to:
> Send administrative queries to
>

#############################################################

This message is sent to you because you are subscribed to
  the mailing list Lasso [hidden email]
Official list archives available at http://www.lassotalk.com
To unsubscribe, E-mail to: <[hidden email]>
Send administrative queries to  <[hidden email]>