PostgreSQL

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|

PostgreSQL

lizquigg
I have a few columns in my postgreSQL table that I created as text.  
When I look at the table with a postgreSQL client, they show up as a  
text column.  However when I look at it using databaseBrowser.lasso,  
they list them as blobs.   The create statements had "text "to create  
them.

Is this a bug?

Liz

________________________
Liz Quigg • Fermilab MS 226
Box 500  • Batavia • IL • 60510
[hidden email] • 630 840-2631



--
This list is a free service of LassoSoft: http://www.LassoSoft.com/
Search the list archives: http://www.ListSearch.com/Lasso/Browse/
Manage your subscription: http://www.ListSearch.com/Lasso/

Reply | Threaded
Open this post in threaded view
|

Error connecting to PostgreSQL (OS X)

Asle Benoni-2
Hi,
I am trying to connect to local PostgreSQL but can´t connect. Using  
Lasso 8.5.5 on OS X Server.
PostgreSQL is installed and running I have confirmed with PG Admin.

In the documentation on page 146 it says to make a symblink to the  
libpg.dylib:

sudo ln -s /usr/local/pgsql/lib/libpq.dylib .

But where do I run this command? I believe the symblink must be  
somewhere Lasso can find it. Where is that?
Do I have to restart Lasso after I have made the symblink?

/asle benoni

--
This list is a free service of LassoSoft: http://www.LassoSoft.com/
Search the list archives: http://www.ListSearch.com/Lasso/Browse/
Manage your subscription: http://www.ListSearch.com/Lasso/


Reply | Threaded
Open this post in threaded view
|

Re: Error connecting to PostgreSQL (OS X)

stevepiercy
See this thread.

http://www.nabble.com/Postgresql-on-8.5-p4941938.html

--steve


On Thursday, March 5, 2009, [hidden email] (Asle Benoni) pronounced:

>Hi,
>I am trying to connect to local PostgreSQL but can´t connect. Using  
>Lasso 8.5.5 on OS X Server.
>PostgreSQL is installed and running I have confirmed with PG Admin.
>
>In the documentation on page 146 it says to make a symblink to the  
>libpg.dylib:
>
>sudo ln -s /usr/local/pgsql/lib/libpq.dylib .
>
>But where do I run this command? I believe the symblink must be  
>somewhere Lasso can find it. Where is that?
>Do I have to restart Lasso after I have made the symblink?
>
>/asle benoni
>
>--
>This list is a free service of LassoSoft: http://www.LassoSoft.com/
>Search the list archives: http://www.ListSearch.com/Lasso/Browse/
>Manage your subscription: http://www.ListSearch.com/Lasso/
>
>

-- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
Steve Piercy               Web Site Builder               Soquel, CA
<[hidden email]>                  <http://www.StevePiercy.com/>


--
This list is a free service of LassoSoft: http://www.LassoSoft.com/
Search the list archives: http://www.ListSearch.com/Lasso/Browse/
Manage your subscription: http://www.ListSearch.com/Lasso/


Reply | Threaded
Open this post in threaded view
|

Re: Error connecting to PostgreSQL (OS X)

Asle Benoni-2
Thanks.
But I cannot find libpq.so anywhere. It is not included in the  
PostgreSQL build for OS X.
Same problem elsewhere with PostgreSQL:
http://osdir.com/ml/python.db.psycopg.devel/2003-12/msg00032.html

I wonder if the libpq.dylib in /usr/local/lib is outdated? Since it  
says "..4.1.." Any ideas, anyone?

/asle

Den 6. mars. 2009 kl. 12.38 skrev Steve Piercy - Web Site Builder:

> See this thread.
>
> http://www.nabble.com/Postgresql-on-8.5-p4941938.html
>
> --steve
>
>
> On Thursday, March 5, 2009, [hidden email] (Asle Benoni)  
> pronounced:
>
>> Hi,
>> I am trying to connect to local PostgreSQL but can´t connect. Using
>> Lasso 8.5.5 on OS X Server.
>> PostgreSQL is installed and running I have confirmed with PG Admin.
>>
>> In the documentation on page 146 it says to make a symblink to the
>> libpg.dylib:
>>
>> sudo ln -s /usr/local/pgsql/lib/libpq.dylib .
>>
>> But where do I run this command? I believe the symblink must be
>> somewhere Lasso can find it. Where is that?
>> Do I have to restart Lasso after I have made the symblink?
>>
>> /asle benoni
>>
>> --
>> This list is a free service of LassoSoft: http://www.LassoSoft.com/
>> Search the list archives: http://www.ListSearch.com/Lasso/Browse/
>> Manage your subscription: http://www.ListSearch.com/Lasso/
>>
>>
>
> -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
> Steve Piercy               Web Site Builder               Soquel, CA
> <[hidden email]>                  <http://www.StevePiercy.com/>
>
>
> --
> This list is a free service of LassoSoft: http://www.LassoSoft.com/
> Search the list archives: http://www.ListSearch.com/Lasso/Browse/
> Manage your subscription: http://www.ListSearch.com/Lasso/
>
>



--
This list is a free service of LassoSoft: http://www.LassoSoft.com/
Search the list archives: http://www.ListSearch.com/Lasso/Browse/
Manage your subscription: http://www.ListSearch.com/Lasso/


Reply | Threaded
Open this post in threaded view
|

Re: Error connecting to PostgreSQL (OS X)

Asle Benoni-2
In reply to this post by stevepiercy
Steve, I think that thread is a bit old (2006) and things must be  
different on OS X 10.5.

I tried to make a symblink in
/Applications/Lasso Professional 8/LassoModules

libpq.dylib -> /usr/local/pgsql/lib/libpq.dylib

So that Lasso should find the module. The Lasso documentation is very  
slim here :-(

When I try to add a new postgresql host in Lasso Sites I get this error:
Add error (-9959)

Anyone got PostgreSQL working on Lasso 8.5.5 on OS X 10.5 (Server) ??

/asle

Den 6. mars. 2009 kl. 12.38 skrev Steve Piercy - Web Site Builder:

> See this thread.
>
> http://www.nabble.com/Postgresql-on-8.5-p4941938.html
>
> --steve
>
>
> On Thursday, March 5, 2009, [hidden email] (Asle Benoni)  
> pronounced:
>
>> Hi,
>> I am trying to connect to local PostgreSQL but can´t connect. Using
>> Lasso 8.5.5 on OS X Server.
>> PostgreSQL is installed and running I have confirmed with PG Admin.
>>
>> In the documentation on page 146 it says to make a symblink to the
>> libpg.dylib:
>>
>> sudo ln -s /usr/local/pgsql/lib/libpq.dylib .
>>
>> But where do I run this command? I believe the symblink must be
>> somewhere Lasso can find it. Where is that?
>> Do I have to restart Lasso after I have made the symblink?
>>
>> /asle benoni
>>
>> --
>> This list is a free service of LassoSoft: http://www.LassoSoft.com/
>> Search the list archives: http://www.ListSearch.com/Lasso/Browse/
>> Manage your subscription: http://www.ListSearch.com/Lasso/
>>
>>
>
> -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
> Steve Piercy               Web Site Builder               Soquel, CA
> <[hidden email]>                  <http://www.StevePiercy.com/>
>
>
> --
> This list is a free service of LassoSoft: http://www.LassoSoft.com/
> Search the list archives: http://www.ListSearch.com/Lasso/Browse/
> Manage your subscription: http://www.ListSearch.com/Lasso/
>
>



--
This list is a free service of LassoSoft: http://www.LassoSoft.com/
Search the list archives: http://www.ListSearch.com/Lasso/Browse/
Manage your subscription: http://www.ListSearch.com/Lasso/


Reply | Threaded
Open this post in threaded view
|

Re: Error connecting to PostgreSQL (OS X)

Asle Benoni-2
Anyone using PostgreSQL?
I would be glad for any help getting Lasso to talk to PG :-)

/asle

Den 10. mars. 2009 kl. 08.44 skrev Asle Benoni:

> Steve, I think that thread is a bit old (2006) and things must be  
> different on OS X 10.5.
>
> I tried to make a symblink in
> /Applications/Lasso Professional 8/LassoModules
>
> libpq.dylib -> /usr/local/pgsql/lib/libpq.dylib
>
> So that Lasso should find the module. The Lasso documentation is  
> very slim here :-(
>
> When I try to add a new postgresql host in Lasso Sites I get this  
> error:
> Add error (-9959)
>
> Anyone got PostgreSQL working on Lasso 8.5.5 on OS X 10.5 (Server) ??
>
> /asle
>
> Den 6. mars. 2009 kl. 12.38 skrev Steve Piercy - Web Site Builder:
>
>> See this thread.
>>
>> http://www.nabble.com/Postgresql-on-8.5-p4941938.html
>>
>> --steve
>>
>>
>> On Thursday, March 5, 2009, [hidden email] (Asle Benoni)  
>> pronounced:
>>
>>> Hi,
>>> I am trying to connect to local PostgreSQL but can´t connect. Using
>>> Lasso 8.5.5 on OS X Server.
>>> PostgreSQL is installed and running I have confirmed with PG Admin.
>>>
>>> In the documentation on page 146 it says to make a symblink to the
>>> libpg.dylib:
>>>
>>> sudo ln -s /usr/local/pgsql/lib/libpq.dylib .
>>>
>>> But where do I run this command? I believe the symblink must be
>>> somewhere Lasso can find it. Where is that?
>>> Do I have to restart Lasso after I have made the symblink?
>>>
>>> /asle benoni
>>>
>>> --
>>> This list is a free service of LassoSoft: http://www.LassoSoft.com/
>>> Search the list archives: http://www.ListSearch.com/Lasso/Browse/
>>> Manage your subscription: http://www.ListSearch.com/Lasso/
>>>
>>>
>>
>> -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
>> Steve Piercy               Web Site Builder               Soquel, CA
>> <[hidden email]>                  <http://www.StevePiercy.com/>
>>
>>
>> --
>> This list is a free service of LassoSoft: http://www.LassoSoft.com/
>> Search the list archives: http://www.ListSearch.com/Lasso/Browse/
>> Manage your subscription: http://www.ListSearch.com/Lasso/
>>
>>
>
>
>
> --
> This list is a free service of LassoSoft: http://www.LassoSoft.com/
> Search the list archives: http://www.ListSearch.com/Lasso/Browse/
> Manage your subscription: http://www.ListSearch.com/Lasso/
>
>



--
This list is a free service of LassoSoft: http://www.LassoSoft.com/
Search the list archives: http://www.ListSearch.com/Lasso/Browse/
Manage your subscription: http://www.ListSearch.com/Lasso/