OT: Any luck with Navicat 6.1.4 and OS 10.4 Server?

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

OT: Any luck with Navicat 6.1.4 and OS 10.4 Server?

Diane Houdek
I'm trying to set up mySQL to use for the first time with Lasso and
would like to use Navicat for an admin tool on a Tiger 10.4 server and
Navicat just can't seem to make the connection (kind of a host not found
error).  I used the default set up location on Tiger server for mySQL.
Could Navicat just not be able to find where Apple put mySQL? Does
anyone else have experience with these two?

Thanks,
Diane


------------------------------
Lasso Support: http://support.omnipilot.com/
Search the list archives: http://www.listsearch.com/lassotalk.lasso
Manage your list subscription:  
http://www.listsearch.com/lassotalk.lasso?manage
Reply | Threaded
Open this post in threaded view
|

Re: OT: Any luck with Navicat 6.1.4 and OS 10.4 Server?

Bram Verniest
Hi,

I use navicat for all my connections, with OSX 10.4.5
Are your security settings in MySQL ok?
Is your user allowed?

Bram
--
http://hotel.eu.com
Platform for online reservations
[hidden email]
Bram Verniest | 0477/726268


On 01 Mar 2006, at 22:06, Diane Houdek wrote:

I'm trying to set up mySQL to use for the first time with Lasso and
would like to use Navicat for an admin tool on a Tiger 10.4 server and
Navicat just can't seem to make the connection (kind of a host not found
error).  I used the default set up location on Tiger server for mySQL.
Could Navicat just not be able to find where Apple put mySQL? Does
anyone else have experience with these two?

Thanks,
Diane


------------------------------
Lasso Support: http://support.omnipilot.com/
Search the list archives: http://www.listsearch.com/lassotalk.lasso
Manage your list subscription:
http://www.listsearch.com/lassotalk.lasso?manage



------------------------------
Lasso Support: http://support.omnipilot.com/
Search the list archives: http://www.listsearch.com/lassotalk.lasso
Manage your list subscription:  
http://www.listsearch.com/lassotalk.lasso?manage
Reply | Threaded
Open this post in threaded view
|

Re: OT: Any luck with Navicat 6.1.4 and OS 10.4 Server?

Jono-2
In reply to this post by Diane Houdek
Hi Diane

Are you accessing it from ON the server or on your desktop/laptop?

Have you made sure the user you are using to connect to the mysql  
server has permissions to access the mysql from a host other than  
localhost?

We're using that same combination here and it works a treat.

On 02/03/2006, at 10:06 AM, Diane Houdek wrote:

> I'm trying to set up mySQL to use for the first time with Lasso and
> would like to use Navicat for an admin tool on a Tiger 10.4 server and
> Navicat just can't seem to make the connection (kind of a host not  
> found
> error).  I used the default set up location on Tiger server for mySQL.
> Could Navicat just not be able to find where Apple put mySQL? Does
> anyone else have experience with these two?
>
> Thanks,
> Diane
>
>
> ------------------------------
> Lasso Support: http://support.omnipilot.com/
> Search the list archives: http://www.listsearch.com/lassotalk.lasso
> Manage your list subscription:
> http://www.listsearch.com/lassotalk.lasso?manage


Jono

// ---------------------------------------------------------
/*
     Jonathan Guthrie
     xServe Ltd, Wellington NZ
     [hidden email]   |   http://xserve.co.nz   | +64 21 678890

*/
// ---------------------------------------------------------




------------------------------
Lasso Support: http://support.omnipilot.com/
Search the list archives: http://www.listsearch.com/lassotalk.lasso
Manage your list subscription:  
http://www.listsearch.com/lassotalk.lasso?manage
Reply | Threaded
Open this post in threaded view
|

Re: OT: Any luck with Navicat 6.1.4 and OS 10.4 Server?

Diane Houdek
In reply to this post by Diane Houdek
I did get the connection to work, I forgot to turn on the network
setting in MySQLManager - silly me!! However, now I can't do anything
with the user setup, so I'm assuming that my user has a permissions
problem, but I'm not sure how to diagnose it. This is the problem with
learning how to use a "real" database after using FileMaker for ever.
;-)

I'm running Navicat on the server it's installed on, so I'm connecting
to localhost.

Thanks for all help!
Diane
 
 
>>>[hidden email] 03/01/06 3:35 pm >>>
Hi Diane
 
Are you accessing it from ON the server or on your desktop/laptop?
 
Have you made sure the user you are using to connect to the mysql  
server has permissions to access the mysql from a host other than  
localhost?
 
We're using that same combination here and it works a treat.  
 
 
Jono
 



------------------------------
Lasso Support: http://support.omnipilot.com/
Search the list archives: http://www.listsearch.com/lassotalk.lasso
Manage your list subscription:  
http://www.listsearch.com/lassotalk.lasso?manage
Reply | Threaded
Open this post in threaded view
|

Re: OT: Any luck with Navicat 6.1.4 and OS 10.4 Server?

Pierre Yelle
In reply to this post by Diane Houdek

On 1-Mar-06, at 4:55 PM, Diane Houdek wrote:

> I did get the connection to work, I forgot to turn on the network
> setting in MySQLManager - silly me!! However, now I can't do anything
> with the user setup, so I'm assuming that my user has a permissions
> problem, but I'm not sure how to diagnose it. This is the problem with
> learning how to use a "real" database after using FileMaker for ever.
> ;-)
>
> I'm running Navicat on the server it's installed on, so I'm connecting
> to localhost.
>
> Thanks for all help!
> Diane
>
If you run a top command in Terminal is mysqld listed ?

can you access the mysqld instance via the mysql client application
from the Terminal ?

Run a Grant command for yourself and/or the user from mysql client
application:


to set perms for yourself on the localhost
GRANT ALL PRIVILEGES ON *.* TO diane@localhost IDENTIFIED BY 'secret'
WITH GRANT OPTION

to set perms for yoursel from anywhere
GRANT ALL PRIVILEGES ON *.* TO diane@'%' IDENTIFIED BY 'secret' WITH
GRANT OPTION;

Set the connection properties in Navicat with above


If no user exists at this time you will need to access simply connect
with

root as a user and leave the password field empty

   Good luck
Pierre
604-288-2708



------------------------------
Lasso Support: http://support.omnipilot.com/
Search the list archives: http://www.listsearch.com/lassotalk.lasso
Manage your list subscription:  
http://www.listsearch.com/lassotalk.lasso?manage