Quantcast

No image type in Lasso 9.3.1

classic Classic list List threaded Threaded
16 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

No image type in Lasso 9.3.1

Jolle Carlestam-2
After upgrading to 9.3.1 it turns out that the image type is not there anymore on Linux 6.

First discovery was this error:
Definition Not Found: image(bytes)
Triggered by this code:
#img_decribedata = image(file_read(#upload -> tmpfilename)) -> describe

I then tried this on a simple test page:
image -> listmethods -> join(br)

On OS X with 9.3.1 it returned all methods for the image type. On the Linux distro I got this error:
Definition Not Found: image()

At about that point I found it suitable to say out loud; What the duck?

The lasso.out.txt shows nothing indicating that something’s not loading.

HDB
Jolle

#############################################################

This message is sent to you because you are subscribed to
  the mailing list Lasso [hidden email]
Official list archives available at http://www.lassotalk.com
To unsubscribe, E-mail to: <[hidden email]>
Send administrative queries to  <[hidden email]>
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: No image type in Lasso 9.3.1

Steffan Cline
I’ve not checked mine yet but did you make sure that the image module is missing?

It could be an ImageMagick version conflict. I recently had this with 9.2.7.


Thank you,
Steffan Cline
602-793-0014








On 1/5/16, 5:12 AM, "Jolle Carlestam" <[hidden email] on behalf of [hidden email]> wrote:

>After upgrading to 9.3.1 it turns out that the image type is not there anymore on Linux 6.
>
>First discovery was this error:
>Definition Not Found: image(bytes)
>Triggered by this code:
>#img_decribedata = image(file_read(#upload -> tmpfilename)) -> describe
>
>I then tried this on a simple test page:
>image -> listmethods -> join(br)
>
>On OS X with 9.3.1 it returned all methods for the image type. On the Linux distro I got this error:
>Definition Not Found: image()
>
>At about that point I found it suitable to say out loud; What the duck?
>
>The lasso.out.txt shows nothing indicating that something’s not loading.
>
>HDB
>Jolle
>
>#############################################################
>
>This message is sent to you because you are subscribed to
>  the mailing list Lasso [hidden email]
>Official list archives available at http://www.lassotalk.com
>To unsubscribe, E-mail to: <[hidden email]>
>Send administrative queries to  <[hidden email]>


#############################################################

This message is sent to you because you are subscribed to
  the mailing list Lasso [hidden email]
Official list archives available at http://www.lassotalk.com
To unsubscribe, E-mail to: <[hidden email]>
Send administrative queries to  <[hidden email]>
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: No image type in Lasso 9.3.1

Jolle Carlestam-2
5 jan 2016 kl. 14:17 skrev Steffan Cline <[hidden email]>:
>
> I’ve not checked mine yet but did you make sure that the image module is missing?

How can I check that?
What I did check was to run this:
image -> listmethods -> join(br)

That failed.

HDB
Jolle

#############################################################

This message is sent to you because you are subscribed to
  the mailing list Lasso [hidden email]
Official list archives available at http://www.lassotalk.com
To unsubscribe, E-mail to: <[hidden email]>
Send administrative queries to  <[hidden email]>
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: No image type in Lasso 9.3.1

Steffan Cline
Look in /var/lasso/home/LassoModules


Thanks,
Steffan Cline
[hidden email]
602-793-0014

> On Jan 5, 2016, at 6:34 AM, Jolle Carlestam <[hidden email]> wrote:
>
>> 5 jan 2016 kl. 14:17 skrev Steffan Cline <[hidden email]>:
>>
>> I’ve not checked mine yet but did you make sure that the image module is missing?
>
> How can I check that?
> What I did check was to run this:
> image -> listmethods -> join(br)
>
> That failed.
>
> HDB
> Jolle
>
> #############################################################
>
> This message is sent to you because you are subscribed to
>  the mailing list Lasso [hidden email]
> Official list archives available at http://www.lassotalk.com
> To unsubscribe, E-mail to: <[hidden email]>
> Send administrative queries to  <[hidden email]>

#############################################################

This message is sent to you because you are subscribed to
  the mailing list Lasso [hidden email]
Official list archives available at http://www.lassotalk.com
To unsubscribe, E-mail to: <[hidden email]>
Send administrative queries to  <[hidden email]>
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: No image type in Lasso 9.3.1

Jolle Carlestam-2
5 jan 2016 kl. 14:35 skrev Steffan Cline <[hidden email]>:
>
> Look in /var/lasso/home/LassoModules

ImageMagick.so    luxusg.so            OS_Process.so
LDAPConnector.so  MongoDBConnector.so  SQLConnector.so
LJAPI9.so         MySQLConnector.so    SQLiteConnector.so

Looks the same as in OS X. Still, no image type in 9.3.1 on Centos 6.

HDB
Jolle

#############################################################

This message is sent to you because you are subscribed to
  the mailing list Lasso [hidden email]
Official list archives available at http://www.lassotalk.com
To unsubscribe, E-mail to: <[hidden email]>
Send administrative queries to  <[hidden email]>
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: No image type in Lasso 9.3.1

Steffan Cline
You have the module. The issue is it’s built against an older version of ImageMagick then you have installed.

Try:

ldd /var/lasso/home/ImageMagick.so

That will show you the version required for them to work.

Marc Pope sent an email to the list showing how to downgrade using RPM. Rather than using RPM as he did, use yum remove to get rid of the IM package and then use yum localinstall xxx.rpm to let yum install it for you.

Last time I tried to do a yum downgrade xxxxx the older version had already been removed from the repos.

 

Thank you,
Steffan Cline
602-793-0014







On 1/5/16, 8:15 AM, "Jolle Carlestam" <[hidden email] on behalf of [hidden email]> wrote:

>5 jan 2016 kl. 14:35 skrev Steffan Cline <[hidden email]>:
>>
>> Look in /var/lasso/home/LassoModules
>
>ImageMagick.so    luxusg.so            OS_Process.so
>LDAPConnector.so  MongoDBConnector.so  SQLConnector.so
>LJAPI9.so         MySQLConnector.so    SQLiteConnector.so
>
>Looks the same as in OS X. Still, no image type in 9.3.1 on Centos 6.
>
>HDB
>Jolle
>
>#############################################################
>
>This message is sent to you because you are subscribed to
>  the mailing list Lasso [hidden email]
>Official list archives available at http://www.lassotalk.com
>To unsubscribe, E-mail to: <[hidden email]>
>Send administrative queries to  <[hidden email]>
>


#############################################################

This message is sent to you because you are subscribed to
  the mailing list Lasso [hidden email]
Official list archives available at http://www.lassotalk.com
To unsubscribe, E-mail to: <[hidden email]>
Send administrative queries to  <[hidden email]>
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: No image type in Lasso 9.3.1

Steffan Cline
Of course the alternative is for LS to release a hot fix containing a newer image module built against the newer IM so you don’t have to jack up your install with fixed version installs of IM.



Thank you,
Steffan Cline
602-793-0014








On 1/5/16, 8:19 AM, "Steffan Cline" <[hidden email] on behalf of [hidden email]> wrote:

>You have the module. The issue is it’s built against an older version of ImageMagick then you have installed.
>
>Try:
>
>ldd /var/lasso/home/ImageMagick.so
>
>That will show you the version required for them to work.
>
>Marc Pope sent an email to the list showing how to downgrade using RPM. Rather than using RPM as he did, use yum remove to get rid of the IM package and then use yum localinstall xxx.rpm to let yum install it for you.
>
>Last time I tried to do a yum downgrade xxxxx the older version had already been removed from the repos.
>
>
>
>Thank you,
>Steffan Cline
>602-793-0014
>
>
>
>
>
>
>
>On 1/5/16, 8:15 AM, "Jolle Carlestam" <[hidden email] on behalf of [hidden email]> wrote:
>
>>5 jan 2016 kl. 14:35 skrev Steffan Cline <[hidden email]>:
>>>
>>> Look in /var/lasso/home/LassoModules
>>
>>ImageMagick.so    luxusg.so            OS_Process.so
>>LDAPConnector.so  MongoDBConnector.so  SQLConnector.so
>>LJAPI9.so         MySQLConnector.so    SQLiteConnector.so
>>
>>Looks the same as in OS X. Still, no image type in 9.3.1 on Centos 6.
>>
>>HDB
>>Jolle
>>
>>#############################################################
>>
>>This message is sent to you because you are subscribed to
>>  the mailing list Lasso [hidden email]
>>Official list archives available at http://www.lassotalk.com
>>To unsubscribe, E-mail to: <[hidden email]>
>>Send administrative queries to  <[hidden email]>
>>
>
>
>#############################################################
>
>This message is sent to you because you are subscribed to
>  the mailing list Lasso [hidden email]
>Official list archives available at http://www.lassotalk.com
>To unsubscribe, E-mail to: <[hidden email]>
>Send administrative queries to  <[hidden email]>


#############################################################

This message is sent to you because you are subscribed to
  the mailing list Lasso [hidden email]
Official list archives available at http://www.lassotalk.com
To unsubscribe, E-mail to: <[hidden email]>
Send administrative queries to  <[hidden email]>
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: No image type in Lasso 9.3.1

Jolle Carlestam-2
In reply to this post by Steffan Cline
5 jan 2016 kl. 16:19 skrev Steffan Cline <[hidden email]>:
>
> ldd /var/lasso/home/ImageMagick.so
>
> That will show you the version required for them to work.

What do I do with this info?

ldd /var/lasso/home/LassoModules/ImageMagick.so
        linux-vdso.so.1 =>  (0x00007fff48200000)
        libMagickWand.so.5 => not found
        libMagickCore.so.5 => not found
        libfreetype.so.6 => /usr/lib64/libfreetype.so.6 (0x00007fda819a8000)
        libjpeg.so.62 => /usr/lib64/libjpeg.so.62 (0x00007fda81758000)
        libpng12.so.0 => /usr/lib64/libpng12.so.0 (0x00007fda81530000)
        libtiff.so.3 => /usr/lib64/libtiff.so.3 (0x00007fda812c8000)
        libbz2.so.1 => /lib64/libbz2.so.1 (0x00007fda810b0000)
        libz.so.1 => /lib64/libz.so.1 (0x00007fda80e98000)
        liblasso9_runtime.so => /usr/lib64/liblasso9_runtime.so (0x00007fda7e328000)
        libdl.so.2 => /lib64/libdl.so.2 (0x00007fda7e120000)
        librt.so.1 => /lib64/librt.so.1 (0x00007fda7df18000)
        libstdc++.so.6 => /usr/lib64/libstdc++.so.6 (0x00007fda7dc10000)
        libm.so.6 => /lib64/libm.so.6 (0x00007fda7d988000)
        libgcc_s.so.1 => /lib64/libgcc_s.so.1 (0x00007fda7d770000)
        libpthread.so.0 => /lib64/libpthread.so.0 (0x00007fda7d550000)
        libc.so.6 => /lib64/libc.so.6 (0x00007fda7d1b8000)
        libcrypto.so.10 => /usr/lib64/libcrypto.so.10 (0x00007fda7cdd0000)
        libcurl.so.4 => /usr/lib64/libcurl.so.4 (0x00007fda7cb78000)
        libssl.so.10 => /usr/lib64/libssl.so.10 (0x00007fda7c908000)
        libxml2.so.2 => /usr/lib64/libxml2.so.2 (0x00007fda7c5b0000)
        libxslt.so.1 => /usr/lib64/libxslt.so.1 (0x00007fda7c370000)
        libuuid.so.1 => /lib64/libuuid.so.1 (0x00007fda7c168000)
        libresolv.so.2 => /lib64/libresolv.so.2 (0x00007fda7bf48000)
        /lib64/ld-linux-x86-64.so.2 (0x00007fda81e68000)
        libidn.so.11 => /lib64/libidn.so.11 (0x00007fda7bd10000)
        libldap-2.4.so.2 => /lib64/libldap-2.4.so.2 (0x00007fda7bac0000)
        libgssapi_krb5.so.2 => /lib64/libgssapi_krb5.so.2 (0x00007fda7b878000)
        libkrb5.so.3 => /lib64/libkrb5.so.3 (0x00007fda7b590000)
        libk5crypto.so.3 => /lib64/libk5crypto.so.3 (0x00007fda7b360000)
        libcom_err.so.2 => /lib64/libcom_err.so.2 (0x00007fda7b158000)
        libssl3.so => /usr/lib64/libssl3.so (0x00007fda7af18000)
        libsmime3.so => /usr/lib64/libsmime3.so (0x00007fda7ace8000)
        libnss3.so => /usr/lib64/libnss3.so (0x00007fda7a9a8000)
        libnssutil3.so => /usr/lib64/libnssutil3.so (0x00007fda7a778000)
        libplds4.so => /lib64/libplds4.so (0x00007fda7a570000)
        libplc4.so => /lib64/libplc4.so (0x00007fda7a368000)
        libnspr4.so => /lib64/libnspr4.so (0x00007fda7a128000)
        libssh2.so.1 => /usr/lib64/libssh2.so.1 (0x00007fda79f00000)
        liblber-2.4.so.2 => /lib64/liblber-2.4.so.2 (0x00007fda79cf0000)
        libsasl2.so.2 => /usr/lib64/libsasl2.so.2 (0x00007fda79ad0000)
        libkrb5support.so.0 => /lib64/libkrb5support.so.0 (0x00007fda798c0000)
        libkeyutils.so.1 => /lib64/libkeyutils.so.1 (0x00007fda796b8000)
        libcrypt.so.1 => /lib64/libcrypt.so.1 (0x00007fda79480000)
        libselinux.so.1 => /lib64/libselinux.so.1 (0x00007fda79260000)
        libfreebl3.so => /lib64/libfreebl3.so (0x00007fda79058000)


#############################################################

This message is sent to you because you are subscribed to
  the mailing list Lasso [hidden email]
Official list archives available at http://www.lassotalk.com
To unsubscribe, E-mail to: <[hidden email]>
Send administrative queries to  <[hidden email]>
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: No image type in Lasso 9.3.1

Jolle Carlestam-2
In reply to this post by Steffan Cline
5 jan 2016 kl. 16:20 skrev Steffan Cline <[hidden email]>:
>
> Of course the alternative is for LS to release a hot fix containing a newer image module built against the newer IM so you don’t have to jack up your install with fixed version installs of IM.

Why would this happen when going from 9.3 to 9.3.1? Nothing else is changed, to my knowledge.

HDB
Jolle


#############################################################

This message is sent to you because you are subscribed to
  the mailing list Lasso [hidden email]
Official list archives available at http://www.lassotalk.com
To unsubscribe, E-mail to: <[hidden email]>
Send administrative queries to  <[hidden email]>
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: No image type in Lasso 9.3.1

Steffan Cline
When they rebuilt the newer Lasso version, they just happened to build against a different version of IM they had on their build OS.



Thank you,
Steffan Cline
602-793-0014








On 1/5/16, 8:24 AM, "Jolle Carlestam" <[hidden email] on behalf of [hidden email]> wrote:

>5 jan 2016 kl. 16:20 skrev Steffan Cline <[hidden email]>:
>>
>> Of course the alternative is for LS to release a hot fix containing a newer image module built against the newer IM so you don’t have to jack up your install with fixed version installs of IM.
>
>Why would this happen when going from 9.3 to 9.3.1? Nothing else is changed, to my knowledge.
>
>HDB
>Jolle
>
>
>#############################################################
>
>This message is sent to you because you are subscribed to
>  the mailing list Lasso [hidden email]
>Official list archives available at http://www.lassotalk.com
>To unsubscribe, E-mail to: <[hidden email]>
>Send administrative queries to  <[hidden email]>


#############################################################

This message is sent to you because you are subscribed to
  the mailing list Lasso [hidden email]
Official list archives available at http://www.lassotalk.com
To unsubscribe, E-mail to: <[hidden email]>
Send administrative queries to  <[hidden email]>
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: No image type in Lasso 9.3.1

Steffan Cline
In reply to this post by Jolle Carlestam-2
Your problem is right there.

libMagickWand.so.5 => not found
        libMagickCore.so.5 => not found


It’s looking for an older version that what you have installed.

Petition LS to release a hot fix or follow the process to bork your install with the fixed version.


Thank you,
Steffan Cline
602-793-0014








On 1/5/16, 8:24 AM, "Jolle Carlestam" <[hidden email] on behalf of [hidden email]> wrote:

>5 jan 2016 kl. 16:19 skrev Steffan Cline <[hidden email]>:
>>
>> ldd /var/lasso/home/ImageMagick.so
>>
>> That will show you the version required for them to work.
>
>What do I do with this info?
>
>ldd /var/lasso/home/LassoModules/ImageMagick.so
> linux-vdso.so.1 =>  (0x00007fff48200000)
> libMagickWand.so.5 => not found
> libMagickCore.so.5 => not found
> libfreetype.so.6 => /usr/lib64/libfreetype.so.6 (0x00007fda819a8000)
> libjpeg.so.62 => /usr/lib64/libjpeg.so.62 (0x00007fda81758000)
> libpng12.so.0 => /usr/lib64/libpng12.so.0 (0x00007fda81530000)
> libtiff.so.3 => /usr/lib64/libtiff.so.3 (0x00007fda812c8000)
> libbz2.so.1 => /lib64/libbz2.so.1 (0x00007fda810b0000)
> libz.so.1 => /lib64/libz.so.1 (0x00007fda80e98000)
> liblasso9_runtime.so => /usr/lib64/liblasso9_runtime.so (0x00007fda7e328000)
> libdl.so.2 => /lib64/libdl.so.2 (0x00007fda7e120000)
> librt.so.1 => /lib64/librt.so.1 (0x00007fda7df18000)
> libstdc++.so.6 => /usr/lib64/libstdc++.so.6 (0x00007fda7dc10000)
> libm.so.6 => /lib64/libm.so.6 (0x00007fda7d988000)
> libgcc_s.so.1 => /lib64/libgcc_s.so.1 (0x00007fda7d770000)
> libpthread.so.0 => /lib64/libpthread.so.0 (0x00007fda7d550000)
> libc.so.6 => /lib64/libc.so.6 (0x00007fda7d1b8000)
> libcrypto.so.10 => /usr/lib64/libcrypto.so.10 (0x00007fda7cdd0000)
> libcurl.so.4 => /usr/lib64/libcurl.so.4 (0x00007fda7cb78000)
> libssl.so.10 => /usr/lib64/libssl.so.10 (0x00007fda7c908000)
> libxml2.so.2 => /usr/lib64/libxml2.so.2 (0x00007fda7c5b0000)
> libxslt.so.1 => /usr/lib64/libxslt.so.1 (0x00007fda7c370000)
> libuuid.so.1 => /lib64/libuuid.so.1 (0x00007fda7c168000)
> libresolv.so.2 => /lib64/libresolv.so.2 (0x00007fda7bf48000)
> /lib64/ld-linux-x86-64.so.2 (0x00007fda81e68000)
> libidn.so.11 => /lib64/libidn.so.11 (0x00007fda7bd10000)
> libldap-2.4.so.2 => /lib64/libldap-2.4.so.2 (0x00007fda7bac0000)
> libgssapi_krb5.so.2 => /lib64/libgssapi_krb5.so.2 (0x00007fda7b878000)
> libkrb5.so.3 => /lib64/libkrb5.so.3 (0x00007fda7b590000)
> libk5crypto.so.3 => /lib64/libk5crypto.so.3 (0x00007fda7b360000)
> libcom_err.so.2 => /lib64/libcom_err.so.2 (0x00007fda7b158000)
> libssl3.so => /usr/lib64/libssl3.so (0x00007fda7af18000)
> libsmime3.so => /usr/lib64/libsmime3.so (0x00007fda7ace8000)
> libnss3.so => /usr/lib64/libnss3.so (0x00007fda7a9a8000)
> libnssutil3.so => /usr/lib64/libnssutil3.so (0x00007fda7a778000)
> libplds4.so => /lib64/libplds4.so (0x00007fda7a570000)
> libplc4.so => /lib64/libplc4.so (0x00007fda7a368000)
> libnspr4.so => /lib64/libnspr4.so (0x00007fda7a128000)
> libssh2.so.1 => /usr/lib64/libssh2.so.1 (0x00007fda79f00000)
> liblber-2.4.so.2 => /lib64/liblber-2.4.so.2 (0x00007fda79cf0000)
> libsasl2.so.2 => /usr/lib64/libsasl2.so.2 (0x00007fda79ad0000)
> libkrb5support.so.0 => /lib64/libkrb5support.so.0 (0x00007fda798c0000)
> libkeyutils.so.1 => /lib64/libkeyutils.so.1 (0x00007fda796b8000)
> libcrypt.so.1 => /lib64/libcrypt.so.1 (0x00007fda79480000)
> libselinux.so.1 => /lib64/libselinux.so.1 (0x00007fda79260000)
> libfreebl3.so => /lib64/libfreebl3.so (0x00007fda79058000)
>
>
>#############################################################
>
>This message is sent to you because you are subscribed to
>  the mailing list Lasso [hidden email]
>Official list archives available at http://www.lassotalk.com
>To unsubscribe, E-mail to: <[hidden email]>
>Send administrative queries to  <[hidden email]>


#############################################################

This message is sent to you because you are subscribed to
  the mailing list Lasso [hidden email]
Official list archives available at http://www.lassotalk.com
To unsubscribe, E-mail to: <[hidden email]>
Send administrative queries to  <[hidden email]>
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: No image type in Lasso 9.3.1

Jolle Carlestam-2
Pretty please, Lassosoft, release a fix.

HDB
Jolle

Sent from a mobile device. Any anomalies is due to Autocorrect.

> 5 jan. 2016 kl. 17:04 skrev Steffan Cline <[hidden email]>:
>
> Petition LS to release a hot fix or follow the process to bork your install with the fixed version.

#############################################################

This message is sent to you because you are subscribed to
  the mailing list Lasso [hidden email]
Official list archives available at http://www.lassotalk.com
To unsubscribe, E-mail to: <[hidden email]>
Send administrative queries to  <[hidden email]>
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: No image type in Lasso 9.3.1

Jussi Hirvi-2
In reply to this post by Jolle Carlestam-2
On 5.1.2016 17.24, Jolle Carlestam wrote:
> Why would this happen when going from 9.3 to 9.3.1? Nothing else is changed, to my knowledge.

My guess is that it's not related to : 9.3.1 but to a system update that
you might have done at around the same time as you upgraded Lasso.

This issue popped up for me on L8.6 on CentOS 6 at some system update -
I think it was the newest decimal update, CentOS 6.7. The tip from Mark
Pope worked just great!

- Jussi


#############################################################

This message is sent to you because you are subscribed to
  the mailing list Lasso [hidden email]
Official list archives available at http://www.lassotalk.com
To unsubscribe, E-mail to: <[hidden email]>
Send administrative queries to  <[hidden email]>
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: No image type in Lasso 9.3.1

Jolle Carlestam-2
In reply to this post by Jolle Carlestam-2
5 jan 2016 kl. 18:14 skrev Jolle Carlestam <[hidden email]>:
>
> Pretty please, Lassosoft, release a fix.

Lassosoft has not released a fix. They did however investigate the issue deeply and some iterating over the Lasso Gitter room solved the issue.

Apparently Centos made a change as to what ImageMagick library it links to between the version Centos 6.6 and 6.7. Lasso 9.3.1 in the present distribution is assuming that Centos 6 means Centos 6.7 or higher and links to that version of ImageMagick. I am using Centos 6.6 on my servers and thus got the failing image handling.

The solution for me was to do a painless yum update of ImageMagick, restart Lasso and that was it.

Huge thanks to Eric for taking his time to solve this with me!

HDB
Jolle

#############################################################

This message is sent to you because you are subscribed to
  the mailing list Lasso [hidden email]
Official list archives available at http://www.lassotalk.com
To unsubscribe, E-mail to: <[hidden email]>
Send administrative queries to  <[hidden email]>
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: No image type in Lasso 9.3.1

Anibal Escobar
Hi, I'm bringing back this old thread.  I'm on Centos 6.7, ImageMagick 6.5.4-7 2014-02-10 Q1, Lasso 9.3.1 and Lasso 8.6 on the same machine.  The image tag doesn't work on Lasso 9, but does on Lasso 8.  Marc Pope downgraded the version of lasso and then it worked on 9, but not 8.  I used to have it working on both 8 and 9 but some upgrade somewhere changed that.  Does anyone have the image tags working on a setup similar to mine?

Thanks,
Anibal Escobar
646 502 8821




On Jan 15, 2016, at 2:50 AM, Jolle Carlestam wrote:

> 5 jan 2016 kl. 18:14 skrev Jolle Carlestam <[hidden email]>:
>>
>> Pretty please, Lassosoft, release a fix.
>
> Lassosoft has not released a fix. They did however investigate the issue deeply and some iterating over the Lasso Gitter room solved the issue.
>
> Apparently Centos made a change as to what ImageMagick library it links to between the version Centos 6.6 and 6.7. Lasso 9.3.1 in the present distribution is assuming that Centos 6 means Centos 6.7 or higher and links to that version of ImageMagick. I am using Centos 6.6 on my servers and thus got the failing image handling.
>
> The solution for me was to do a painless yum update of ImageMagick, restart Lasso and that was it.
>
> Huge thanks to Eric for taking his time to solve this with me!
>
> HDB
> Jolle
>
> #############################################################
>
> This message is sent to you because you are subscribed to
>  the mailing list Lasso [hidden email]
> Official list archives available at http://www.lassotalk.com
> To unsubscribe, E-mail to: <[hidden email]>
> Send administrative queries to  <[hidden email]>


#############################################################

This message is sent to you because you are subscribed to
  the mailing list Lasso [hidden email]
Official list archives available at http://www.lassotalk.com
To unsubscribe, E-mail to: <[hidden email]>
Send administrative queries to  <[hidden email]>
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: No image type in Lasso 9.3.1

Johan Solve
This works for us
http://execuchoice.com/lasso-8-6-x-and-9-3-x-side-by-side-on-centos-6-7/

Thanks Steffan!

If you've replaced IM with an older version before, you need to reverse
that first so IM gets updates properly, and then applies Steffan's solution
so Lasso 8 remains linked to a separate older build of IM.

tisdag 2 augusti 2016 skrev Anibal Escobar <[hidden email]>:

> Hi, I'm bringing back this old thread.  I'm on Centos 6.7, ImageMagick
> 6.5.4-7 2014-02-10 Q1, Lasso 9.3.1 and Lasso 8.6 on the same machine.  The
> image tag doesn't work on Lasso 9, but does on Lasso 8.  Marc Pope
> downgraded the version of lasso and then it worked on 9, but not 8.  I used
> to have it working on both 8 and 9 but some upgrade somewhere changed
> that.  Does anyone have the image tags working on a setup similar to mine?
>
> Thanks,
> Anibal Escobar
> 646 502 8821
>
>
>
>
> On Jan 15, 2016, at 2:50 AM, Jolle Carlestam wrote:
>
> > 5 jan 2016 kl. 18:14 skrev Jolle Carlestam <[hidden email]
> <javascript:;>>:
> >>
> >> Pretty please, Lassosoft, release a fix.
> >
> > Lassosoft has not released a fix. They did however investigate the issue
> deeply and some iterating over the Lasso Gitter room solved the issue.
> >
> > Apparently Centos made a change as to what ImageMagick library it links
> to between the version Centos 6.6 and 6.7. Lasso 9.3.1 in the present
> distribution is assuming that Centos 6 means Centos 6.7 or higher and links
> to that version of ImageMagick. I am using Centos 6.6 on my servers and
> thus got the failing image handling.
> >
> > The solution for me was to do a painless yum update of ImageMagick,
> restart Lasso and that was it.
> >
> > Huge thanks to Eric for taking his time to solve this with me!
> >
> > HDB
> > Jolle
> >
> > #############################################################
> >
> > This message is sent to you because you are subscribed to
> >  the mailing list Lasso [hidden email] <javascript:;>
> > Official list archives available at http://www.lassotalk.com
> > To unsubscribe, E-mail to: <[hidden email]
> <javascript:;>>
> > Send administrative queries to  <[hidden email]
> <javascript:;>>
>
>
> #############################################################
>
> This message is sent to you because you are subscribed to
>   the mailing list Lasso [hidden email] <javascript:;>
> Official list archives available at http://www.lassotalk.com
> To unsubscribe, E-mail to: <[hidden email]
> <javascript:;>>
> Send administrative queries to  <[hidden email]
> <javascript:;>>
>


--
Mvh
Johan Sölve
____________________________________
Montania System AB
Halmstad   Stockholm
http://www.montania.se

Johan Sölve
Mobil +46 709-51 55 70
[hidden email]

Kristinebergsvägen 17, S-302 41 Halmstad, Sweden
Telefon +46 35-136800 |  Fax +46 35-136801

#############################################################

This message is sent to you because you are subscribed to
  the mailing list Lasso [hidden email]
Official list archives available at http://www.lassotalk.com
To unsubscribe, E-mail to: <[hidden email]>
Send administrative queries to  <[hidden email]>
Loading...