MySQL upgrade breaks search? [SOLVED]

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

MySQL upgrade breaks search? [SOLVED]

Marc Pinnell-3
Apparently, from what I can find, MySQL 4.0x didn't have multiple  
character/collation sets, but 4.1 does. When upgrading it labeled all  
my columns as UTF8. I am guessing that UTF8 is case sensitive where  
MySQL searches were case insensitive before. I tired changing the  
lowercase 'a' and 'lz' to 'A' and 'Lz' in the below statement at it  
started working. I then changed it back to lower case and changed the  
column character set to ascii and ascii_general_ci for collation and  
the original SQL statement started working again!

Hmmm,
Marc

==
I recently upgraded my servers and in the process changed from  
version 4.021 to version 4.1.12 of MySQL. The below search (which  
gets saved as a var and inserted into an inline) was working fine and  
I just noticed that it no longer works! Any ideas?

SELECT EmailAdd, Website, FirstName, LastName, BizName FROM Members  
WHERE BizName BETWEEN 'a' AND 'lz' AND Approved = 'Yes' ORDER BY  
BizName;

It doesn't throw an error, just doesn't find anything. I believe it  
has something to do with the "Between a and lz" part.

Thanx
Marc

--
Marc Pinnell
1027 Consulting
web << DESIGN >> print
PO Box 990872; Redding, CA 96099-0872
www.1027Consulting.com



============================================
Attend the Lasso Summit
February 17-19, 2006 in Fort Lauderdale, FL
http://www.LassoSummit.com/
============================================

--
------------------------------
Lasso Support: http://support.omnipilot.com/
Search the list archives: http://www.listsearch.com/lassotalk.lasso
Manage your list subscription:  
http://www.listsearch.com/lassotalk.lasso?manage