Lasso 9 CentOS 7.4 not processing script syntax

classic Classic list List threaded Threaded
8 messages Options
Reply | Threaded
Open this post in threaded view
|

Lasso 9 CentOS 7.4 not processing script syntax

Ari Denison
I think I must be missing something obvious in lux or my httpd config files, but in new server setup, but I can’t get Lasso to process anything inside <LassoScript … ?> It will only old square bracket [ ] syntax.

My setup is a minimal install of CentOS 7.4, with apache and Lasso 9.3x

Can someone help me understand why this might be happening?

- Ari

#############################################################

This message is sent to you because you are subscribed to
  the mailing list Lasso [hidden email]
Official list archives available at http://www.lassotalk.com
To unsubscribe, E-mail to: <[hidden email]>
Send administrative queries to  <[hidden email]>
Reply | Threaded
Open this post in threaded view
|

Re: Lasso 9 CentOS 7.4 not processing script syntax

stevepiercy
<LassoScript … ?>

or

<?LassoScript … ?>

<?lasso … ?> is supported, and <?LassoScript … ?> is omitted.

http://lassoguide.com/language/calling-lasso.html#calling-lasso-web-pages

--steve


On 3/10/18 at 1:50 PM, [hidden email] (Ari Denison) pronounced:

> I think I must be missing something obvious in lux or my httpd config files, but in new
> server setup, but I can’t get Lasso to process anything inside <LassoScript … ?> It will
> only old square bracket [ ] syntax.
>
> My setup is a minimal install of CentOS 7.4, with apache and Lasso 9.3x
>
> Can someone help me understand why this might be happening?
>
> - Ari
>
> #############################################################
>
> This message is sent to you because you are subscribed to
>   the mailing list Lasso [hidden email]
> Official list archives available at http://www.lassotalk.com
> To unsubscribe, E-mail to: <[hidden email]>
> Send administrative queries to  <[hidden email]>

-- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
Steve Piercy              Website Builder              Eugene, OR
<[hidden email]>               <http://www.stevepiercy.com/>


#############################################################

This message is sent to you because you are subscribed to
  the mailing list Lasso [hidden email]
Official list archives available at http://www.lassotalk.com
To unsubscribe, E-mail to: <[hidden email]>
Send administrative queries to  <[hidden email]>
Reply | Threaded
Open this post in threaded view
|

Re: Lasso 9 CentOS 7.4 not processing script syntax

Ari Denison
Ok, thank you. When did this happen? I have thousands and thousands of <?LassoScript pages that have been running for years.

Do I need to convert my old <?LassoScript pages to <?Lasso or is there some sort of compatibility mode I can use to enable legacy support of LassoScript?

Thanks for the heads up, but I really am wondering why and when this change was made. Seems arbitrary, not that such changes are unusual in languages.



> On Mar 10, 2018, at 1:56 PM, Steve Piercy - Website Builder <[hidden email]> wrote:
>
> <LassoScript … ?>
>
> or
>
> <?LassoScript … ?>
>
> <?lasso … ?> is supported, and <?LassoScript … ?> is omitted.
>
> http://lassoguide.com/language/calling-lasso.html#calling-lasso-web-pages
>
> --steve
>
>
> On 3/10/18 at 1:50 PM, [hidden email] (Ari Denison) pronounced:
>
>> I think I must be missing something obvious in lux or my httpd config files, but in new
>> server setup, but I can’t get Lasso to process anything inside <LassoScript … ?> It will
>> only old square bracket [ ] syntax.
>>
>> My setup is a minimal install of CentOS 7.4, with apache and Lasso 9.3x
>>
>> Can someone help me understand why this might be happening?
>>
>> - Ari
>>
>> #############################################################
>>
>> This message is sent to you because you are subscribed to
>>  the mailing list Lasso [hidden email]
>> Official list archives available at http://www.lassotalk.com
>> To unsubscribe, E-mail to: <[hidden email]>
>> Send administrative queries to  <[hidden email]>
>
> -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
> Steve Piercy              Website Builder              Eugene, OR
> <[hidden email]>               <http://www.stevepiercy.com/>
>
>
> #############################################################
>
> This message is sent to you because you are subscribed to
>  the mailing list Lasso [hidden email]
> Official list archives available at http://www.lassotalk.com
> To unsubscribe, E-mail to: <[hidden email]>
> Send administrative queries to  <[hidden email]>


#############################################################

This message is sent to you because you are subscribed to
  the mailing list Lasso [hidden email]
Official list archives available at http://www.lassotalk.com
To unsubscribe, E-mail to: <[hidden email]>
Send administrative queries to  <[hidden email]>
Reply | Threaded
Open this post in threaded view
|

Re: Lasso 9 CentOS 7.4 not processing script syntax

stevepiercy
I don't know.

Were your files written for Lasso 8?  Lasso 8 syntax is mostly
compatible with Lasso 9, yet not entirely.  The idiosyncratic
differences will cause no end in frustration, none of which are
documented in an upgrade guide.

--steve


On 3/10/18 at 2:03 PM, [hidden email] (Ari Denison) pronounced:

>Ok, thank you. When did this happen? I have thousands and
>thousands of <?LassoScript pages that have been running for years.
>Do I need to convert my old <?LassoScript pages to <?Lasso or
>is there some sort of compatibility mode I can use to enable
>legacy support of LassoScript?
>Thanks for the heads up, but I really am wondering why and when
>this change was made. Seems arbitrary, not that such changes
>are unusual in languages.
>
>
>>On Mar 10, 2018, at 1:56 PM, Steve Piercy - Website Builder <[hidden email]> wrote:
>>
>><LassoScript … ?>
>>
>>or
>>
>><?LassoScript … ?>
>>
>><?lasso … ?> is supported, and <?LassoScript … ?> is omitted.
>>
>>http://lassoguide.com/language/calling-lasso.html#calling-lasso-web-pages
>>
>>--steve
>>
>>
>>On 3/10/18 at 1:50 PM, [hidden email] (Ari Denison) pronounced:
>>
>>>  I think I must be missing something obvious in lux or my
>>>httpd config files, but in new  server setup, but I can’t
>>>get Lasso to process anything inside <LassoScript … ?> It
>>>will  only old square bracket [ ] syntax.   My setup is a
>>>minimal install of CentOS 7.4, with apache and Lasso 9.3x
>>>   Can someone help me understand why this might be
>>>happening?   - Ari
>>>   #############################################################
>>>   This message is sent to you because you are subscribed to
>>>  the mailing list Lasso [hidden email]
>>> Official list archives available at http://www.lassotalk.com
>>> To unsubscribe, E-mail to: <[hidden email]>
>>> Send administrative queries to  <[hidden email]>
>>
>>-- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
>>Steve Piercy              Website Builder              Eugene, OR
>><[hidden email]>               <http://www.stevepiercy.com/>
>>
>>
>>#############################################################
>>
>>This message is sent to you because you are subscribed to
>>the mailing list Lasso [hidden email]
>>Official list archives available at http://www.lassotalk.com
>>To unsubscribe, E-mail to: <[hidden email]>
>>Send administrative queries to  <[hidden email]>
>
>
>#############################################################
>
>This message is sent to you because you are subscribed to
>the mailing list Lasso [hidden email]
>Official list archives available at http://www.lassotalk.com
>To unsubscribe, E-mail to: <[hidden email]>
>Send administrative queries to  <[hidden email]>

-- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
Steve Piercy              Website Builder              Eugene, OR
<[hidden email]>               <http://www.stevepiercy.com/>


#############################################################

This message is sent to you because you are subscribed to
  the mailing list Lasso [hidden email]
Official list archives available at http://www.lassotalk.com
To unsubscribe, E-mail to: <[hidden email]>
Send administrative queries to  <[hidden email]>
Reply | Threaded
Open this post in threaded view
|

Re: Lasso 9 CentOS 7.4 not processing script syntax

Ari Denison
Originally written in 8 then converted to earlier installs 9, and I swear that includes earlier installs of 9.3. It worked in those earlier installs of 9 but not the version I just installed. That’s why I figured there might be a setting I missed. Oh well, easy enough fix with find/replace in bbedit. :)

Thanks again.

> On Mar 10, 2018, at 2:36 PM, Steve Piercy - Website Builder <[hidden email]> wrote:
>
> I don't know.
>
> Were your files written for Lasso 8?  Lasso 8 syntax is mostly compatible with Lasso 9, yet not entirely.  The idiosyncratic differences will cause no end in frustration, none of which are documented in an upgrade guide.
>
> --steve
>
>
> On 3/10/18 at 2:03 PM, [hidden email] (Ari Denison) pronounced:
>
>> Ok, thank you. When did this happen? I have thousands and thousands of <?LassoScript pages that have been running for years.
>> Do I need to convert my old <?LassoScript pages to <?Lasso or is there some sort of compatibility mode I can use to enable legacy support of LassoScript?
>> Thanks for the heads up, but I really am wondering why and when this change was made. Seems arbitrary, not that such changes are unusual in languages.
>>
>>
>>> On Mar 10, 2018, at 1:56 PM, Steve Piercy - Website Builder <[hidden email]> wrote:
>>>
>>> <LassoScript … ?>
>>>
>>> or
>>>
>>> <?LassoScript … ?>
>>>
>>> <?lasso … ?> is supported, and <?LassoScript … ?> is omitted.
>>>
>>> http://lassoguide.com/language/calling-lasso.html#calling-lasso-web-pages
>>>
>>> --steve
>>>
>>>
>>> On 3/10/18 at 1:50 PM, [hidden email] (Ari Denison) pronounced:
>>>
>>>> I think I must be missing something obvious in lux or my httpd config files, but in new  server setup, but I can’t get Lasso to process anything inside <LassoScript … ?> It will  only old square bracket [ ] syntax.   My setup is a minimal install of CentOS 7.4, with apache and Lasso 9.3x
>>>>  Can someone help me understand why this might be happening?   - Ari
>>>>  #############################################################
>>>>  This message is sent to you because you are subscribed to
>>>> the mailing list Lasso [hidden email]
>>>> Official list archives available at http://www.lassotalk.com
>>>> To unsubscribe, E-mail to: <[hidden email]>
>>>> Send administrative queries to  <[hidden email]>
>>>
>>> -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
>>> Steve Piercy              Website Builder              Eugene, OR
>>> <[hidden email]>               <http://www.stevepiercy.com/>
>>>
>>>
>>> #############################################################
>>>
>>> This message is sent to you because you are subscribed to
>>> the mailing list Lasso [hidden email]
>>> Official list archives available at http://www.lassotalk.com
>>> To unsubscribe, E-mail to: <[hidden email]>
>>> Send administrative queries to  <[hidden email]>
>>
>>
>> #############################################################
>>
>> This message is sent to you because you are subscribed to
>> the mailing list Lasso [hidden email]
>> Official list archives available at http://www.lassotalk.com
>> To unsubscribe, E-mail to: <[hidden email]>
>> Send administrative queries to  <[hidden email]>
>
> -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
> Steve Piercy              Website Builder              Eugene, OR
> <[hidden email]>               <http://www.stevepiercy.com/>
>
>
> #############################################################
>
> This message is sent to you because you are subscribed to
> the mailing list Lasso [hidden email]
> Official list archives available at http://www.lassotalk.com
> To unsubscribe, E-mail to: <[hidden email]>
> Send administrative queries to  <[hidden email]>


#############################################################

This message is sent to you because you are subscribed to
  the mailing list Lasso [hidden email]
Official list archives available at http://www.lassotalk.com
To unsubscribe, E-mail to: <[hidden email]>
Send administrative queries to  <[hidden email]>
Reply | Threaded
Open this post in threaded view
|

Re: Lasso 9 CentOS 7.4 not processing script syntax

Tim Taplin
In reply to this post by stevepiercy
Hmm.. I have several sites using <?LassoScript and <?lassoscript on Lasso 9.3 and MacOS

I don’t do much on Linux, so its possible that support was not provided there ? Anyone able to clear this up ?

Tim Taplin


> On Mar 10, 2018, at 2:56 PM, Steve Piercy - Website Builder <[hidden email]> wrote:
>
> <LassoScript … ?>
>
> or
>
> <?LassoScript … ?>
>
> <?lasso … ?> is supported, and <?LassoScript … ?> is omitted.
>
> http://lassoguide.com/language/calling-lasso.html#calling-lasso-web-pages
>
> --steve
>
>
> On 3/10/18 at 1:50 PM, [hidden email] (Ari Denison) pronounced:
>
>> I think I must be missing something obvious in lux or my httpd config files, but in new
>> server setup, but I can’t get Lasso to process anything inside <LassoScript … ?> It will
>> only old square bracket [ ] syntax.
>>
>> My setup is a minimal install of CentOS 7.4, with apache and Lasso 9.3x
>>
>> Can someone help me understand why this might be happening?
>>
>> - Ari
>>
>> #############################################################
>>
>> This message is sent to you because you are subscribed to
>>  the mailing list Lasso [hidden email]
>> Official list archives available at http://www.lassotalk.com
>> To unsubscribe, E-mail to: <[hidden email]>
>> Send administrative queries to  <[hidden email]>
>
> -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
> Steve Piercy              Website Builder              Eugene, OR
> <[hidden email]>               <http://www.stevepiercy.com/>
>
>
> #############################################################
>
> This message is sent to you because you are subscribed to
>  the mailing list Lasso [hidden email]
> Official list archives available at http://www.lassotalk.com
> To unsubscribe, E-mail to: <[hidden email]>
> Send administrative queries to  <[hidden email]>


#############################################################

This message is sent to you because you are subscribed to
  the mailing list Lasso [hidden email]
Official list archives available at http://www.lassotalk.com
To unsubscribe, E-mail to: <[hidden email]>
Send administrative queries to  <[hidden email]>
Reply | Threaded
Open this post in threaded view
|

Re: Lasso 9 CentOS 7.4 not processing script syntax

Jolle Carlestam-2
This was fun.

My experiments shows that the supported versions are indeed
<?lasso ... ?>
<?= ... ?>
and
[ ... ]

So how come
<?lassoscript
?>
works?

Well, my guess is that it’s because the Lasso interpreter is satisfied with the <?lasso as a clue. Whatever comes after that is treated as code. I tried for example
<?lassodate
?>
and it worked too.

In any case I’m using a lot of <?lassoscript in my solutions and they have so far worked without issues on MacOS and Linux in different flavours and with different versions of Lasso 9.2-9.3X.

<lassoscript on the other hand is something I don’t use nor think has been advertised as should work.

HDB
Jolle


> 12 mars 2018 kl. 11:42 skrev Tim Taplin <[hidden email]>:
>
> Hmm.. I have several sites using <?LassoScript and <?lassoscript on Lasso 9.3 and MacOS
>
> I don’t do much on Linux, so its possible that support was not provided there ? Anyone able to clear this up ?
>
> Tim Taplin
>
>
>> On Mar 10, 2018, at 2:56 PM, Steve Piercy - Website Builder <[hidden email]> wrote:
>>
>> <LassoScript … ?>
>>
>> or
>>
>> <?LassoScript … ?>
>>
>> <?lasso … ?> is supported, and <?LassoScript … ?> is omitted.
>>
>> http://lassoguide.com/language/calling-lasso.html#calling-lasso-web-pages
>>
>> --steve
>>
>>
>> On 3/10/18 at 1:50 PM, [hidden email] (Ari Denison) pronounced:
>>
>>> I think I must be missing something obvious in lux or my httpd config files, but in new
>>> server setup, but I can’t get Lasso to process anything inside <LassoScript … ?> It will
>>> only old square bracket [ ] syntax.
>>>
>>> My setup is a minimal install of CentOS 7.4, with apache and Lasso 9.3x
>>>
>>> Can someone help me understand why this might be happening?
>>>
>>> - Ari
>>>
>>> #############################################################
>>>
>>> This message is sent to you because you are subscribed to
>>> the mailing list Lasso [hidden email]
>>> Official list archives available at http://www.lassotalk.com
>>> To unsubscribe, E-mail to: <[hidden email]>
>>> Send administrative queries to  <[hidden email]>
>>
>> -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
>> Steve Piercy              Website Builder              Eugene, OR
>> <[hidden email]>               <http://www.stevepiercy.com/>
>>
>>
>> #############################################################
>>
>> This message is sent to you because you are subscribed to
>> the mailing list Lasso [hidden email]
>> Official list archives available at http://www.lassotalk.com
>> To unsubscribe, E-mail to: <[hidden email]>
>> Send administrative queries to  <[hidden email]>
>
>
> #############################################################
>
> This message is sent to you because you are subscribed to
>  the mailing list Lasso [hidden email]
> Official list archives available at http://www.lassotalk.com
> To unsubscribe, E-mail to: <[hidden email]>
> Send administrative queries to  <[hidden email]>


#############################################################

This message is sent to you because you are subscribed to
  the mailing list Lasso [hidden email]
Official list archives available at http://www.lassotalk.com
To unsubscribe, E-mail to: <[hidden email]>
Send administrative queries to  <[hidden email]>
Reply | Threaded
Open this post in threaded view
|

Re: Lasso 9 CentOS 7.4 not processing script syntax

stevepiercy
Perhaps it is in compat for 8?

--steve


On 3/12/18 at 12:10 PM, [hidden email] (Jolle Carlestam) pronounced:

>This was fun.
>
>My experiments shows that the supported versions are indeed
><?lasso ... ?>
><?= ... ?>
>and
>[ ... ]
>
>So how come
><?lassoscript
>?>
>works?
>
>Well, my guess is that it’s because the Lasso interpreter is
>satisfied with the <?lasso as a clue. Whatever comes after that
>is treated as code. I tried for example
><?lassodate
>?>
>and it worked too.
>
>In any case I’m using a lot of <?lassoscript in my solutions
>and they have so far worked without issues on MacOS and Linux
>in different flavours and with different versions of Lasso 9.2-9.3X.
>
><lassoscript on the other hand is something I don’t use nor
>think has been advertised as should work.
>
>HDB
>Jolle
>
>
>>12 mars 2018 kl. 11:42 skrev Tim Taplin <[hidden email]>:
>>
>>Hmm.. I have several sites using <?LassoScript and <?lassoscript on Lasso 9.3 and MacOS
>>
>>I don’t do much on Linux, so its possible that support was not provided there ? Anyone
>able to clear this up ?
>>
>>Tim Taplin
>>
>>
>>> On Mar 10, 2018, at 2:56 PM, Steve Piercy - Website Builder <[hidden email]> wrote:
>>>   <LassoScript … ?>
>>>   or
>>>   <?LassoScript … ?>
>>>   <?lasso … ?> is supported, and <?LassoScript … ?> is omitted.
>>>   http://lassoguide.com/language/calling-lasso.html#calling-lasso-web-pages
>>>   --steve
>>>    On 3/10/18 at 1:50 PM, [hidden email] (Ari
>>>Denison) pronounced:
>>>
>>>>  I think I must be missing something obvious in lux or my
>>>>httpd config files, but in new  server setup, but I can’t
>>>>get Lasso to process anything inside <LassoScript … ?> It
>will
>>>>  only old square bracket [ ] syntax.   My setup is a
>>>>minimal install of CentOS 7.4, with apache and Lasso 9.3x
>>>>   Can someone help me understand why this might be
>>>>happening?   - Ari
>>>>   #############################################################
>>>>   This message is sent to you because you are subscribed to
>>>> the mailing list Lasso [hidden email]
>>>> Official list archives available at http://www.lassotalk.com
>>>> To unsubscribe, E-mail to: <[hidden email]>
>>>> Send administrative queries to  <[hidden email]>
>>>   -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
>>>-- -- --
>>> Steve Piercy              Website Builder              Eugene, OR
>>> <[hidden email]>               <http://www.stevepiercy.com/>
>>>    #############################################################
>>>   This message is sent to you because you are subscribed to
>>> the mailing list Lasso [hidden email]
>>> Official list archives available at http://www.lassotalk.com
>>> To unsubscribe, E-mail to: <[hidden email]>
>>> Send administrative queries to  <[hidden email]>
>>
>>
>>#############################################################
>>
>>This message is sent to you because you are subscribed to
>>the mailing list Lasso [hidden email]
>>Official list archives available at http://www.lassotalk.com
>>To unsubscribe, E-mail to: <[hidden email]>
>>Send administrative queries to  <[hidden email]>
>
>
>#############################################################
>
>This message is sent to you because you are subscribed to
>the mailing list Lasso [hidden email]
>Official list archives available at http://www.lassotalk.com
>To unsubscribe, E-mail to: <[hidden email]>
>Send administrative queries to  <[hidden email]>

-- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
Steve Piercy              Website Builder              Eugene, OR
<[hidden email]>               <http://www.stevepiercy.com/>


#############################################################

This message is sent to you because you are subscribed to
  the mailing list Lasso [hidden email]
Official list archives available at http://www.lassotalk.com
To unsubscribe, E-mail to: <[hidden email]>
Send administrative queries to  <[hidden email]>