Lasso 9.3.1 on OS X 10.11.4

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|

Lasso 9.3.1 on OS X 10.11.4

Eric Knibbe-2
The current release of Lasso 9.3.1 doesn't run on OS X 10.11.4, failing with the error "dyld: Symbol not found: _EVP_rc5_32_12_16_cbc". It appears related to the most recent security update, which bumped the included OpenSSL libraries to 0.9.8zh. It turns out that using the OpenSSL from Apple's SDK has been deprecated for a while, so the build below statically-links to version 1.0.1s instead. In my testing it runs fine in OS X 10.7 through 10.11, but I'm posting it here before I change the link on the download page.

<http://www.lassosoft.com/_downloads/public/Lasso_Server/BETA/Lasso-Server-for-Mac-9.3.1-5BETA.zip>

‐‐‐‐‐‐‐‐‐‐✂‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐
Eric3
 


#############################################################

This message is sent to you because you are subscribed to
  the mailing list Lasso [hidden email]
Official list archives available at http://www.lassotalk.com
To unsubscribe, E-mail to: <[hidden email]>
Send administrative queries to  <[hidden email]>
Reply | Threaded
Open this post in threaded view
|

Re: Lasso 9.3.1 on OS X 10.11.4

Jolle Carlestam-2
Downloaded and installed on my 10.11.3 machine. Works like a charm.

HDB
Jolle

Sent from a mobile device. Any anomalies is due to Autocorrect.

> 24 mars 2016 kl. 20:26 skrev Eric Knibbe <[hidden email]>:
>
> The current release of Lasso 9.3.1 doesn't run on OS X 10.11.4, failing with the error "dyld: Symbol not found: _EVP_rc5_32_12_16_cbc". It appears related to the most recent security update, which bumped the included OpenSSL libraries to 0.9.8zh. It turns out that using the OpenSSL from Apple's SDK has been deprecated for a while, so the build below statically-links to version 1.0.1s instead. In my testing it runs fine in OS X 10.7 through 10.11, but I'm posting it here before I change the link on the download page.
>
> <http://www.lassosoft.com/_downloads/public/Lasso_Server/BETA/Lasso-Server-for-Mac-9.3.1-5BETA.zip>
>
> ‐‐‐‐‐‐‐‐‐‐✂‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐
> Eric3
>
>
>
> #############################################################
>
> This message is sent to you because you are subscribed to
>  the mailing list Lasso [hidden email]
> Official list archives available at http://www.lassotalk.com
> To unsubscribe, E-mail to: <[hidden email]>
> Send administrative queries to  <[hidden email]>


#############################################################

This message is sent to you because you are subscribed to
  the mailing list Lasso [hidden email]
Official list archives available at http://www.lassotalk.com
To unsubscribe, E-mail to: <[hidden email]>
Send administrative queries to  <[hidden email]>
Reply | Threaded
Open this post in threaded view
|

Re: Lasso 9.3.1 on OS X 10.11.4

Marc Vos-3
Installed the 9.3.1-5BETA on 10.11.4 and it works.

- -
Marc

> On 26 mrt. 2016, at 01:39, Jolle Carlestam <[hidden email]> wrote:
>
> Downloaded and installed on my 10.11.3 machine. Works like a charm.
>
> HDB
> Jolle
>
> Sent from a mobile device. Any anomalies is due to Autocorrect.
>
>> 24 mars 2016 kl. 20:26 skrev Eric Knibbe <[hidden email]>:
>>
>> The current release of Lasso 9.3.1 doesn't run on OS X 10.11.4, failing with the error "dyld: Symbol not found: _EVP_rc5_32_12_16_cbc". It appears related to the most recent security update, which bumped the included OpenSSL libraries to 0.9.8zh. It turns out that using the OpenSSL from Apple's SDK has been deprecated for a while, so the build below statically-links to version 1.0.1s instead. In my testing it runs fine in OS X 10.7 through 10.11, but I'm posting it here before I change the link on the download page.
>>
>> <http://www.lassosoft.com/_downloads/public/Lasso_Server/BETA/Lasso-Server-for-Mac-9.3.1-5BETA.zip>
>>
>> ‐‐‐‐‐‐‐‐‐‐✂‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐
>> Eric3
>>
>>
>>
>> #############################################################
>>
>> This message is sent to you because you are subscribed to
>> the mailing list Lasso [hidden email]
>> Official list archives available at http://www.lassotalk.com
>> To unsubscribe, E-mail to: <[hidden email]>
>> Send administrative queries to  <[hidden email]>
>
>
> #############################################################
>
> This message is sent to you because you are subscribed to
>  the mailing list Lasso [hidden email]
> Official list archives available at http://www.lassotalk.com
> To unsubscribe, E-mail to: <[hidden email]>
> Send administrative queries to  <[hidden email]>


#############################################################

This message is sent to you because you are subscribed to
  the mailing list Lasso [hidden email]
Official list archives available at http://www.lassotalk.com
To unsubscribe, E-mail to: <[hidden email]>
Send administrative queries to  <[hidden email]>
Reply | Threaded
Open this post in threaded view
|

Re: Lasso 9.3.1 on OS X 10.11.4

Ke Carlton-3
In reply to this post by Eric Knibbe-2
Can confirm was just hit by this on a fresh El Capitan update — 10.11.4
(15E65).

Attempted with Lasso-Server-for-Mac-9.3.1-4 and failed with:

dyld: _dyld_bind_fully_image_containing_address() error
dyld: Symbol not found: _EVP_rc5_32_12_16_cbc
 Referenced from: /Library/Frameworks/Lasso9.framework/Versions/B/Lasso9
 Expected in: /usr/lib/libcrypto.0.9.8.dylib
in /Library/Frameworks/Lasso9.framework/Versions/B/Lasso9
Trace/BPT trap: 5

Scratched my head for a long time until came across this email.

Worked OK with Lasso Server for Mac 9.3.1-5.

Probably best to get this release out sooner rather than later.

Ke

On Fri, Mar 25, 2016 at 8:27 AM Eric Knibbe <[hidden email]> wrote:

> The current release of Lasso 9.3.1 doesn't run on OS X 10.11.4, failing
> with the error "dyld: Symbol not found: _EVP_rc5_32_12_16_cbc". It appears
> related to the most recent security update, which bumped the included
> OpenSSL libraries to 0.9.8zh. It turns out that using the OpenSSL from
> Apple's SDK has been deprecated for a while, so the build below
> statically-links to version 1.0.1s instead. In my testing it runs fine in
> OS X 10.7 through 10.11, but I'm posting it here before I change the link
> on the download page.
>
> <
> http://www.lassosoft.com/_downloads/public/Lasso_Server/BETA/Lasso-Server-for-Mac-9.3.1-5BETA.zip
> >
>
> ‐‐‐‐‐‐‐‐‐‐✂‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐
> Eric3
>
>
>

#############################################################

This message is sent to you because you are subscribed to
  the mailing list Lasso [hidden email]
Official list archives available at http://www.lassotalk.com
To unsubscribe, E-mail to: <[hidden email]>
Send administrative queries to  <[hidden email]>
Reply | Threaded
Open this post in threaded view
|

Re: Lasso 9.3.1 on OS X 10.11.4

Ke Carlton-3
Had to chown /var/lasso to _lasso:_lasso in order to create an instance —
so perhaps that's something to check.

It was root:wheel — but creating an instance just stalled without anything
happening.

Ke

On Mon, Apr 18, 2016 at 4:38 PM Ke Carlton <[hidden email]> wrote:

> Can confirm was just hit by this on a fresh El Capitan update — 10.11.4
> (15E65).
>
> Attempted with Lasso-Server-for-Mac-9.3.1-4 and failed with:
>
> dyld: _dyld_bind_fully_image_containing_address() error
> dyld: Symbol not found: _EVP_rc5_32_12_16_cbc
>  Referenced from: /Library/Frameworks/Lasso9.framework/Versions/B/Lasso9
>  Expected in: /usr/lib/libcrypto.0.9.8.dylib
> in /Library/Frameworks/Lasso9.framework/Versions/B/Lasso9
> Trace/BPT trap: 5
>
> Scratched my head for a long time until came across this email.
>
> Worked OK with Lasso Server for Mac 9.3.1-5.
>
> Probably best to get this release out sooner rather than later.
>
> Ke
>
> On Fri, Mar 25, 2016 at 8:27 AM Eric Knibbe <[hidden email]> wrote:
>
>> The current release of Lasso 9.3.1 doesn't run on OS X 10.11.4, failing
>> with the error "dyld: Symbol not found: _EVP_rc5_32_12_16_cbc". It appears
>> related to the most recent security update, which bumped the included
>> OpenSSL libraries to 0.9.8zh. It turns out that using the OpenSSL from
>> Apple's SDK has been deprecated for a while, so the build below
>> statically-links to version 1.0.1s instead. In my testing it runs fine in
>> OS X 10.7 through 10.11, but I'm posting it here before I change the link
>> on the download page.
>>
>> <
>> http://www.lassosoft.com/_downloads/public/Lasso_Server/BETA/Lasso-Server-for-Mac-9.3.1-5BETA.zip
>> >
>>
>> ‐‐‐‐‐‐‐‐‐‐✂‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐
>> Eric3
>>
>>
>>

#############################################################

This message is sent to you because you are subscribed to
  the mailing list Lasso [hidden email]
Official list archives available at http://www.lassotalk.com
To unsubscribe, E-mail to: <[hidden email]>
Send administrative queries to  <[hidden email]>
Reply | Threaded
Open this post in threaded view
|

Re: Lasso 9.3.1 on OS X 10.11.4

Da'oud Rashid
For me, Lasso would not start automatically on OS X 10.11.4 with the 9.3.1-5 beta.

It seems the launch daemon had been disabled at some point (probably with one of several operating system updates after installing and uninstalling Lasso 9 ages ago…I had the same issue with 9.3.1 on OS X 10.10).

Executing the following from the command line seems to have fixed the issue:

launchctl load -w /Library/LaunchDaemons/com.lassosoft.lassoinstancemanager.plist

Note that the -w flag above overrides the disabled key and sets it to false for a launchctl load and true for an unload.

Hope this helps someone in a similar situation.

Kind regards,
Da'oud

> On Apr 18, 2016, at 5:43 AM, Ke Carlton <[hidden email]> wrote:
>
> Had to chown /var/lasso to _lasso:_lasso in order to create an instance —
> so perhaps that's something to check.
>
> It was root:wheel — but creating an instance just stalled without anything
> happening.
>
> Ke
>
> On Mon, Apr 18, 2016 at 4:38 PM Ke Carlton <[hidden email]> wrote:
>
>> Can confirm was just hit by this on a fresh El Capitan update — 10.11.4
>> (15E65).
>>
>> Attempted with Lasso-Server-for-Mac-9.3.1-4 and failed with:
>>
>> dyld: _dyld_bind_fully_image_containing_address() error
>> dyld: Symbol not found: _EVP_rc5_32_12_16_cbc
>> Referenced from: /Library/Frameworks/Lasso9.framework/Versions/B/Lasso9
>> Expected in: /usr/lib/libcrypto.0.9.8.dylib
>> in /Library/Frameworks/Lasso9.framework/Versions/B/Lasso9
>> Trace/BPT trap: 5
>>
>> Scratched my head for a long time until came across this email.
>>
>> Worked OK with Lasso Server for Mac 9.3.1-5.
>>
>> Probably best to get this release out sooner rather than later.
>>
>> Ke
>>
>> On Fri, Mar 25, 2016 at 8:27 AM Eric Knibbe <[hidden email]> wrote:
>>
>>> The current release of Lasso 9.3.1 doesn't run on OS X 10.11.4, failing
>>> with the error "dyld: Symbol not found: _EVP_rc5_32_12_16_cbc". It appears
>>> related to the most recent security update, which bumped the included
>>> OpenSSL libraries to 0.9.8zh. It turns out that using the OpenSSL from
>>> Apple's SDK has been deprecated for a while, so the build below
>>> statically-links to version 1.0.1s instead. In my testing it runs fine in
>>> OS X 10.7 through 10.11, but I'm posting it here before I change the link
>>> on the download page.
>>>
>>> <
>>> http://www.lassosoft.com/_downloads/public/Lasso_Server/BETA/Lasso-Server-for-Mac-9.3.1-5BETA.zip
>>>>
>>>
>>> ‐‐‐‐‐‐‐‐‐‐✂‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐
>>> Eric3
>>>
>>>
>>>
>
> #############################################################
>
> This message is sent to you because you are subscribed to
>  the mailing list Lasso [hidden email]
> Official list archives available at http://www.lassotalk.com
> To unsubscribe, E-mail to: <[hidden email]>
> Send administrative queries to  <[hidden email]>


#############################################################

This message is sent to you because you are subscribed to
  the mailing list Lasso [hidden email]
Official list archives available at http://www.lassotalk.com
To unsubscribe, E-mail to: <[hidden email]>
Send administrative queries to  <[hidden email]>