LP8 with MacPorts Apache2

classic Classic list List threaded Threaded
8 messages Options
Reply | Threaded
Open this post in threaded view
|

LP8 with MacPorts Apache2

Greg Willits-2
Are there any problems with running Lasso 8.1 for Apache2 from MacPorts?

The installer talks about Complete Apache 2.0. Is it just a matter of  
pushing some files around?

-- gw




============================================
Attend the Lasso Summit
March 2-4, 2007 in Fort Lauderdale, FL
http://www.LassoSummit.com/
============================================

------------------------------
Lasso Support: http://support.omnipilot.com/
Search the list archives: http://www.listsearch.com/lassotalk.lasso
Manage your list subscription:  
http://www.listsearch.com/lassotalk.lasso?manage
Reply | Threaded
Open this post in threaded view
|

Re: LP8 with MacPorts Apache2

Greg Willits-2
On Feb 24, 2007, at 7:50 PM, Greg Willits wrote:

> Are there any problems with running Lasso 8.1 for Apache2 from  
> MacPorts?
> The installer talks about Complete Apache 2.0. Is it just a matter  
> of pushing some files around?

Dang forget to mention I need it to run under Apache 2.2 not 2.0

-- gw

============================================
Attend the Lasso Summit
March 2-4, 2007 in Fort Lauderdale, FL
http://www.LassoSummit.com/
============================================

------------------------------
Lasso Support: http://support.omnipilot.com/
Search the list archives: http://www.listsearch.com/lassotalk.lasso
Manage your list subscription:  
http://www.listsearch.com/lassotalk.lasso?manage
Reply | Threaded
Open this post in threaded view
|

Re: LP8 with MacPorts Apache2

Greg Willits-2
On Feb 24, 2007, at 7:52 PM, Greg Willits wrote:
> On Feb 24, 2007, at 7:50 PM, Greg Willits wrote:
>
>> Are there any problems with running Lasso 8.1 for Apache2 from  
>> MacPorts?
>> The installer talks about Complete Apache 2.0. Is it just a matter  
>> of pushing some files around?
>> I need it to run under Apache 2.2 not 2.0


Well, the short answer would appear to be "no."

I installed the one for iAssist so the files would be easy to find. I  
moved Lasso8ConnectorforAache2.so to the Apache2 modules folder (/opt/
local/apache2/modules/) and moved lasso8.conf so I could include it/

Upon launch, Apache gripes about the connector being garbled.

From: http://httpd.apache.org/docs/2.2/upgrading.html
        "Many third-party modules designed for version 2.0 will work  
unchanged with the the Apache HTTP Server version 2.2. But all  
modules must be recompiled before being loaded."

I found the Lasso connector source, but I'm not finding any info on  
how to tweak it/compile it for Apache 2.2

BTW, at this point, it would seem support for iAssist should be  
removed (abandoned app) and support for Ports & Fink added.

-- gw




============================================
Attend the Lasso Summit
March 2-4, 2007 in Fort Lauderdale, FL
http://www.LassoSummit.com/
============================================

------------------------------
Lasso Support: http://support.omnipilot.com/
Search the list archives: http://www.listsearch.com/lassotalk.lasso
Manage your list subscription:  
http://www.listsearch.com/lassotalk.lasso?manage
Reply | Threaded
Open this post in threaded view
|

Re: LP8 with MacPorts Apache2

Fletcher Sandbeck
> Well, the short answer would appear to be "no."
>
> I installed the one for iAssist so the files would be easy to find. I  
> moved Lasso8ConnectorforAache2.so to the Apache2 modules folder (/opt/
> local/apache2/modules/) and moved lasso8.conf so I could include it/
>
> Upon launch, Apache gripes about the connector being garbled.
>
> From: http://httpd.apache.org/docs/2.2/upgrading.html
>   "Many third-party modules designed for version 2.0 will work  
> unchanged with the the Apache HTTP Server version 2.2. But all  
> modules must be recompiled before being loaded."
>
> I found the Lasso connector source, but I'm not finding any info on  
> how to tweak it/compile it for Apache 2.2

The Extensions folder contains a build of the Apache 2.2 module, but it
must be manually placed in the proper location.

[fletcher]
--
Fletcher Sandbeck                         [hidden email]
Director of Product Development       http://www.lassostudio.com
OmniPilot Software, Inc.                http://www.omnipilot.com

============================================
Attend the Lasso Summit
March 2-4, 2007 in Fort Lauderdale, FL
http://www.LassoSummit.com/
============================================

------------------------------
Lasso Support: http://support.omnipilot.com/
Search the list archives: http://www.listsearch.com/lassotalk.lasso
Manage your list subscription:  
http://www.listsearch.com/lassotalk.lasso?manage
Reply | Threaded
Open this post in threaded view
|

Re: LP8 with MacPorts Apache2

Jonathan Guthrie-5
In reply to this post by Greg Willits-2
It's not often we can reply to our own questions twice over :)

On 25/02/2007, at 7:25 PM, Greg Willits wrote:

> On Feb 24, 2007, at 7:52 PM, Greg Willits wrote:
>> On Feb 24, 2007, at 7:50 PM, Greg Willits wrote:
>>
>>> Are there any problems with running Lasso 8.1 for Apache2 from  
>>> MacPorts?
>>> The installer talks about Complete Apache 2.0. Is it just a  
>>> matter of pushing some files around?
>>> I need it to run under Apache 2.2 not 2.0
>
>
> Well, the short answer would appear to be "no."


Jono

// ---------------------------------------------------------
/*
     Jonathan Guthrie
     xServe Ltd, Wellington NZ
     [hidden email]   |   http://xserve.co.nz
     DDI +64 4 978 7388   |   Mob +64 21 678890

*/
// ---------------------------------------------------------



============================================
Attend the Lasso Summit
March 2-4, 2007 in Fort Lauderdale, FL
http://www.LassoSummit.com/
============================================

------------------------------
Lasso Support: http://support.omnipilot.com/
Search the list archives: http://www.listsearch.com/lassotalk.lasso
Manage your list subscription:  
http://www.listsearch.com/lassotalk.lasso?manage
Reply | Threaded
Open this post in threaded view
|

Re: LP8 with MacPorts Apache2

Greg Willits-2
In reply to this post by Fletcher Sandbeck
On Feb 24, 2007, at 10:38 PM, Fletcher Sandbeck wrote:

>> Well, the short answer would appear to be "no."
>>
>> I installed the one for iAssist so the files would be easy to find. I
>> moved Lasso8ConnectorforAache2.so to the Apache2 modules folder (/
>> opt/
>> local/apache2/modules/) and moved lasso8.conf so I could include it/
>>
>> Upon launch, Apache gripes about the connector being garbled.
>>
>> From: http://httpd.apache.org/docs/2.2/upgrading.html
>>   "Many third-party modules designed for version 2.0 will work
>> unchanged with the the Apache HTTP Server version 2.2. But all
>> modules must be recompiled before being loaded."
>>
>> I found the Lasso connector source, but I'm not finding any info on
>> how to tweak it/compile it for Apache 2.2
>
> The Extensions folder contains a build of the Apache 2.2 module,  
> but it
> must be manually placed in the proper location.


Hmm. Not on my system. Ah, then I figured you might be talking 8.5 --  
yep, there it is.

Fingers crossed it works with 8.1...

-- gw



============================================
Attend the Lasso Summit
March 2-4, 2007 in Fort Lauderdale, FL
http://www.LassoSummit.com/
============================================

------------------------------
Lasso Support: http://support.omnipilot.com/
Search the list archives: http://www.listsearch.com/lassotalk.lasso
Manage your list subscription:  
http://www.listsearch.com/lassotalk.lasso?manage
Reply | Threaded
Open this post in threaded view
|

Re: LP8 with MacPorts Apache2

Greg Willits-2
In reply to this post by Jonathan Guthrie-5
I taught Pilson everything he knows about answering his own questions...


On Feb 24, 2007, at 10:42 PM, Jonathan Guthrie wrote:

> It's not often we can reply to our own questions twice over :)
>
> On 25/02/2007, at 7:25 PM, Greg Willits wrote:
>
>> On Feb 24, 2007, at 7:52 PM, Greg Willits wrote:
>>> On Feb 24, 2007, at 7:50 PM, Greg Willits wrote:
>>>
>>>> Are there any problems with running Lasso 8.1 for Apache2 from  
>>>> MacPorts?
>>>> The installer talks about Complete Apache 2.0. Is it just a  
>>>> matter of pushing some files around?
>>>> I need it to run under Apache 2.2 not 2.0
>>
>>
>> Well, the short answer would appear to be "no."


============================================
Attend the Lasso Summit
March 2-4, 2007 in Fort Lauderdale, FL
http://www.LassoSummit.com/
============================================

------------------------------
Lasso Support: http://support.omnipilot.com/
Search the list archives: http://www.listsearch.com/lassotalk.lasso
Manage your list subscription:  
http://www.listsearch.com/lassotalk.lasso?manage
Reply | Threaded
Open this post in threaded view
|

Re: LP8 with MacPorts Apache2

Simon Forster
In reply to this post by Greg Willits-2


On 25 Feb 2007, at 03:50, Greg Willits wrote:

> Are there any problems with running Lasso 8.1 for Apache2 from  
> MacPorts?

FWIW, I had it running on a system here absolutely fine.

Simon Forster
_______________________________________________________
  LDML Ltd, 62 Pall Mall, London, SW1Y 5HZ, UK
  Tel: +44 (0)20 8133 0528   Fax: +44 (0)70 9230 5247
_______________________________________________________

============================================
Attend the Lasso Summit
March 2-4, 2007 in Fort Lauderdale, FL
http://www.LassoSummit.com/
============================================

------------------------------
Lasso Support: http://support.omnipilot.com/
Search the list archives: http://www.listsearch.com/lassotalk.lasso
Manage your list subscription:  
http://www.listsearch.com/lassotalk.lasso?manage