LCAPI make on RHEL4

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

LCAPI make on RHEL4

Petrus Näslund
I'm trying to recompile one of my LCAPI tags for LP8 on RHEL4 but get errors during make. It compiles fine on OSX.
I then try to compile one of OmniPilots own example files and get the same error...

---
[root@localhost Lasso Connector for Apache]# make
c++ -I/usr/include/apache -Wno-multichar -DMACHINE_LINUX=1 -DEAPI -DEAPI -I../../../../LCAPI -I/usr/include/apache -Wno-multichar -DMACHINE_LINUX=1 -DEAPI -DEAPI -I../../../../LCAPI  -c -o Lasso8ConnectorforApache.o Lasso8ConnectorforApache.c
make: c++: Command not found
make: *** [Lasso8ConnectorforApache.o] Error 127
---

I suppose that I might have to install some extra packages in RHEL, but the manual is kinda sparse on Linux info!
From what I have understood from other sources, the gcc comes without the c++ compiler in the RHEL4 installation?
I have the following installed:
libgcc-3.4.3-9.EL4
libstdc++-3.4.3-9.EL4

Is anyone compiling LCAPI c++ happily on RHEL4 and able to provide some info on his/her setup?

//Petrus





--
------------------------------
Lasso Support: http://support.omnipilot.com/
Search the list archives: http://www.listsearch.com/lassotalk.lasso
Manage your list subscription:  
http://www.listsearch.com/lassotalk.lasso?manage
Reply | Threaded
Open this post in threaded view
|

Re: LCAPI make on RHEL4

cJJUNnH41s90Y
CONTENTS DELETED
The author has deleted this message.
Reply | Threaded
Open this post in threaded view
|

Re: LCAPI make on RHEL4

Petrus Näslund
In reply to this post by Petrus Näslund
I have now compiled my tag succesfully for LP8 on RHEL4 :-)
I needed to install some packages and tweak the makefile a bit.

The following rpm's were needed for me (installed in order):

glibc-kernheaders-2.4-9.1.87.i386.rpm
glibc-headers-2.3.4-2.i386.rpm
glibc-devel-2.3.4-2.i386.rpm
gcc-3.4.3-9.EL4.i386.rpm
libstdc++-devel-3.4.3-9.EL4.i386.rpm
gcc-c++-3.4.3-9.EL4.i386.rpm
zlib-devel-1.2.1.2-1.i386.rpm

//Petrus



On Tuesday, May 31, 2005, at 01:27PM, noah williamsson <[hidden email]> wrote:

>[hidden email] wrote:
>> [root@localhost Lasso Connector for Apache]# make
>> c++ -I/usr/include/apache -Wno-multichar -DMACHINE_LINUX=1 -DEAPI -DEAPI
>> -I../../../../LCAPI -I/usr/include/apache -Wno-multichar
>> -DMACHINE_LINUX=1 -DEAPI -DEAPI -I../../../../LCAPI  -c -o
>> Lasso8ConnectorforApache.o Lasso8ConnectorforApache.c
>> make: c++: Command not found
>> make: *** [Lasso8ConnectorforApache.o] Error 127
>> ---
>>
>> I suppose that I might have to install some extra packages in RHEL, but
>> the manual is kinda sparse on Linux info!
>>  From what I have understood from other sources, the gcc comes without
>> the c++ compiler in the RHEL4 installation?
>> I have the following installed:
>> libgcc-3.4.3-9.EL4
>> libstdc++-3.4.3-9.EL4
>
>These are just GCC's runtime library and GNU's standard C++ library.
>You need to install the C++ compiler and/or the compiler suite too.
>
>For RedHat 9 these packages were available for download
>gcc-3.2.2-5.i386.rpm           gcc-g77-3.2.2-5.i386.rpm
>gcc-java-3.2.2-5.i386.rpm      gcc-c++-3.2.2-5.i386.rpm
>gcc-gnat-3.2.2-5.i386.rpm      gcc-objc-3.2.2-5.i386.rpm
>
>The ones you would need if you were running RH9 would be gcc-3.2.2-5 and
>gcc-c++-3.2.2-5 (use rpm's query option to see whether these are
>installed or not).
>
>If i recall correctly, RedHat comes with a GUI tool (up2date?) which
>allows you to browse among available packages from RedHat Network.
>
>   -- noah
>
>--
>------------------------------
>Lasso Support: http://support.omnipilot.com/
>Search the list archives: http://www.listsearch.com/lassotalk.lasso
>Manage your list subscription:  
>http://www.listsearch.com/lassotalk.lasso?manage
>
>

--
------------------------------
Lasso Support: http://support.omnipilot.com/
Search the list archives: http://www.listsearch.com/lassotalk.lasso
Manage your list subscription:  
http://www.listsearch.com/lassotalk.lasso?manage