Image: The image tags have not loaded... Again !

classic Classic list List threaded Threaded
12 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Image: The image tags have not loaded... Again !

bienvenue
Hi all,

ImageMagick and Lasso seem to be a tricky story.

Posts about are numerous...
...As this one about installation on CentOS
http://lasso.2283332.n4.nabble.com/Lasso-8-6-3-imageMagick-not-loading-td4644637.html

Well, we are running Lasso 8.6.+ on a virtual CentOS / Apache machine.

In an old app, which has been for years, from update to update, we suddenly had this error this morning :
"Image: The image tags have not loaded. This is usually due to ImageMagick or X11 not being installed. at: Image with params: '/folder/path-to-image.gif"
Something must have change in the VM, but we don't know what.

ImageMagick 6.7 was involved (and running ok). Reading posts, we decided to downgrade to IM 6.5 4 7.
The app is throwing the same error.
(We notice that aside this installation changed our apache config to run .htm files with Lasso)

We checked the /usr/lib64/libMagickCore.so, we have :
libMagickCore.so.2.0.0
and two aliases :
libMagickCore.so
libMagickCore.so.2

But image tags do not work, calls throw the same error ...

To allow users to work with the app, we moved it temporarly to another Lasso VM where the image tag run ok.
But we have to fix the problem on this VM.

Any hints about the points to check around ?
Thank for your advices, welcome...
---
Jean-Pierre Kocherhans
E SYSTEMES
F-59000 LILLE

#############################################################

This message is sent to you because you are subscribed to
  the mailing list Lasso [hidden email]
Official list archives available at http://www.lassotalk.com
To unsubscribe, E-mail to: <[hidden email]>
Send administrative queries to  <[hidden email]>
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Image: The image tags have not loaded... Again !

Johan Solve
Make sure you follow the advice from Steffan in the last comment (posted by
me)

On 30 August 2016 at 18:28, bienvenue <[hidden email]> wrote:

> Hi all,
>
> ImageMagick and Lasso seem to be a tricky story.
>
> Posts about are numerous...
> ...As this one about installation on CentOS
> http://lasso.2283332.n4.nabble.com/Lasso-8-6-3-imageMagick-not-loading-
> td4644637.html
>
> Well, we are running Lasso 8.6.+ on a virtual CentOS / Apache machine.
>
> In an old app, which has been for years, from update to update, we
> suddenly had this error this morning :
> "Image: The image tags have not loaded. This is usually due to ImageMagick
> or X11 not being installed. at: Image with params:
> '/folder/path-to-image.gif"
> Something must have change in the VM, but we don't know what.
>
> ImageMagick 6.7 was involved (and running ok). Reading posts, we decided
> to downgrade to IM 6.5 4 7.
> The app is throwing the same error.
> (We notice that aside this installation changed our apache config to run
> .htm files with Lasso)
>
> We checked the /usr/lib64/libMagickCore.so, we have :
> libMagickCore.so.2.0.0
> and two aliases :
> libMagickCore.so
> libMagickCore.so.2
>
> But image tags do not work, calls throw the same error ...
>
> To allow users to work with the app, we moved it temporarly to another
> Lasso VM where the image tag run ok.
> But we have to fix the problem on this VM.
>
> Any hints about the points to check around ?
> Thank for your advices, welcome...
> ---
> Jean-Pierre Kocherhans
> E SYSTEMES
> F-59000 LILLE
>
> #############################################################
>
> This message is sent to you because you are subscribed to
>   the mailing list Lasso [hidden email]
> Official list archives available at http://www.lassotalk.com
> To unsubscribe, E-mail to: <[hidden email]>
> Send administrative queries to  <[hidden email]>
>



--
Mvh
Johan Sölve
____________________________________
Montania System AB
Halmstad   Stockholm
http://www.montania.se

Johan Sölve
Mobil +46 709-51 55 70
[hidden email]

Kristinebergsvägen 17, S-302 41 Halmstad, Sweden
Telefon +46 35-136800 |  Fax +46 35-136801

#############################################################

This message is sent to you because you are subscribed to
  the mailing list Lasso [hidden email]
Official list archives available at http://www.lassotalk.com
To unsubscribe, E-mail to: <[hidden email]>
Send administrative queries to  <[hidden email]>
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Image: The image tags have not loaded... Again !

bienvenue
Thank for your advice Johan.
Going to follow this hint.

For information about our problem, we have several virtual machine with the same CentOS / Lasso / Imagick installation.
So we transfert our app on another one and users may continue to use it.

Here are excerpt from lasso log, as restarting a lasso instances, on 2 machines, one loading image tags correctly, and the one which fails to load them.
Look at lien prefixed by ==>>

First one : image tags loading allright
---------------
[08/31/16 18:35:06][6] Loading datasource "SQLiteConnector"
[08/31/16 18:35:06][6] Done loading datasource "SQLiteConnector"
[08/31/16 18:35:06][6] SQLiteConnector using SQLite: 3.6.20
Unable to determine timezone based on /etc/localtime. Ensure that /etc/localtime is a symlink to /usr/share/zoneinfo/<your>/<zone>.
[08/31/16 18:35:06][6] Loading "SQLConnector.so" module...
[08/31/16 18:35:06][6] SQLAPIDS: Oracle datasource disabled due to missing DBMS client libraries.
[08/31/16 18:35:06][6] SQLAPIDS: SQLServer datasource disabled due to missing DBMS client libraries.
[08/31/16 18:35:06][6] SQLAPIDS: Using PostgreSQL client API version: 0.0
[08/31/16 18:35:06][6] Loading datasource "PostgreSQL"
[08/31/16 18:35:06][6] Done loading datasource "PostgreSQL"
[08/31/16 18:35:06][6] SQLAPIDS: Using ODBC client API version: 0.0
[08/31/16 18:35:06][6] Loading datasource "ODBC"
[08/31/16 18:35:06][6] Done loading datasource "ODBC"
[08/31/16 18:35:06][6] SQLAPIDS: Sybase datasource disabled due to missing DBMS client libraries.
[08/31/16 18:35:06][6] Module "SQLConnector.so" loaded successfully.
[08/31/16 18:35:06][6] Loading "MySQLConnector.so" module...
[08/31/16 18:35:06][6] Loading datasource "MySQLDS"
[08/31/16 18:35:06][6] Done loading datasource "MySQLDS"
[08/31/16 18:35:06][6] MySQLConnector using MySQL client: 5.1.73
[08/31/16 18:35:06][6] Module "MySQLConnector.so" loaded successfully.
[08/31/16 18:35:06][6] Loading "OS_Process.so" module...
[08/31/16 18:35:06][6] Module "OS_Process.so" loaded successfully.
[08/31/16 18:35:06][6] Loading "FMSAConnector.so" module...
[08/31/16 18:35:06][6] Loading datasource "FMServerAdvancedDataSource"
[08/31/16 18:35:06][6] Done loading datasource "FMServerAdvancedDataSource"
[08/31/16 18:35:06][6] Module "FMSAConnector.so" loaded successfully.
==>> [08/31/16 18:35:06][6] Loading "ImageTag.so" module...
==>> [08/31/16 18:35:06][6] Using ImageMagick 6.5.4-7 2014-02-10 Q16 OpenMP http://www.imagemagick.org
==>> [08/31/16 18:35:06][6] Module "ImageTag.so" loaded successfully.
[08/31/16 18:35:06][6] Loading "LDAPConnector.so" module...
[08/31/16 18:35:06][6] Module "LDAPConnector.so" loaded successfully.
[08/31/16 18:35:06][6] Loading "LJAPI.so" module...
---------------
We have in /usr/lib64 :
libMagickCore.so.2.0.0
libMagickCore.so.2 (alias)
libmagic.so.1.0.0
libmagic.so.1 (alias)

Second one : image tags fail to load....
---------------
[08/31/16 18:32:24][6] Loading datasource "SQLiteConnector"
[08/31/16 18:32:24][6] Done loading datasource "SQLiteConnector"
[08/31/16 18:32:24][6] SQLiteConnector using SQLite: 3.6.20
Unable to determine timezone based on /etc/localtime. Ensure that /etc/localtime is a symlink to /usr/share/zoneinfo/<your>/<zone>.
[08/31/16 18:32:24][6] Loading "SQLConnector.so" module...
[08/31/16 18:32:24][6] SQLAPIDS: Oracle datasource disabled due to missing DBMS client libraries.
[08/31/16 18:32:24][6] SQLAPIDS: SQLServer datasource disabled due to missing DBMS client libraries.
[08/31/16 18:32:24][6] SQLAPIDS: Using PostgreSQL client API version: 0.0
[08/31/16 18:32:24][6] Loading datasource "PostgreSQL"
[08/31/16 18:32:24][6] Done loading datasource "PostgreSQL"
[08/31/16 18:32:24][6] SQLAPIDS: Using ODBC client API version: 0.0
[08/31/16 18:32:24][6] Loading datasource "ODBC"
[08/31/16 18:32:24][6] Done loading datasource "ODBC"
[08/31/16 18:32:24][6] SQLAPIDS: Sybase datasource disabled due to missing DBMS client libraries.
[08/31/16 18:32:24][6] Module "SQLConnector.so" loaded successfully.
[08/31/16 18:32:24][6] Loading "MySQLConnector.so" module...
[08/31/16 18:32:24][6] Loading datasource "MySQLDS"
[08/31/16 18:32:24][6] Done loading datasource "MySQLDS"
[08/31/16 18:32:24][6] MySQLConnector using MySQL client: 5.1.73
[08/31/16 18:32:24][6] Module "MySQLConnector.so" loaded successfully.
[08/31/16 18:32:24][6] Loading "FMSAConnector.so" module...
[08/31/16 18:32:24][6] Loading datasource "FMServerAdvancedDataSource"
[08/31/16 18:32:24][6] Done loading datasource "FMServerAdvancedDataSource"
[08/31/16 18:32:24][6] Module "FMSAConnector.so" loaded successfully.
==>> [08/31/16 18:32:24][6] Error from dlopen: libMagickCore.so.4: cannot open shared object file: No such file or directory
[08/31/16 18:32:24][6] Loading "LDAPConnector.so" module...
[08/31/16 18:32:24][6] Module "LDAPConnector.so" loaded successfully.
[08/31/16 18:32:24][6] Loading "LJAPI.so" module...
---------------
We have in /usr/lib64 :
libMagickCore.so.2.0.0
libMagickCore.so.2 (alias)
libmagickCore.so (alias)
libmagic.so.1.0.0
libmagic.so.1 (alias)

We have the same  ImageMagick 6.5.4-7 on the 2 VM only the distrib date is different.
May be some hint about the case ?

Thanks
---
Jean-Pierre Kocherhans
E SYSTEMES
F 59000 Lille


Le 31 août 2016 à 17:30, Johan Solve <[hidden email]> a écrit :

> Make sure you follow the advice from Steffan in the last comment (posted by
> me)
>
> On 30 August 2016 at 18:28, bienvenue <[hidden email]> wrote:
>
>> Hi all,
>>
>> ImageMagick and Lasso seem to be a tricky story.
>>
>> Posts about are numerous...
>> ...As this one about installation on CentOS
>> http://lasso.2283332.n4.nabble.com/Lasso-8-6-3-imageMagick-not-loading-
>> td4644637.html
>>
>> Well, we are running Lasso 8.6.+ on a virtual CentOS / Apache machine.
>>
>> In an old app, which has been for years, from update to update, we
>> suddenly had this error this morning :
>> "Image: The image tags have not loaded. This is usually due to ImageMagick
>> or X11 not being installed. at: Image with params:
>> '/folder/path-to-image.gif"
>> Something must have change in the VM, but we don't know what.
>>
>> ImageMagick 6.7 was involved (and running ok). Reading posts, we decided
>> to downgrade to IM 6.5 4 7.
>> The app is throwing the same error.
>> (We notice that aside this installation changed our apache config to run
>> .htm files with Lasso)
>>
>> We checked the /usr/lib64/libMagickCore.so, we have :
>> libMagickCore.so.2.0.0
>> and two aliases :
>> libMagickCore.so
>> libMagickCore.so.2
>>
>> But image tags do not work, calls throw the same error ...
>>
>> To allow users to work with the app, we moved it temporarly to another
>> Lasso VM where the image tag run ok.
>> But we have to fix the problem on this VM.
>>
>> Any hints about the points to check around ?
>> Thank for your advices, welcome...
>> ---
>> Jean-Pierre Kocherhans
>> E SYSTEMES
>> F-59000 LILLE
>>
>> #############################################################
>>
>> This message is sent to you because you are subscribed to
>>  the mailing list Lasso [hidden email]
>> Official list archives available at http://www.lassotalk.com
>> To unsubscribe, E-mail to: <[hidden email]>
>> Send administrative queries to  <[hidden email]>
>>
>
>
>
> --
> Mvh
> Johan Sölve
> ____________________________________
> Montania System AB
> Halmstad   Stockholm
> http://www.montania.se
>
> Johan Sölve
> Mobil +46 709-51 55 70
> [hidden email]
>
> Kristinebergsvägen 17, S-302 41 Halmstad, Sweden
> Telefon +46 35-136800 |  Fax +46 35-136801
>
> #############################################################
>
> This message is sent to you because you are subscribed to
>  the mailing list Lasso [hidden email]
> Official list archives available at http://www.lassotalk.com
> To unsubscribe, E-mail to: <[hidden email]>
> Send administrative queries to  <[hidden email]>


#############################################################

This message is sent to you because you are subscribed to
  the mailing list Lasso [hidden email]
Official list archives available at http://www.lassotalk.com
To unsubscribe, E-mail to: <[hidden email]>
Send administrative queries to  <[hidden email]>
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Image: The image tags have not loaded... Again !

Steffan Cline
Are these both the same version of lasso loading the image tags?

BTW, fix the local time thing. It's an easy symlink to make.

Thanks,
Steffan Cline
[hidden email]
602-793-0014

> On Aug 31, 2016, at 10:04 AM, bienvenue <[hidden email]> wrote:
>
> Thank for your advice Johan.
> Going to follow this hint.
>
> For information about our problem, we have several virtual machine with the same CentOS / Lasso / Imagick installation.
> So we transfert our app on another one and users may continue to use it.
>
> Here are excerpt from lasso log, as restarting a lasso instances, on 2 machines, one loading image tags correctly, and the one which fails to load them.
> Look at lien prefixed by ==>>
>
> First one : image tags loading allright
> ---------------
> [08/31/16 18:35:06][6] Loading datasource "SQLiteConnector"
> [08/31/16 18:35:06][6] Done loading datasource "SQLiteConnector"
> [08/31/16 18:35:06][6] SQLiteConnector using SQLite: 3.6.20
> Unable to determine timezone based on /etc/localtime. Ensure that /etc/localtime is a symlink to /usr/share/zoneinfo/<your>/<zone>.
> [08/31/16 18:35:06][6] Loading "SQLConnector.so" module...
> [08/31/16 18:35:06][6] SQLAPIDS: Oracle datasource disabled due to missing DBMS client libraries.
> [08/31/16 18:35:06][6] SQLAPIDS: SQLServer datasource disabled due to missing DBMS client libraries.
> [08/31/16 18:35:06][6] SQLAPIDS: Using PostgreSQL client API version: 0.0
> [08/31/16 18:35:06][6] Loading datasource "PostgreSQL"
> [08/31/16 18:35:06][6] Done loading datasource "PostgreSQL"
> [08/31/16 18:35:06][6] SQLAPIDS: Using ODBC client API version: 0.0
> [08/31/16 18:35:06][6] Loading datasource "ODBC"
> [08/31/16 18:35:06][6] Done loading datasource "ODBC"
> [08/31/16 18:35:06][6] SQLAPIDS: Sybase datasource disabled due to missing DBMS client libraries.
> [08/31/16 18:35:06][6] Module "SQLConnector.so" loaded successfully.
> [08/31/16 18:35:06][6] Loading "MySQLConnector.so" module...
> [08/31/16 18:35:06][6] Loading datasource "MySQLDS"
> [08/31/16 18:35:06][6] Done loading datasource "MySQLDS"
> [08/31/16 18:35:06][6] MySQLConnector using MySQL client: 5.1.73
> [08/31/16 18:35:06][6] Module "MySQLConnector.so" loaded successfully.
> [08/31/16 18:35:06][6] Loading "OS_Process.so" module...
> [08/31/16 18:35:06][6] Module "OS_Process.so" loaded successfully.
> [08/31/16 18:35:06][6] Loading "FMSAConnector.so" module...
> [08/31/16 18:35:06][6] Loading datasource "FMServerAdvancedDataSource"
> [08/31/16 18:35:06][6] Done loading datasource "FMServerAdvancedDataSource"
> [08/31/16 18:35:06][6] Module "FMSAConnector.so" loaded successfully.
> ==>> [08/31/16 18:35:06][6] Loading "ImageTag.so" module...
> ==>> [08/31/16 18:35:06][6] Using ImageMagick 6.5.4-7 2014-02-10 Q16 OpenMP http://www.imagemagick.org
> ==>> [08/31/16 18:35:06][6] Module "ImageTag.so" loaded successfully.
> [08/31/16 18:35:06][6] Loading "LDAPConnector.so" module...
> [08/31/16 18:35:06][6] Module "LDAPConnector.so" loaded successfully.
> [08/31/16 18:35:06][6] Loading "LJAPI.so" module...
> ---------------
> We have in /usr/lib64 :
> libMagickCore.so.2.0.0
> libMagickCore.so.2 (alias)
> libmagic.so.1.0.0
> libmagic.so.1 (alias)
>
> Second one : image tags fail to load....
> ---------------
> [08/31/16 18:32:24][6] Loading datasource "SQLiteConnector"
> [08/31/16 18:32:24][6] Done loading datasource "SQLiteConnector"
> [08/31/16 18:32:24][6] SQLiteConnector using SQLite: 3.6.20
> Unable to determine timezone based on /etc/localtime. Ensure that /etc/localtime is a symlink to /usr/share/zoneinfo/<your>/<zone>.
> [08/31/16 18:32:24][6] Loading "SQLConnector.so" module...
> [08/31/16 18:32:24][6] SQLAPIDS: Oracle datasource disabled due to missing DBMS client libraries.
> [08/31/16 18:32:24][6] SQLAPIDS: SQLServer datasource disabled due to missing DBMS client libraries.
> [08/31/16 18:32:24][6] SQLAPIDS: Using PostgreSQL client API version: 0.0
> [08/31/16 18:32:24][6] Loading datasource "PostgreSQL"
> [08/31/16 18:32:24][6] Done loading datasource "PostgreSQL"
> [08/31/16 18:32:24][6] SQLAPIDS: Using ODBC client API version: 0.0
> [08/31/16 18:32:24][6] Loading datasource "ODBC"
> [08/31/16 18:32:24][6] Done loading datasource "ODBC"
> [08/31/16 18:32:24][6] SQLAPIDS: Sybase datasource disabled due to missing DBMS client libraries.
> [08/31/16 18:32:24][6] Module "SQLConnector.so" loaded successfully.
> [08/31/16 18:32:24][6] Loading "MySQLConnector.so" module...
> [08/31/16 18:32:24][6] Loading datasource "MySQLDS"
> [08/31/16 18:32:24][6] Done loading datasource "MySQLDS"
> [08/31/16 18:32:24][6] MySQLConnector using MySQL client: 5.1.73
> [08/31/16 18:32:24][6] Module "MySQLConnector.so" loaded successfully.
> [08/31/16 18:32:24][6] Loading "FMSAConnector.so" module...
> [08/31/16 18:32:24][6] Loading datasource "FMServerAdvancedDataSource"
> [08/31/16 18:32:24][6] Done loading datasource "FMServerAdvancedDataSource"
> [08/31/16 18:32:24][6] Module "FMSAConnector.so" loaded successfully.
> ==>> [08/31/16 18:32:24][6] Error from dlopen: libMagickCore.so.4: cannot open shared object file: No such file or directory
> [08/31/16 18:32:24][6] Loading "LDAPConnector.so" module...
> [08/31/16 18:32:24][6] Module "LDAPConnector.so" loaded successfully.
> [08/31/16 18:32:24][6] Loading "LJAPI.so" module...
> ---------------
> We have in /usr/lib64 :
> libMagickCore.so.2.0.0
> libMagickCore.so.2 (alias)
> libmagickCore.so (alias)
> libmagic.so.1.0.0
> libmagic.so.1 (alias)
>
> We have the same  ImageMagick 6.5.4-7 on the 2 VM only the distrib date is different.
> May be some hint about the case ?
>
> Thanks
> ---
> Jean-Pierre Kocherhans
> E SYSTEMES
> F 59000 Lille
>
>
>> Le 31 août 2016 à 17:30, Johan Solve <[hidden email]> a écrit :
>>
>> Make sure you follow the advice from Steffan in the last comment (posted by
>> me)
>>
>>> On 30 August 2016 at 18:28, bienvenue <[hidden email]> wrote:
>>>
>>> Hi all,
>>>
>>> ImageMagick and Lasso seem to be a tricky story.
>>>
>>> Posts about are numerous...
>>> ...As this one about installation on CentOS
>>> http://lasso.2283332.n4.nabble.com/Lasso-8-6-3-imageMagick-not-loading-
>>> td4644637.html
>>>
>>> Well, we are running Lasso 8.6.+ on a virtual CentOS / Apache machine.
>>>
>>> In an old app, which has been for years, from update to update, we
>>> suddenly had this error this morning :
>>> "Image: The image tags have not loaded. This is usually due to ImageMagick
>>> or X11 not being installed. at: Image with params:
>>> '/folder/path-to-image.gif"
>>> Something must have change in the VM, but we don't know what.
>>>
>>> ImageMagick 6.7 was involved (and running ok). Reading posts, we decided
>>> to downgrade to IM 6.5 4 7.
>>> The app is throwing the same error.
>>> (We notice that aside this installation changed our apache config to run
>>> .htm files with Lasso)
>>>
>>> We checked the /usr/lib64/libMagickCore.so, we have :
>>> libMagickCore.so.2.0.0
>>> and two aliases :
>>> libMagickCore.so
>>> libMagickCore.so.2
>>>
>>> But image tags do not work, calls throw the same error ...
>>>
>>> To allow users to work with the app, we moved it temporarly to another
>>> Lasso VM where the image tag run ok.
>>> But we have to fix the problem on this VM.
>>>
>>> Any hints about the points to check around ?
>>> Thank for your advices, welcome...
>>> ---
>>> Jean-Pierre Kocherhans
>>> E SYSTEMES
>>> F-59000 LILLE
>>>
>>> #############################################################
>>>
>>> This message is sent to you because you are subscribed to
>>> the mailing list Lasso [hidden email]
>>> Official list archives available at http://www.lassotalk.com
>>> To unsubscribe, E-mail to: <[hidden email]>
>>> Send administrative queries to  <[hidden email]>
>>>
>>
>>
>>
>> --
>> Mvh
>> Johan Sölve
>> ____________________________________
>> Montania System AB
>> Halmstad   Stockholm
>> http://www.montania.se
>>
>> Johan Sölve
>> Mobil +46 709-51 55 70
>> [hidden email]
>>
>> Kristinebergsvägen 17, S-302 41 Halmstad, Sweden
>> Telefon +46 35-136800 |  Fax +46 35-136801
>>
>> #############################################################
>>
>> This message is sent to you because you are subscribed to
>> the mailing list Lasso [hidden email]
>> Official list archives available at http://www.lassotalk.com
>> To unsubscribe, E-mail to: <[hidden email]>
>> Send administrative queries to  <[hidden email]>
>
>
> #############################################################
>
> This message is sent to you because you are subscribed to
>  the mailing list Lasso [hidden email]
> Official list archives available at http://www.lassotalk.com
> To unsubscribe, E-mail to: <[hidden email]>
> Send administrative queries to  <[hidden email]>
>


#############################################################

This message is sent to you because you are subscribed to
  the mailing list Lasso [hidden email]
Official list archives available at http://www.lassotalk.com
To unsubscribe, E-mail to: <[hidden email]>
Send administrative queries to  <[hidden email]>
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Image: The image tags have not loaded... Again !

Steffan Cline
Looking back at this again, you have the wrong versions of IM installed. You have .2 and it wants .4.

Thanks,
Steffan Cline
[hidden email]
602-793-0014

> On Aug 31, 2016, at 10:36 AM, Steffan Cline <[hidden email]> wrote:
>
> Are these both the same version of lasso loading the image tags?
>
> BTW, fix the local time thing. It's an easy symlink to make.
>
> Thanks,
> Steffan Cline
> [hidden email]
> 602-793-0014
>
>> On Aug 31, 2016, at 10:04 AM, bienvenue <[hidden email]> wrote:
>>
>> Thank for your advice Johan.
>> Going to follow this hint.
>>
>> For information about our problem, we have several virtual machine with the same CentOS / Lasso / Imagick installation.
>> So we transfert our app on another one and users may continue to use it.
>>
>> Here are excerpt from lasso log, as restarting a lasso instances, on 2 machines, one loading image tags correctly, and the one which fails to load them.
>> Look at lien prefixed by ==>>
>>
>> First one : image tags loading allright
>> ---------------
>> [08/31/16 18:35:06][6] Loading datasource "SQLiteConnector"
>> [08/31/16 18:35:06][6] Done loading datasource "SQLiteConnector"
>> [08/31/16 18:35:06][6] SQLiteConnector using SQLite: 3.6.20
>> Unable to determine timezone based on /etc/localtime. Ensure that /etc/localtime is a symlink to /usr/share/zoneinfo/<your>/<zone>.
>> [08/31/16 18:35:06][6] Loading "SQLConnector.so" module...
>> [08/31/16 18:35:06][6] SQLAPIDS: Oracle datasource disabled due to missing DBMS client libraries.
>> [08/31/16 18:35:06][6] SQLAPIDS: SQLServer datasource disabled due to missing DBMS client libraries.
>> [08/31/16 18:35:06][6] SQLAPIDS: Using PostgreSQL client API version: 0.0
>> [08/31/16 18:35:06][6] Loading datasource "PostgreSQL"
>> [08/31/16 18:35:06][6] Done loading datasource "PostgreSQL"
>> [08/31/16 18:35:06][6] SQLAPIDS: Using ODBC client API version: 0.0
>> [08/31/16 18:35:06][6] Loading datasource "ODBC"
>> [08/31/16 18:35:06][6] Done loading datasource "ODBC"
>> [08/31/16 18:35:06][6] SQLAPIDS: Sybase datasource disabled due to missing DBMS client libraries.
>> [08/31/16 18:35:06][6] Module "SQLConnector.so" loaded successfully.
>> [08/31/16 18:35:06][6] Loading "MySQLConnector.so" module...
>> [08/31/16 18:35:06][6] Loading datasource "MySQLDS"
>> [08/31/16 18:35:06][6] Done loading datasource "MySQLDS"
>> [08/31/16 18:35:06][6] MySQLConnector using MySQL client: 5.1.73
>> [08/31/16 18:35:06][6] Module "MySQLConnector.so" loaded successfully.
>> [08/31/16 18:35:06][6] Loading "OS_Process.so" module...
>> [08/31/16 18:35:06][6] Module "OS_Process.so" loaded successfully.
>> [08/31/16 18:35:06][6] Loading "FMSAConnector.so" module...
>> [08/31/16 18:35:06][6] Loading datasource "FMServerAdvancedDataSource"
>> [08/31/16 18:35:06][6] Done loading datasource "FMServerAdvancedDataSource"
>> [08/31/16 18:35:06][6] Module "FMSAConnector.so" loaded successfully.
>> ==>> [08/31/16 18:35:06][6] Loading "ImageTag.so" module...
>> ==>> [08/31/16 18:35:06][6] Using ImageMagick 6.5.4-7 2014-02-10 Q16 OpenMP http://www.imagemagick.org
>> ==>> [08/31/16 18:35:06][6] Module "ImageTag.so" loaded successfully.
>> [08/31/16 18:35:06][6] Loading "LDAPConnector.so" module...
>> [08/31/16 18:35:06][6] Module "LDAPConnector.so" loaded successfully.
>> [08/31/16 18:35:06][6] Loading "LJAPI.so" module...
>> ---------------
>> We have in /usr/lib64 :
>> libMagickCore.so.2.0.0
>> libMagickCore.so.2 (alias)
>> libmagic.so.1.0.0
>> libmagic.so.1 (alias)
>>
>> Second one : image tags fail to load....
>> ---------------
>> [08/31/16 18:32:24][6] Loading datasource "SQLiteConnector"
>> [08/31/16 18:32:24][6] Done loading datasource "SQLiteConnector"
>> [08/31/16 18:32:24][6] SQLiteConnector using SQLite: 3.6.20
>> Unable to determine timezone based on /etc/localtime. Ensure that /etc/localtime is a symlink to /usr/share/zoneinfo/<your>/<zone>.
>> [08/31/16 18:32:24][6] Loading "SQLConnector.so" module...
>> [08/31/16 18:32:24][6] SQLAPIDS: Oracle datasource disabled due to missing DBMS client libraries.
>> [08/31/16 18:32:24][6] SQLAPIDS: SQLServer datasource disabled due to missing DBMS client libraries.
>> [08/31/16 18:32:24][6] SQLAPIDS: Using PostgreSQL client API version: 0.0
>> [08/31/16 18:32:24][6] Loading datasource "PostgreSQL"
>> [08/31/16 18:32:24][6] Done loading datasource "PostgreSQL"
>> [08/31/16 18:32:24][6] SQLAPIDS: Using ODBC client API version: 0.0
>> [08/31/16 18:32:24][6] Loading datasource "ODBC"
>> [08/31/16 18:32:24][6] Done loading datasource "ODBC"
>> [08/31/16 18:32:24][6] SQLAPIDS: Sybase datasource disabled due to missing DBMS client libraries.
>> [08/31/16 18:32:24][6] Module "SQLConnector.so" loaded successfully.
>> [08/31/16 18:32:24][6] Loading "MySQLConnector.so" module...
>> [08/31/16 18:32:24][6] Loading datasource "MySQLDS"
>> [08/31/16 18:32:24][6] Done loading datasource "MySQLDS"
>> [08/31/16 18:32:24][6] MySQLConnector using MySQL client: 5.1.73
>> [08/31/16 18:32:24][6] Module "MySQLConnector.so" loaded successfully.
>> [08/31/16 18:32:24][6] Loading "FMSAConnector.so" module...
>> [08/31/16 18:32:24][6] Loading datasource "FMServerAdvancedDataSource"
>> [08/31/16 18:32:24][6] Done loading datasource "FMServerAdvancedDataSource"
>> [08/31/16 18:32:24][6] Module "FMSAConnector.so" loaded successfully.
>> ==>> [08/31/16 18:32:24][6] Error from dlopen: libMagickCore.so.4: cannot open shared object file: No such file or directory
>> [08/31/16 18:32:24][6] Loading "LDAPConnector.so" module...
>> [08/31/16 18:32:24][6] Module "LDAPConnector.so" loaded successfully.
>> [08/31/16 18:32:24][6] Loading "LJAPI.so" module...
>> ---------------
>> We have in /usr/lib64 :
>> libMagickCore.so.2.0.0
>> libMagickCore.so.2 (alias)
>> libmagickCore.so (alias)
>> libmagic.so.1.0.0
>> libmagic.so.1 (alias)
>>
>> We have the same  ImageMagick 6.5.4-7 on the 2 VM only the distrib date is different.
>> May be some hint about the case ?
>>
>> Thanks
>> ---
>> Jean-Pierre Kocherhans
>> E SYSTEMES
>> F 59000 Lille
>>
>>
>>> Le 31 août 2016 à 17:30, Johan Solve <[hidden email]> a écrit :
>>>
>>> Make sure you follow the advice from Steffan in the last comment (posted by
>>> me)
>>>
>>>> On 30 August 2016 at 18:28, bienvenue <[hidden email]> wrote:
>>>>
>>>> Hi all,
>>>>
>>>> ImageMagick and Lasso seem to be a tricky story.
>>>>
>>>> Posts about are numerous...
>>>> ...As this one about installation on CentOS
>>>> http://lasso.2283332.n4.nabble.com/Lasso-8-6-3-imageMagick-not-loading-
>>>> td4644637.html
>>>>
>>>> Well, we are running Lasso 8.6.+ on a virtual CentOS / Apache machine.
>>>>
>>>> In an old app, which has been for years, from update to update, we
>>>> suddenly had this error this morning :
>>>> "Image: The image tags have not loaded. This is usually due to ImageMagick
>>>> or X11 not being installed. at: Image with params:
>>>> '/folder/path-to-image.gif"
>>>> Something must have change in the VM, but we don't know what.
>>>>
>>>> ImageMagick 6.7 was involved (and running ok). Reading posts, we decided
>>>> to downgrade to IM 6.5 4 7.
>>>> The app is throwing the same error.
>>>> (We notice that aside this installation changed our apache config to run
>>>> .htm files with Lasso)
>>>>
>>>> We checked the /usr/lib64/libMagickCore.so, we have :
>>>> libMagickCore.so.2.0.0
>>>> and two aliases :
>>>> libMagickCore.so
>>>> libMagickCore.so.2
>>>>
>>>> But image tags do not work, calls throw the same error ...
>>>>
>>>> To allow users to work with the app, we moved it temporarly to another
>>>> Lasso VM where the image tag run ok.
>>>> But we have to fix the problem on this VM.
>>>>
>>>> Any hints about the points to check around ?
>>>> Thank for your advices, welcome...
>>>> ---
>>>> Jean-Pierre Kocherhans
>>>> E SYSTEMES
>>>> F-59000 LILLE
>>>>
>>>> #############################################################
>>>>
>>>> This message is sent to you because you are subscribed to
>>>> the mailing list Lasso [hidden email]
>>>> Official list archives available at http://www.lassotalk.com
>>>> To unsubscribe, E-mail to: <[hidden email]>
>>>> Send administrative queries to  <[hidden email]>
>>>
>>>
>>>
>>> --
>>> Mvh
>>> Johan Sölve
>>> ____________________________________
>>> Montania System AB
>>> Halmstad   Stockholm
>>> http://www.montania.se
>>>
>>> Johan Sölve
>>> Mobil +46 709-51 55 70
>>> [hidden email]
>>>
>>> Kristinebergsvägen 17, S-302 41 Halmstad, Sweden
>>> Telefon +46 35-136800 |  Fax +46 35-136801
>>>
>>> #############################################################
>>>
>>> This message is sent to you because you are subscribed to
>>> the mailing list Lasso [hidden email]
>>> Official list archives available at http://www.lassotalk.com
>>> To unsubscribe, E-mail to: <[hidden email]>
>>> Send administrative queries to  <[hidden email]>
>>
>>
>> #############################################################
>>
>> This message is sent to you because you are subscribed to
>> the mailing list Lasso [hidden email]
>> Official list archives available at http://www.lassotalk.com
>> To unsubscribe, E-mail to: <[hidden email]>
>> Send administrative queries to  <[hidden email]>
>
>
> #############################################################
>
> This message is sent to you because you are subscribed to
>  the mailing list Lasso [hidden email]
> Official list archives available at http://www.lassotalk.com
> To unsubscribe, E-mail to: <[hidden email]>
> Send administrative queries to  <[hidden email]>


#############################################################

This message is sent to you because you are subscribed to
  the mailing list Lasso [hidden email]
Official list archives available at http://www.lassotalk.com
To unsubscribe, E-mail to: <[hidden email]>
Send administrative queries to  <[hidden email]>
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Image: The image tags have not loaded... Again !

bienvenue
In reply to this post by Steffan Cline
Yes Stephan,

Same version of Lasso.
All Lasso licences and VM where upgraded and installed at the same time when we moved from OSX servers...
Lasso 8.6.3 both running on CentOS release 6.5 (Final)
---
Jean-Pierre Kocherhans
E SYSTEMES
F 59000 Lille

Le 31 août 2016 à 19:36, Steffan Cline <[hidden email]> a écrit :

> Are these both the same version of lasso loading the image tags?
>
> BTW, fix the local time thing. It's an easy symlink to make.
>
> Thanks,
> Steffan Cline
> [hidden email]
> 602-793-0014
>
>> On Aug 31, 2016, at 10:04 AM, bienvenue <[hidden email]> wrote:
>>
>> Thank for your advice Johan.
>> Going to follow this hint.
>>
>> For information about our problem, we have several virtual machine with the same CentOS / Lasso / Imagick installation.
>> So we transfert our app on another one and users may continue to use it.
>>
>> Here are excerpt from lasso log, as restarting a lasso instances, on 2 machines, one loading image tags correctly, and the one which fails to load them.
>> Look at lien prefixed by ==>>
>>
>> First one : image tags loading allright
>> ---------------
>> [08/31/16 18:35:06][6] Loading datasource "SQLiteConnector"
>> [08/31/16 18:35:06][6] Done loading datasource "SQLiteConnector"
>> [08/31/16 18:35:06][6] SQLiteConnector using SQLite: 3.6.20
>> Unable to determine timezone based on /etc/localtime. Ensure that /etc/localtime is a symlink to /usr/share/zoneinfo/<your>/<zone>.
>> [08/31/16 18:35:06][6] Loading "SQLConnector.so" module...
>> [08/31/16 18:35:06][6] SQLAPIDS: Oracle datasource disabled due to missing DBMS client libraries.
>> [08/31/16 18:35:06][6] SQLAPIDS: SQLServer datasource disabled due to missing DBMS client libraries.
>> [08/31/16 18:35:06][6] SQLAPIDS: Using PostgreSQL client API version: 0.0
>> [08/31/16 18:35:06][6] Loading datasource "PostgreSQL"
>> [08/31/16 18:35:06][6] Done loading datasource "PostgreSQL"
>> [08/31/16 18:35:06][6] SQLAPIDS: Using ODBC client API version: 0.0
>> [08/31/16 18:35:06][6] Loading datasource "ODBC"
>> [08/31/16 18:35:06][6] Done loading datasource "ODBC"
>> [08/31/16 18:35:06][6] SQLAPIDS: Sybase datasource disabled due to missing DBMS client libraries.
>> [08/31/16 18:35:06][6] Module "SQLConnector.so" loaded successfully.
>> [08/31/16 18:35:06][6] Loading "MySQLConnector.so" module...
>> [08/31/16 18:35:06][6] Loading datasource "MySQLDS"
>> [08/31/16 18:35:06][6] Done loading datasource "MySQLDS"
>> [08/31/16 18:35:06][6] MySQLConnector using MySQL client: 5.1.73
>> [08/31/16 18:35:06][6] Module "MySQLConnector.so" loaded successfully.
>> [08/31/16 18:35:06][6] Loading "OS_Process.so" module...
>> [08/31/16 18:35:06][6] Module "OS_Process.so" loaded successfully.
>> [08/31/16 18:35:06][6] Loading "FMSAConnector.so" module...
>> [08/31/16 18:35:06][6] Loading datasource "FMServerAdvancedDataSource"
>> [08/31/16 18:35:06][6] Done loading datasource "FMServerAdvancedDataSource"
>> [08/31/16 18:35:06][6] Module "FMSAConnector.so" loaded successfully.
>> ==>> [08/31/16 18:35:06][6] Loading "ImageTag.so" module...
>> ==>> [08/31/16 18:35:06][6] Using ImageMagick 6.5.4-7 2014-02-10 Q16 OpenMP http://www.imagemagick.org
>> ==>> [08/31/16 18:35:06][6] Module "ImageTag.so" loaded successfully.
>> [08/31/16 18:35:06][6] Loading "LDAPConnector.so" module...
>> [08/31/16 18:35:06][6] Module "LDAPConnector.so" loaded successfully.
>> [08/31/16 18:35:06][6] Loading "LJAPI.so" module...
>> ---------------
>> We have in /usr/lib64 :
>> libMagickCore.so.2.0.0
>> libMagickCore.so.2 (alias)
>> libmagic.so.1.0.0
>> libmagic.so.1 (alias)
>>
>> Second one : image tags fail to load....
>> ---------------
>> [08/31/16 18:32:24][6] Loading datasource "SQLiteConnector"
>> [08/31/16 18:32:24][6] Done loading datasource "SQLiteConnector"
>> [08/31/16 18:32:24][6] SQLiteConnector using SQLite: 3.6.20
>> Unable to determine timezone based on /etc/localtime. Ensure that /etc/localtime is a symlink to /usr/share/zoneinfo/<your>/<zone>.
>> [08/31/16 18:32:24][6] Loading "SQLConnector.so" module...
>> [08/31/16 18:32:24][6] SQLAPIDS: Oracle datasource disabled due to missing DBMS client libraries.
>> [08/31/16 18:32:24][6] SQLAPIDS: SQLServer datasource disabled due to missing DBMS client libraries.
>> [08/31/16 18:32:24][6] SQLAPIDS: Using PostgreSQL client API version: 0.0
>> [08/31/16 18:32:24][6] Loading datasource "PostgreSQL"
>> [08/31/16 18:32:24][6] Done loading datasource "PostgreSQL"
>> [08/31/16 18:32:24][6] SQLAPIDS: Using ODBC client API version: 0.0
>> [08/31/16 18:32:24][6] Loading datasource "ODBC"
>> [08/31/16 18:32:24][6] Done loading datasource "ODBC"
>> [08/31/16 18:32:24][6] SQLAPIDS: Sybase datasource disabled due to missing DBMS client libraries.
>> [08/31/16 18:32:24][6] Module "SQLConnector.so" loaded successfully.
>> [08/31/16 18:32:24][6] Loading "MySQLConnector.so" module...
>> [08/31/16 18:32:24][6] Loading datasource "MySQLDS"
>> [08/31/16 18:32:24][6] Done loading datasource "MySQLDS"
>> [08/31/16 18:32:24][6] MySQLConnector using MySQL client: 5.1.73
>> [08/31/16 18:32:24][6] Module "MySQLConnector.so" loaded successfully.
>> [08/31/16 18:32:24][6] Loading "FMSAConnector.so" module...
>> [08/31/16 18:32:24][6] Loading datasource "FMServerAdvancedDataSource"
>> [08/31/16 18:32:24][6] Done loading datasource "FMServerAdvancedDataSource"
>> [08/31/16 18:32:24][6] Module "FMSAConnector.so" loaded successfully.
>> ==>> [08/31/16 18:32:24][6] Error from dlopen: libMagickCore.so.4: cannot open shared object file: No such file or directory
>> [08/31/16 18:32:24][6] Loading "LDAPConnector.so" module...
>> [08/31/16 18:32:24][6] Module "LDAPConnector.so" loaded successfully.
>> [08/31/16 18:32:24][6] Loading "LJAPI.so" module...
>> ---------------
>> We have in /usr/lib64 :
>> libMagickCore.so.2.0.0
>> libMagickCore.so.2 (alias)
>> libmagickCore.so (alias)
>> libmagic.so.1.0.0
>> libmagic.so.1 (alias)
>>
>> We have the same  ImageMagick 6.5.4-7 on the 2 VM only the distrib date is different.
>> May be some hint about the case ?
>>
>> Thanks
>> ---
>> Jean-Pierre Kocherhans
>> E SYSTEMES
>> F 59000 Lille
>>
>>
>>> Le 31 août 2016 à 17:30, Johan Solve <[hidden email]> a écrit :
>>>
>>> Make sure you follow the advice from Steffan in the last comment (posted by
>>> me)
>>>
>>>> On 30 August 2016 at 18:28, bienvenue <[hidden email]> wrote:
>>>>
>>>> Hi all,
>>>>
>>>> ImageMagick and Lasso seem to be a tricky story.
>>>>
>>>> Posts about are numerous...
>>>> ...As this one about installation on CentOS
>>>> http://lasso.2283332.n4.nabble.com/Lasso-8-6-3-imageMagick-not-loading-
>>>> td4644637.html
>>>>
>>>> Well, we are running Lasso 8.6.+ on a virtual CentOS / Apache machine.
>>>>
>>>> In an old app, which has been for years, from update to update, we
>>>> suddenly had this error this morning :
>>>> "Image: The image tags have not loaded. This is usually due to ImageMagick
>>>> or X11 not being installed. at: Image with params:
>>>> '/folder/path-to-image.gif"
>>>> Something must have change in the VM, but we don't know what.
>>>>
>>>> ImageMagick 6.7 was involved (and running ok). Reading posts, we decided
>>>> to downgrade to IM 6.5 4 7.
>>>> The app is throwing the same error.
>>>> (We notice that aside this installation changed our apache config to run
>>>> .htm files with Lasso)
>>>>
>>>> We checked the /usr/lib64/libMagickCore.so, we have :
>>>> libMagickCore.so.2.0.0
>>>> and two aliases :
>>>> libMagickCore.so
>>>> libMagickCore.so.2
>>>>
>>>> But image tags do not work, calls throw the same error ...
>>>>
>>>> To allow users to work with the app, we moved it temporarly to another
>>>> Lasso VM where the image tag run ok.
>>>> But we have to fix the problem on this VM.
>>>>
>>>> Any hints about the points to check around ?
>>>> Thank for your advices, welcome...
>>>> ---
>>>> Jean-Pierre Kocherhans
>>>> E SYSTEMES
>>>> F-59000 LILLE
>>>>
>>>> #############################################################
>>>>
>>>> This message is sent to you because you are subscribed to
>>>> the mailing list Lasso [hidden email]
>>>> Official list archives available at http://www.lassotalk.com
>>>> To unsubscribe, E-mail to: <[hidden email]>
>>>> Send administrative queries to  <[hidden email]>
>>>>
>>>
>>>
>>>
>>> --
>>> Mvh
>>> Johan Sölve
>>> ____________________________________
>>> Montania System AB
>>> Halmstad   Stockholm
>>> http://www.montania.se
>>>
>>> Johan Sölve
>>> Mobil +46 709-51 55 70
>>> [hidden email]
>>>
>>> Kristinebergsvägen 17, S-302 41 Halmstad, Sweden
>>> Telefon +46 35-136800 |  Fax +46 35-136801
>>>
>>> #############################################################
>>>
>>> This message is sent to you because you are subscribed to
>>> the mailing list Lasso [hidden email]
>>> Official list archives available at http://www.lassotalk.com
>>> To unsubscribe, E-mail to: <[hidden email]>
>>> Send administrative queries to  <[hidden email]>
>>
>>
>> #############################################################
>>
>> This message is sent to you because you are subscribed to
>> the mailing list Lasso [hidden email]
>> Official list archives available at http://www.lassotalk.com
>> To unsubscribe, E-mail to: <[hidden email]>
>> Send administrative queries to  <[hidden email]>
>>
>
>
> #############################################################
>
> This message is sent to you because you are subscribed to
>  the mailing list Lasso [hidden email]
> Official list archives available at http://www.lassotalk.com
> To unsubscribe, E-mail to: <[hidden email]>
> Send administrative queries to  <[hidden email]>


#############################################################

This message is sent to you because you are subscribed to
  the mailing list Lasso [hidden email]
Official list archives available at http://www.lassotalk.com
To unsubscribe, E-mail to: <[hidden email]>
Send administrative queries to  <[hidden email]>
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Image: The image tags have not loaded... Again !

Steffan Cline
"Steffan" not Stephan. :-)

You have a couple choices.
1) use the older RPM that Marc Pope posted to the list and add it to your yum.conf exemptions.

2) follow the instructions in my blog post on how to build the different version. I personally prefer this because it doesn't screw with any other packages you may be using that rely on IM. If I
Could figure out how to make RPM install in a different directory you wouldn't need to build it. Perhaps if I get some time I can make one.

Of course the ultimate goal is to get LS to make a new build that uses all the latest and greatest binaries.

Thanks,
Steffan Cline
[hidden email]
602-793-0014

> On Aug 31, 2016, at 10:44 AM, bienvenue <[hidden email]> wrote:
>
> Yes Stephan,
>
> Same version of Lasso.
> All Lasso licences and VM where upgraded and installed at the same time when we moved from OSX servers...
> Lasso 8.6.3 both running on CentOS release 6.5 (Final)
> ---
> Jean-Pierre Kocherhans
> E SYSTEMES
> F 59000 Lille
>
>> Le 31 août 2016 à 19:36, Steffan Cline <[hidden email]> a écrit :
>>
>> Are these both the same version of lasso loading the image tags?
>>
>> BTW, fix the local time thing. It's an easy symlink to make.
>>
>> Thanks,
>> Steffan Cline
>> [hidden email]
>> 602-793-0014
>>
>>> On Aug 31, 2016, at 10:04 AM, bienvenue <[hidden email]> wrote:
>>>
>>> Thank for your advice Johan.
>>> Going to follow this hint.
>>>
>>> For information about our problem, we have several virtual machine with the same CentOS / Lasso / Imagick installation.
>>> So we transfert our app on another one and users may continue to use it.
>>>
>>> Here are excerpt from lasso log, as restarting a lasso instances, on 2 machines, one loading image tags correctly, and the one which fails to load them.
>>> Look at lien prefixed by ==>>
>>>
>>> First one : image tags loading allright
>>> ---------------
>>> [08/31/16 18:35:06][6] Loading datasource "SQLiteConnector"
>>> [08/31/16 18:35:06][6] Done loading datasource "SQLiteConnector"
>>> [08/31/16 18:35:06][6] SQLiteConnector using SQLite: 3.6.20
>>> Unable to determine timezone based on /etc/localtime. Ensure that /etc/localtime is a symlink to /usr/share/zoneinfo/<your>/<zone>.
>>> [08/31/16 18:35:06][6] Loading "SQLConnector.so" module...
>>> [08/31/16 18:35:06][6] SQLAPIDS: Oracle datasource disabled due to missing DBMS client libraries.
>>> [08/31/16 18:35:06][6] SQLAPIDS: SQLServer datasource disabled due to missing DBMS client libraries.
>>> [08/31/16 18:35:06][6] SQLAPIDS: Using PostgreSQL client API version: 0.0
>>> [08/31/16 18:35:06][6] Loading datasource "PostgreSQL"
>>> [08/31/16 18:35:06][6] Done loading datasource "PostgreSQL"
>>> [08/31/16 18:35:06][6] SQLAPIDS: Using ODBC client API version: 0.0
>>> [08/31/16 18:35:06][6] Loading datasource "ODBC"
>>> [08/31/16 18:35:06][6] Done loading datasource "ODBC"
>>> [08/31/16 18:35:06][6] SQLAPIDS: Sybase datasource disabled due to missing DBMS client libraries.
>>> [08/31/16 18:35:06][6] Module "SQLConnector.so" loaded successfully.
>>> [08/31/16 18:35:06][6] Loading "MySQLConnector.so" module...
>>> [08/31/16 18:35:06][6] Loading datasource "MySQLDS"
>>> [08/31/16 18:35:06][6] Done loading datasource "MySQLDS"
>>> [08/31/16 18:35:06][6] MySQLConnector using MySQL client: 5.1.73
>>> [08/31/16 18:35:06][6] Module "MySQLConnector.so" loaded successfully.
>>> [08/31/16 18:35:06][6] Loading "OS_Process.so" module...
>>> [08/31/16 18:35:06][6] Module "OS_Process.so" loaded successfully.
>>> [08/31/16 18:35:06][6] Loading "FMSAConnector.so" module...
>>> [08/31/16 18:35:06][6] Loading datasource "FMServerAdvancedDataSource"
>>> [08/31/16 18:35:06][6] Done loading datasource "FMServerAdvancedDataSource"
>>> [08/31/16 18:35:06][6] Module "FMSAConnector.so" loaded successfully.
>>> ==>> [08/31/16 18:35:06][6] Loading "ImageTag.so" module...
>>> ==>> [08/31/16 18:35:06][6] Using ImageMagick 6.5.4-7 2014-02-10 Q16 OpenMP http://www.imagemagick.org
>>> ==>> [08/31/16 18:35:06][6] Module "ImageTag.so" loaded successfully.
>>> [08/31/16 18:35:06][6] Loading "LDAPConnector.so" module...
>>> [08/31/16 18:35:06][6] Module "LDAPConnector.so" loaded successfully.
>>> [08/31/16 18:35:06][6] Loading "LJAPI.so" module...
>>> ---------------
>>> We have in /usr/lib64 :
>>> libMagickCore.so.2.0.0
>>> libMagickCore.so.2 (alias)
>>> libmagic.so.1.0.0
>>> libmagic.so.1 (alias)
>>>
>>> Second one : image tags fail to load....
>>> ---------------
>>> [08/31/16 18:32:24][6] Loading datasource "SQLiteConnector"
>>> [08/31/16 18:32:24][6] Done loading datasource "SQLiteConnector"
>>> [08/31/16 18:32:24][6] SQLiteConnector using SQLite: 3.6.20
>>> Unable to determine timezone based on /etc/localtime. Ensure that /etc/localtime is a symlink to /usr/share/zoneinfo/<your>/<zone>.
>>> [08/31/16 18:32:24][6] Loading "SQLConnector.so" module...
>>> [08/31/16 18:32:24][6] SQLAPIDS: Oracle datasource disabled due to missing DBMS client libraries.
>>> [08/31/16 18:32:24][6] SQLAPIDS: SQLServer datasource disabled due to missing DBMS client libraries.
>>> [08/31/16 18:32:24][6] SQLAPIDS: Using PostgreSQL client API version: 0.0
>>> [08/31/16 18:32:24][6] Loading datasource "PostgreSQL"
>>> [08/31/16 18:32:24][6] Done loading datasource "PostgreSQL"
>>> [08/31/16 18:32:24][6] SQLAPIDS: Using ODBC client API version: 0.0
>>> [08/31/16 18:32:24][6] Loading datasource "ODBC"
>>> [08/31/16 18:32:24][6] Done loading datasource "ODBC"
>>> [08/31/16 18:32:24][6] SQLAPIDS: Sybase datasource disabled due to missing DBMS client libraries.
>>> [08/31/16 18:32:24][6] Module "SQLConnector.so" loaded successfully.
>>> [08/31/16 18:32:24][6] Loading "MySQLConnector.so" module...
>>> [08/31/16 18:32:24][6] Loading datasource "MySQLDS"
>>> [08/31/16 18:32:24][6] Done loading datasource "MySQLDS"
>>> [08/31/16 18:32:24][6] MySQLConnector using MySQL client: 5.1.73
>>> [08/31/16 18:32:24][6] Module "MySQLConnector.so" loaded successfully.
>>> [08/31/16 18:32:24][6] Loading "FMSAConnector.so" module...
>>> [08/31/16 18:32:24][6] Loading datasource "FMServerAdvancedDataSource"
>>> [08/31/16 18:32:24][6] Done loading datasource "FMServerAdvancedDataSource"
>>> [08/31/16 18:32:24][6] Module "FMSAConnector.so" loaded successfully.
>>> ==>> [08/31/16 18:32:24][6] Error from dlopen: libMagickCore.so.4: cannot open shared object file: No such file or directory
>>> [08/31/16 18:32:24][6] Loading "LDAPConnector.so" module...
>>> [08/31/16 18:32:24][6] Module "LDAPConnector.so" loaded successfully.
>>> [08/31/16 18:32:24][6] Loading "LJAPI.so" module...
>>> ---------------
>>> We have in /usr/lib64 :
>>> libMagickCore.so.2.0.0
>>> libMagickCore.so.2 (alias)
>>> libmagickCore.so (alias)
>>> libmagic.so.1.0.0
>>> libmagic.so.1 (alias)
>>>
>>> We have the same  ImageMagick 6.5.4-7 on the 2 VM only the distrib date is different.
>>> May be some hint about the case ?
>>>
>>> Thanks
>>> ---
>>> Jean-Pierre Kocherhans
>>> E SYSTEMES
>>> F 59000 Lille
>>>
>>>
>>>> Le 31 août 2016 à 17:30, Johan Solve <[hidden email]> a écrit :
>>>>
>>>> Make sure you follow the advice from Steffan in the last comment (posted by
>>>> me)
>>>>
>>>>> On 30 August 2016 at 18:28, bienvenue <[hidden email]> wrote:
>>>>>
>>>>> Hi all,
>>>>>
>>>>> ImageMagick and Lasso seem to be a tricky story.
>>>>>
>>>>> Posts about are numerous...
>>>>> ...As this one about installation on CentOS
>>>>> http://lasso.2283332.n4.nabble.com/Lasso-8-6-3-imageMagick-not-loading-
>>>>> td4644637.html
>>>>>
>>>>> Well, we are running Lasso 8.6.+ on a virtual CentOS / Apache machine.
>>>>>
>>>>> In an old app, which has been for years, from update to update, we
>>>>> suddenly had this error this morning :
>>>>> "Image: The image tags have not loaded. This is usually due to ImageMagick
>>>>> or X11 not being installed. at: Image with params:
>>>>> '/folder/path-to-image.gif"
>>>>> Something must have change in the VM, but we don't know what.
>>>>>
>>>>> ImageMagick 6.7 was involved (and running ok). Reading posts, we decided
>>>>> to downgrade to IM 6.5 4 7.
>>>>> The app is throwing the same error.
>>>>> (We notice that aside this installation changed our apache config to run
>>>>> .htm files with Lasso)
>>>>>
>>>>> We checked the /usr/lib64/libMagickCore.so, we have :
>>>>> libMagickCore.so.2.0.0
>>>>> and two aliases :
>>>>> libMagickCore.so
>>>>> libMagickCore.so.2
>>>>>
>>>>> But image tags do not work, calls throw the same error ...
>>>>>
>>>>> To allow users to work with the app, we moved it temporarly to another
>>>>> Lasso VM where the image tag run ok.
>>>>> But we have to fix the problem on this VM.
>>>>>
>>>>> Any hints about the points to check around ?
>>>>> Thank for your advices, welcome...
>>>>> ---
>>>>> Jean-Pierre Kocherhans
>>>>> E SYSTEMES
>>>>> F-59000 LILLE
>>>>>
>>>>> #############################################################
>>>>>
>>>>> This message is sent to you because you are subscribed to
>>>>> the mailing list Lasso [hidden email]
>>>>> Official list archives available at http://www.lassotalk.com
>>>>> To unsubscribe, E-mail to: <[hidden email]>
>>>>> Send administrative queries to  <[hidden email]>
>>>>
>>>>
>>>>
>>>> --
>>>> Mvh
>>>> Johan Sölve
>>>> ____________________________________
>>>> Montania System AB
>>>> Halmstad   Stockholm
>>>> http://www.montania.se
>>>>
>>>> Johan Sölve
>>>> Mobil +46 709-51 55 70
>>>> [hidden email]
>>>>
>>>> Kristinebergsvägen 17, S-302 41 Halmstad, Sweden
>>>> Telefon +46 35-136800 |  Fax +46 35-136801
>>>>
>>>> #############################################################
>>>>
>>>> This message is sent to you because you are subscribed to
>>>> the mailing list Lasso [hidden email]
>>>> Official list archives available at http://www.lassotalk.com
>>>> To unsubscribe, E-mail to: <[hidden email]>
>>>> Send administrative queries to  <[hidden email]>
>>>
>>>
>>> #############################################################
>>>
>>> This message is sent to you because you are subscribed to
>>> the mailing list Lasso [hidden email]
>>> Official list archives available at http://www.lassotalk.com
>>> To unsubscribe, E-mail to: <[hidden email]>
>>> Send administrative queries to  <[hidden email]>
>>
>>
>> #############################################################
>>
>> This message is sent to you because you are subscribed to
>> the mailing list Lasso [hidden email]
>> Official list archives available at http://www.lassotalk.com
>> To unsubscribe, E-mail to: <[hidden email]>
>> Send administrative queries to  <[hidden email]>
>
>
> #############################################################
>
> This message is sent to you because you are subscribed to
>  the mailing list Lasso [hidden email]
> Official list archives available at http://www.lassotalk.com
> To unsubscribe, E-mail to: <[hidden email]>
> Send administrative queries to  <[hidden email]>
>


#############################################################

This message is sent to you because you are subscribed to
  the mailing list Lasso [hidden email]
Official list archives available at http://www.lassotalk.com
To unsubscribe, E-mail to: <[hidden email]>
Send administrative queries to  <[hidden email]>
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Image: The image tags have not loaded... Again !

bienvenue
Okay SteFFan ;-)

Thank for your advices.

One thing is weird as we read in the lasso log :
"Error from dlopen: libMagickCore.so.4: cannot open shared object file: No such file or directory"...
As we searched that file, libMagickCore.so.4, not found on both VM... Even on the one loading correctly the image tag

...
---
Jean-Pierre Kocherhans
E SYSTEMES
F 59000 Lille

Le 31 août 2016 à 20:59, Steffan Cline <[hidden email]> a écrit :

> "Steffan" not Stephan. :-)
>
> You have a couple choices.
> 1) use the older RPM that Marc Pope posted to the list and add it to your yum.conf exemptions.
>
> 2) follow the instructions in my blog post on how to build the different version. I personally prefer this because it doesn't screw with any other packages you may be using that rely on IM. If I
> Could figure out how to make RPM install in a different directory you wouldn't need to build it. Perhaps if I get some time I can make one.
>
> Of course the ultimate goal is to get LS to make a new build that uses all the latest and greatest binaries.
>
> Thanks,
> Steffan Cline
> [hidden email]
> 602-793-0014
>
>> On Aug 31, 2016, at 10:44 AM, bienvenue <[hidden email]> wrote:
>>
>> Yes Stephan,
>>
>> Same version of Lasso.
>> All Lasso licences and VM where upgraded and installed at the same time when we moved from OSX servers...
>> Lasso 8.6.3 both running on CentOS release 6.5 (Final)
>> ---
>> Jean-Pierre Kocherhans
>> E SYSTEMES
>> F 59000 Lille
>>
>>> Le 31 août 2016 à 19:36, Steffan Cline <[hidden email]> a écrit :
>>>
>>> Are these both the same version of lasso loading the image tags?
>>>
>>> BTW, fix the local time thing. It's an easy symlink to make.
>>>
>>> Thanks,
>>> Steffan Cline
>>> [hidden email]
>>> 602-793-0014
>>>
>>>> On Aug 31, 2016, at 10:04 AM, bienvenue <[hidden email]> wrote:
>>>>
>>>> Thank for your advice Johan.
>>>> Going to follow this hint.
>>>>
>>>> For information about our problem, we have several virtual machine with the same CentOS / Lasso / Imagick installation.
>>>> So we transfert our app on another one and users may continue to use it.
>>>>
>>>> Here are excerpt from lasso log, as restarting a lasso instances, on 2 machines, one loading image tags correctly, and the one which fails to load them.
>>>> Look at lien prefixed by ==>>
>>>>
>>>> First one : image tags loading allright
>>>> ---------------
>>>> [08/31/16 18:35:06][6] Loading datasource "SQLiteConnector"
>>>> [08/31/16 18:35:06][6] Done loading datasource "SQLiteConnector"
>>>> [08/31/16 18:35:06][6] SQLiteConnector using SQLite: 3.6.20
>>>> Unable to determine timezone based on /etc/localtime. Ensure that /etc/localtime is a symlink to /usr/share/zoneinfo/<your>/<zone>.
>>>> [08/31/16 18:35:06][6] Loading "SQLConnector.so" module...
>>>> [08/31/16 18:35:06][6] SQLAPIDS: Oracle datasource disabled due to missing DBMS client libraries.
>>>> [08/31/16 18:35:06][6] SQLAPIDS: SQLServer datasource disabled due to missing DBMS client libraries.
>>>> [08/31/16 18:35:06][6] SQLAPIDS: Using PostgreSQL client API version: 0.0
>>>> [08/31/16 18:35:06][6] Loading datasource "PostgreSQL"
>>>> [08/31/16 18:35:06][6] Done loading datasource "PostgreSQL"
>>>> [08/31/16 18:35:06][6] SQLAPIDS: Using ODBC client API version: 0.0
>>>> [08/31/16 18:35:06][6] Loading datasource "ODBC"
>>>> [08/31/16 18:35:06][6] Done loading datasource "ODBC"
>>>> [08/31/16 18:35:06][6] SQLAPIDS: Sybase datasource disabled due to missing DBMS client libraries.
>>>> [08/31/16 18:35:06][6] Module "SQLConnector.so" loaded successfully.
>>>> [08/31/16 18:35:06][6] Loading "MySQLConnector.so" module...
>>>> [08/31/16 18:35:06][6] Loading datasource "MySQLDS"
>>>> [08/31/16 18:35:06][6] Done loading datasource "MySQLDS"
>>>> [08/31/16 18:35:06][6] MySQLConnector using MySQL client: 5.1.73
>>>> [08/31/16 18:35:06][6] Module "MySQLConnector.so" loaded successfully.
>>>> [08/31/16 18:35:06][6] Loading "OS_Process.so" module...
>>>> [08/31/16 18:35:06][6] Module "OS_Process.so" loaded successfully.
>>>> [08/31/16 18:35:06][6] Loading "FMSAConnector.so" module...
>>>> [08/31/16 18:35:06][6] Loading datasource "FMServerAdvancedDataSource"
>>>> [08/31/16 18:35:06][6] Done loading datasource "FMServerAdvancedDataSource"
>>>> [08/31/16 18:35:06][6] Module "FMSAConnector.so" loaded successfully.
>>>> ==>> [08/31/16 18:35:06][6] Loading "ImageTag.so" module...
>>>> ==>> [08/31/16 18:35:06][6] Using ImageMagick 6.5.4-7 2014-02-10 Q16 OpenMP http://www.imagemagick.org
>>>> ==>> [08/31/16 18:35:06][6] Module "ImageTag.so" loaded successfully.
>>>> [08/31/16 18:35:06][6] Loading "LDAPConnector.so" module...
>>>> [08/31/16 18:35:06][6] Module "LDAPConnector.so" loaded successfully.
>>>> [08/31/16 18:35:06][6] Loading "LJAPI.so" module...
>>>> ---------------
>>>> We have in /usr/lib64 :
>>>> libMagickCore.so.2.0.0
>>>> libMagickCore.so.2 (alias)
>>>> libmagic.so.1.0.0
>>>> libmagic.so.1 (alias)
>>>>
>>>> Second one : image tags fail to load....
>>>> ---------------
>>>> [08/31/16 18:32:24][6] Loading datasource "SQLiteConnector"
>>>> [08/31/16 18:32:24][6] Done loading datasource "SQLiteConnector"
>>>> [08/31/16 18:32:24][6] SQLiteConnector using SQLite: 3.6.20
>>>> Unable to determine timezone based on /etc/localtime. Ensure that /etc/localtime is a symlink to /usr/share/zoneinfo/<your>/<zone>.
>>>> [08/31/16 18:32:24][6] Loading "SQLConnector.so" module...
>>>> [08/31/16 18:32:24][6] SQLAPIDS: Oracle datasource disabled due to missing DBMS client libraries.
>>>> [08/31/16 18:32:24][6] SQLAPIDS: SQLServer datasource disabled due to missing DBMS client libraries.
>>>> [08/31/16 18:32:24][6] SQLAPIDS: Using PostgreSQL client API version: 0.0
>>>> [08/31/16 18:32:24][6] Loading datasource "PostgreSQL"
>>>> [08/31/16 18:32:24][6] Done loading datasource "PostgreSQL"
>>>> [08/31/16 18:32:24][6] SQLAPIDS: Using ODBC client API version: 0.0
>>>> [08/31/16 18:32:24][6] Loading datasource "ODBC"
>>>> [08/31/16 18:32:24][6] Done loading datasource "ODBC"
>>>> [08/31/16 18:32:24][6] SQLAPIDS: Sybase datasource disabled due to missing DBMS client libraries.
>>>> [08/31/16 18:32:24][6] Module "SQLConnector.so" loaded successfully.
>>>> [08/31/16 18:32:24][6] Loading "MySQLConnector.so" module...
>>>> [08/31/16 18:32:24][6] Loading datasource "MySQLDS"
>>>> [08/31/16 18:32:24][6] Done loading datasource "MySQLDS"
>>>> [08/31/16 18:32:24][6] MySQLConnector using MySQL client: 5.1.73
>>>> [08/31/16 18:32:24][6] Module "MySQLConnector.so" loaded successfully.
>>>> [08/31/16 18:32:24][6] Loading "FMSAConnector.so" module...
>>>> [08/31/16 18:32:24][6] Loading datasource "FMServerAdvancedDataSource"
>>>> [08/31/16 18:32:24][6] Done loading datasource "FMServerAdvancedDataSource"
>>>> [08/31/16 18:32:24][6] Module "FMSAConnector.so" loaded successfully.
>>>> ==>> [08/31/16 18:32:24][6] Error from dlopen: libMagickCore.so.4: cannot open shared object file: No such file or directory
>>>> [08/31/16 18:32:24][6] Loading "LDAPConnector.so" module...
>>>> [08/31/16 18:32:24][6] Module "LDAPConnector.so" loaded successfully.
>>>> [08/31/16 18:32:24][6] Loading "LJAPI.so" module...
>>>> ---------------
>>>> We have in /usr/lib64 :
>>>> libMagickCore.so.2.0.0
>>>> libMagickCore.so.2 (alias)
>>>> libmagickCore.so (alias)
>>>> libmagic.so.1.0.0
>>>> libmagic.so.1 (alias)
>>>>
>>>> We have the same  ImageMagick 6.5.4-7 on the 2 VM only the distrib date is different.
>>>> May be some hint about the case ?
>>>>
>>>> Thanks
>>>> ---
>>>> Jean-Pierre Kocherhans
>>>> E SYSTEMES
>>>> F 59000 Lille
>>>>
>>>>
>>>>> Le 31 août 2016 à 17:30, Johan Solve <[hidden email]> a écrit :
>>>>>
>>>>> Make sure you follow the advice from Steffan in the last comment (posted by
>>>>> me)
>>>>>
>>>>>> On 30 August 2016 at 18:28, bienvenue <[hidden email]> wrote:
>>>>>>
>>>>>> Hi all,
>>>>>>
>>>>>> ImageMagick and Lasso seem to be a tricky story.
>>>>>>
>>>>>> Posts about are numerous...
>>>>>> ...As this one about installation on CentOS
>>>>>> http://lasso.2283332.n4.nabble.com/Lasso-8-6-3-imageMagick-not-loading-
>>>>>> td4644637.html
>>>>>>
>>>>>> Well, we are running Lasso 8.6.+ on a virtual CentOS / Apache machine.
>>>>>>
>>>>>> In an old app, which has been for years, from update to update, we
>>>>>> suddenly had this error this morning :
>>>>>> "Image: The image tags have not loaded. This is usually due to ImageMagick
>>>>>> or X11 not being installed. at: Image with params:
>>>>>> '/folder/path-to-image.gif"
>>>>>> Something must have change in the VM, but we don't know what.
>>>>>>
>>>>>> ImageMagick 6.7 was involved (and running ok). Reading posts, we decided
>>>>>> to downgrade to IM 6.5 4 7.
>>>>>> The app is throwing the same error.
>>>>>> (We notice that aside this installation changed our apache config to run
>>>>>> .htm files with Lasso)
>>>>>>
>>>>>> We checked the /usr/lib64/libMagickCore.so, we have :
>>>>>> libMagickCore.so.2.0.0
>>>>>> and two aliases :
>>>>>> libMagickCore.so
>>>>>> libMagickCore.so.2
>>>>>>
>>>>>> But image tags do not work, calls throw the same error ...
>>>>>>
>>>>>> To allow users to work with the app, we moved it temporarly to another
>>>>>> Lasso VM where the image tag run ok.
>>>>>> But we have to fix the problem on this VM.
>>>>>>
>>>>>> Any hints about the points to check around ?
>>>>>> Thank for your advices, welcome...
>>>>>> ---
>>>>>> Jean-Pierre Kocherhans
>>>>>> E SYSTEMES
>>>>>> F-59000 LILLE
>>>>>>
>>>>>
>>>>>
>>>>>
>>>>> --
>>>>> Mvh
>>>>> Johan Sölve
>>>>> ____________________________________
>>>>> Montania System AB
>>>>> Halmstad   Stockholm
>>>>> http://www.montania.se
>>>>>
>>>>> Johan Sölve
>>>>> Mobil +46 709-51 55 70
>>>>> [hidden email]
>>>>>
>>>>> Kristinebergsvägen 17, S-302 41 Halmstad, Sweden
>>>>> Telefon +46 35-136800 |  Fax +46 35-136801


#############################################################

This message is sent to you because you are subscribed to
  the mailing list Lasso [hidden email]
Official list archives available at http://www.lassotalk.com
To unsubscribe, E-mail to: <[hidden email]>
Send administrative queries to  <[hidden email]>
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Image: The image tags have not loaded... Again !

bienvenue
SOLVED

Finaly we re-installed Image Magic (6.5.4.7-7)  from http://bay.uchicago.edu/centos-vault/6.5/updates/x86_64/Packages/ImageMagick-6.5.4.7-7.el6_5.x86_64.rpm,
the one in that Lasso Talk post : [Lasso 8.6.3] imageMagick not loading / http://lasso.2283332.n4.nabble.com/Lasso-8-6-3-imageMagick-not-loading-td4644637.html

It installed in  /usr/lib64 :
libMagickCore.so.2.0.0
libMagickCore.so.2 (alias)
libmagickCore.so (alias)
libMagickWand.so.2.0.0
libMagickWand.so (alias)
libMagickWand.so.2 (alias)

What we did to make it work is
- create symlinks named respectively libMagickCore.so.4 and libMagickWand.so.4 to (respectively again) libMagickCore.so.2.0.0 and libMagickWand.so.2.0.0

That's it, and image tags load and run as expected...

Another ressource about the subject : http://www.lassosoft.com/Upgrading-ImageMagick-on-CentOS-5
Where Image Magick 6.6.5 is used.

I should cite that link to an image type replacement from Jason Huck on GitHub.
It calls IMagick through OSProcess and command line utilities...
That we couldn't use because the -info keyword is not implemented and we use it a lot..
https://gist.github.com/jasonhuck/f281afaa528c82a596a9

Thanks for your involvement in our case.
---
Jean-Pierre Kocherhans
E SYSTEMES
F 59000 Lille

Le 1 sept. 2016 à 10:05, bienvenue <[hidden email]> a écrit :

> Okay SteFFan ;-)
>
> Thank for your advices.
>
> One thing is weird as we read in the lasso log :
> "Error from dlopen: libMagickCore.so.4: cannot open shared object file: No such file or directory"...
> As we searched that file, libMagickCore.so.4, not found on both VM... Even on the one loading correctly the image tag
>
> ...
> ---
> Jean-Pierre Kocherhans
> E SYSTEMES
> F 59000 Lille
>
> Le 31 août 2016 à 20:59, Steffan Cline <[hidden email]> a écrit :
>
>> "Steffan" not Stephan. :-)
>>
>> You have a couple choices.
>> 1) use the older RPM that Marc Pope posted to the list and add it to your yum.conf exemptions.
>>
>> 2) follow the instructions in my blog post on how to build the different version. I personally prefer this because it doesn't screw with any other packages you may be using that rely on IM. If I
>> Could figure out how to make RPM install in a different directory you wouldn't need to build it. Perhaps if I get some time I can make one.
>>
>> Of course the ultimate goal is to get LS to make a new build that uses all the latest and greatest binaries.
>>
>> Thanks,
>> Steffan Cline
>> [hidden email]
>> 602-793-0014
>>
>>> On Aug 31, 2016, at 10:44 AM, bienvenue <[hidden email]> wrote:
>>>
>>> Yes Stephan,
>>>
>>> Same version of Lasso.
>>> All Lasso licences and VM where upgraded and installed at the same time when we moved from OSX servers...
>>> Lasso 8.6.3 both running on CentOS release 6.5 (Final)
>>> ---
>>> Jean-Pierre Kocherhans
>>> E SYSTEMES
>>> F 59000 Lille
>>>
>>>> Le 31 août 2016 à 19:36, Steffan Cline <[hidden email]> a écrit :
>>>>
>>>> Are these both the same version of lasso loading the image tags?
>>>>
>>>> BTW, fix the local time thing. It's an easy symlink to make.
>>>>
>>>> Thanks,
>>>> Steffan Cline
>>>> [hidden email]
>>>> 602-793-0014
>>>>
>>>>> On Aug 31, 2016, at 10:04 AM, bienvenue <[hidden email]> wrote:
>>>>>
>>>>> Thank for your advice Johan.
>>>>> Going to follow this hint.
>>>>>
>>>>> For information about our problem, we have several virtual machine with the same CentOS / Lasso / Imagick installation.
>>>>> So we transfert our app on another one and users may continue to use it.
>>>>>
>>>>> Here are excerpt from lasso log, as restarting a lasso instances, on 2 machines, one loading image tags correctly, and the one which fails to load them.
>>>>> Look at lien prefixed by ==>>
>>>>>
>>>>> First one : image tags loading allright
>>>>> ---------------
>>>>> [08/31/16 18:35:06][6] Loading datasource "SQLiteConnector"
>>>>> [08/31/16 18:35:06][6] Done loading datasource "SQLiteConnector"
>>>>> [08/31/16 18:35:06][6] SQLiteConnector using SQLite: 3.6.20
>>>>> Unable to determine timezone based on /etc/localtime. Ensure that /etc/localtime is a symlink to /usr/share/zoneinfo/<your>/<zone>.
>>>>> [08/31/16 18:35:06][6] Loading "SQLConnector.so" module...
>>>>> [08/31/16 18:35:06][6] SQLAPIDS: Oracle datasource disabled due to missing DBMS client libraries.
>>>>> [08/31/16 18:35:06][6] SQLAPIDS: SQLServer datasource disabled due to missing DBMS client libraries.
>>>>> [08/31/16 18:35:06][6] SQLAPIDS: Using PostgreSQL client API version: 0.0
>>>>> [08/31/16 18:35:06][6] Loading datasource "PostgreSQL"
>>>>> [08/31/16 18:35:06][6] Done loading datasource "PostgreSQL"
>>>>> [08/31/16 18:35:06][6] SQLAPIDS: Using ODBC client API version: 0.0
>>>>> [08/31/16 18:35:06][6] Loading datasource "ODBC"
>>>>> [08/31/16 18:35:06][6] Done loading datasource "ODBC"
>>>>> [08/31/16 18:35:06][6] SQLAPIDS: Sybase datasource disabled due to missing DBMS client libraries.
>>>>> [08/31/16 18:35:06][6] Module "SQLConnector.so" loaded successfully.
>>>>> [08/31/16 18:35:06][6] Loading "MySQLConnector.so" module...
>>>>> [08/31/16 18:35:06][6] Loading datasource "MySQLDS"
>>>>> [08/31/16 18:35:06][6] Done loading datasource "MySQLDS"
>>>>> [08/31/16 18:35:06][6] MySQLConnector using MySQL client: 5.1.73
>>>>> [08/31/16 18:35:06][6] Module "MySQLConnector.so" loaded successfully.
>>>>> [08/31/16 18:35:06][6] Loading "OS_Process.so" module...
>>>>> [08/31/16 18:35:06][6] Module "OS_Process.so" loaded successfully.
>>>>> [08/31/16 18:35:06][6] Loading "FMSAConnector.so" module...
>>>>> [08/31/16 18:35:06][6] Loading datasource "FMServerAdvancedDataSource"
>>>>> [08/31/16 18:35:06][6] Done loading datasource "FMServerAdvancedDataSource"
>>>>> [08/31/16 18:35:06][6] Module "FMSAConnector.so" loaded successfully.
>>>>> ==>> [08/31/16 18:35:06][6] Loading "ImageTag.so" module...
>>>>> ==>> [08/31/16 18:35:06][6] Using ImageMagick 6.5.4-7 2014-02-10 Q16 OpenMP http://www.imagemagick.org
>>>>> ==>> [08/31/16 18:35:06][6] Module "ImageTag.so" loaded successfully.
>>>>> [08/31/16 18:35:06][6] Loading "LDAPConnector.so" module...
>>>>> [08/31/16 18:35:06][6] Module "LDAPConnector.so" loaded successfully.
>>>>> [08/31/16 18:35:06][6] Loading "LJAPI.so" module...
>>>>> ---------------
>>>>> We have in /usr/lib64 :
>>>>> libMagickCore.so.2.0.0
>>>>> libMagickCore.so.2 (alias)
>>>>> libmagic.so.1.0.0
>>>>> libmagic.so.1 (alias)
>>>>>
>>>>> Second one : image tags fail to load....
>>>>> ---------------
>>>>> [08/31/16 18:32:24][6] Loading datasource "SQLiteConnector"
>>>>> [08/31/16 18:32:24][6] Done loading datasource "SQLiteConnector"
>>>>> [08/31/16 18:32:24][6] SQLiteConnector using SQLite: 3.6.20
>>>>> Unable to determine timezone based on /etc/localtime. Ensure that /etc/localtime is a symlink to /usr/share/zoneinfo/<your>/<zone>.
>>>>> [08/31/16 18:32:24][6] Loading "SQLConnector.so" module...
>>>>> [08/31/16 18:32:24][6] SQLAPIDS: Oracle datasource disabled due to missing DBMS client libraries.
>>>>> [08/31/16 18:32:24][6] SQLAPIDS: SQLServer datasource disabled due to missing DBMS client libraries.
>>>>> [08/31/16 18:32:24][6] SQLAPIDS: Using PostgreSQL client API version: 0.0
>>>>> [08/31/16 18:32:24][6] Loading datasource "PostgreSQL"
>>>>> [08/31/16 18:32:24][6] Done loading datasource "PostgreSQL"
>>>>> [08/31/16 18:32:24][6] SQLAPIDS: Using ODBC client API version: 0.0
>>>>> [08/31/16 18:32:24][6] Loading datasource "ODBC"
>>>>> [08/31/16 18:32:24][6] Done loading datasource "ODBC"
>>>>> [08/31/16 18:32:24][6] SQLAPIDS: Sybase datasource disabled due to missing DBMS client libraries.
>>>>> [08/31/16 18:32:24][6] Module "SQLConnector.so" loaded successfully.
>>>>> [08/31/16 18:32:24][6] Loading "MySQLConnector.so" module...
>>>>> [08/31/16 18:32:24][6] Loading datasource "MySQLDS"
>>>>> [08/31/16 18:32:24][6] Done loading datasource "MySQLDS"
>>>>> [08/31/16 18:32:24][6] MySQLConnector using MySQL client: 5.1.73
>>>>> [08/31/16 18:32:24][6] Module "MySQLConnector.so" loaded successfully.
>>>>> [08/31/16 18:32:24][6] Loading "FMSAConnector.so" module...
>>>>> [08/31/16 18:32:24][6] Loading datasource "FMServerAdvancedDataSource"
>>>>> [08/31/16 18:32:24][6] Done loading datasource "FMServerAdvancedDataSource"
>>>>> [08/31/16 18:32:24][6] Module "FMSAConnector.so" loaded successfully.
>>>>> ==>> [08/31/16 18:32:24][6] Error from dlopen: libMagickCore.so.4: cannot open shared object file: No such file or directory
>>>>> [08/31/16 18:32:24][6] Loading "LDAPConnector.so" module...
>>>>> [08/31/16 18:32:24][6] Module "LDAPConnector.so" loaded successfully.
>>>>> [08/31/16 18:32:24][6] Loading "LJAPI.so" module...
>>>>> ---------------
>>>>> We have in /usr/lib64 :
>>>>> libMagickCore.so.2.0.0
>>>>> libMagickCore.so.2 (alias)
>>>>> libmagickCore.so (alias)
>>>>> libmagic.so.1.0.0
>>>>> libmagic.so.1 (alias)
>>>>>
>>>>> We have the same  ImageMagick 6.5.4-7 on the 2 VM only the distrib date is different.
>>>>> May be some hint about the case ?
>>>>>
>>>>> Thanks
>>>>> ---
>>>>> Jean-Pierre Kocherhans
>>>>> E SYSTEMES
>>>>> F 59000 Lille
>>>>>
>>>>>
>>>>>> Le 31 août 2016 à 17:30, Johan Solve <[hidden email]> a écrit :
>>>>>>
>>>>>> Make sure you follow the advice from Steffan in the last comment (posted by
>>>>>> me)
>>>>>>
>>>>>>> On 30 August 2016 at 18:28, bienvenue <[hidden email]> wrote:
>>>>>>>
>>>>>>> Hi all,
>>>>>>>
>>>>>>> ImageMagick and Lasso seem to be a tricky story.
>>>>>>>
>>>>>>> Posts about are numerous...
>>>>>>> ...As this one about installation on CentOS
>>>>>>> http://lasso.2283332.n4.nabble.com/Lasso-8-6-3-imageMagick-not-loading-
>>>>>>> td4644637.html
>>>>>>>
>>>>>>> Well, we are running Lasso 8.6.+ on a virtual CentOS / Apache machine.
>>>>>>>
>>>>>>> In an old app, which has been for years, from update to update, we
>>>>>>> suddenly had this error this morning :
>>>>>>> "Image: The image tags have not loaded. This is usually due to ImageMagick
>>>>>>> or X11 not being installed. at: Image with params:
>>>>>>> '/folder/path-to-image.gif"
>>>>>>> Something must have change in the VM, but we don't know what.
>>>>>>>
>>>>>>> ImageMagick 6.7 was involved (and running ok). Reading posts, we decided
>>>>>>> to downgrade to IM 6.5 4 7.
>>>>>>> The app is throwing the same error.
>>>>>>> (We notice that aside this installation changed our apache config to run
>>>>>>> .htm files with Lasso)
>>>>>>>
>>>>>>> We checked the /usr/lib64/libMagickCore.so, we have :
>>>>>>> libMagickCore.so.2.0.0
>>>>>>> and two aliases :
>>>>>>> libMagickCore.so
>>>>>>> libMagickCore.so.2
>>>>>>>
>>>>>>> But image tags do not work, calls throw the same error ...
>>>>>>>
>>>>>>> To allow users to work with the app, we moved it temporarly to another
>>>>>>> Lasso VM where the image tag run ok.
>>>>>>> But we have to fix the problem on this VM.
>>>>>>>
>>>>>>> Any hints about the points to check around ?
>>>>>>> Thank for your advices, welcome...
>>>>>>> ---
>>>>>>> Jean-Pierre Kocherhans
>>>>>>> E SYSTEMES
>>>>>>> F-59000 LILLE
>>>>>>>
>>>>>>
>>>>>>
>>>>>>
>>>>>> --
>>>>>> Mvh
>>>>>> Johan Sölve
>>>>>> ____________________________________
>>>>>> Montania System AB
>>>>>> Halmstad   Stockholm
>>>>>> http://www.montania.se
>>>>>>
>>>>>> Johan Sölve
>>>>>> Mobil +46 709-51 55 70
>>>>>> [hidden email]
>>>>>>
>>>>>> Kristinebergsvägen 17, S-302 41 Halmstad, Sweden
>>>>>> Telefon +46 35-136800 |  Fax +46 35-136801
>
>
> #############################################################
>
> This message is sent to you because you are subscribed to
>  the mailing list Lasso [hidden email]
> Official list archives available at http://www.lassotalk.com
> To unsubscribe, E-mail to: <[hidden email]>
> Send administrative queries to  <[hidden email]>


#############################################################

This message is sent to you because you are subscribed to
  the mailing list Lasso [hidden email]
Official list archives available at http://www.lassotalk.com
To unsubscribe, E-mail to: <[hidden email]>
Send administrative queries to  <[hidden email]>
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Image: The image tags have not loaded... Again !

Steffan Cline
You may dismiss the error by creating a symlink but that does not solve the problem. It only looks as if it did.

Give it a shot and let us know how it works out.

 
Thank you,
Steffan Cline
602-793-0014

 


On 9/1/16, 3:21 AM, "bienvenue" <[hidden email] on behalf of [hidden email]> wrote:

    SOLVED
   
    Finaly we re-installed Image Magic (6.5.4.7-7)  from http://bay.uchicago.edu/centos-vault/6.5/updates/x86_64/Packages/ImageMagick-6.5.4.7-7.el6_5.x86_64.rpm,
    the one in that Lasso Talk post : [Lasso 8.6.3] imageMagick not loading / http://lasso.2283332.n4.nabble.com/Lasso-8-6-3-imageMagick-not-loading-td4644637.html
   
    It installed in  /usr/lib64 :
    libMagickCore.so.2.0.0
    libMagickCore.so.2 (alias)
    libmagickCore.so (alias)
    libMagickWand.so.2.0.0
    libMagickWand.so (alias)
    libMagickWand.so.2 (alias)
   
    What we did to make it work is
    - create symlinks named respectively libMagickCore.so.4 and libMagickWand.so.4 to (respectively again) libMagickCore.so.2.0.0 and libMagickWand.so.2.0.0
   
    That's it, and image tags load and run as expected...
   
    Another ressource about the subject : http://www.lassosoft.com/Upgrading-ImageMagick-on-CentOS-5
    Where Image Magick 6.6.5 is used.
   
    I should cite that link to an image type replacement from Jason Huck on GitHub.
    It calls IMagick through OSProcess and command line utilities...
    That we couldn't use because the -info keyword is not implemented and we use it a lot..
    https://gist.github.com/jasonhuck/f281afaa528c82a596a9
   
    Thanks for your involvement in our case.
    ---
    Jean-Pierre Kocherhans
    E SYSTEMES
    F 59000 Lille
   
    Le 1 sept. 2016 à 10:05, bienvenue <[hidden email]> a écrit :
   
    > Okay SteFFan ;-)
    >
    > Thank for your advices.
    >
    > One thing is weird as we read in the lasso log :
    > "Error from dlopen: libMagickCore.so.4: cannot open shared object file: No such file or directory"...
    > As we searched that file, libMagickCore.so.4, not found on both VM... Even on the one loading correctly the image tag
    >
    > ...
    > ---
    > Jean-Pierre Kocherhans
    > E SYSTEMES
    > F 59000 Lille
    >
    > Le 31 août 2016 à 20:59, Steffan Cline <[hidden email]> a écrit :
    >
    >> "Steffan" not Stephan. :-)
    >>
    >> You have a couple choices.
    >> 1) use the older RPM that Marc Pope posted to the list and add it to your yum.conf exemptions.
    >>
    >> 2) follow the instructions in my blog post on how to build the different version. I personally prefer this because it doesn't screw with any other packages you may be using that rely on IM. If I
    >> Could figure out how to make RPM install in a different directory you wouldn't need to build it. Perhaps if I get some time I can make one.
    >>
    >> Of course the ultimate goal is to get LS to make a new build that uses all the latest and greatest binaries.
    >>
    >> Thanks,
    >> Steffan Cline
    >> [hidden email]
    >> 602-793-0014
    >>
    >>> On Aug 31, 2016, at 10:44 AM, bienvenue <[hidden email]> wrote:
    >>>
    >>> Yes Stephan,
    >>>
    >>> Same version of Lasso.
    >>> All Lasso licences and VM where upgraded and installed at the same time when we moved from OSX servers...
    >>> Lasso 8.6.3 both running on CentOS release 6.5 (Final)
    >>> ---
    >>> Jean-Pierre Kocherhans
    >>> E SYSTEMES
    >>> F 59000 Lille
    >>>
    >>>> Le 31 août 2016 à 19:36, Steffan Cline <[hidden email]> a écrit :
    >>>>
    >>>> Are these both the same version of lasso loading the image tags?
    >>>>
    >>>> BTW, fix the local time thing. It's an easy symlink to make.
    >>>>
    >>>> Thanks,
    >>>> Steffan Cline
    >>>> [hidden email]
    >>>> 602-793-0014
    >>>>
    >>>>> On Aug 31, 2016, at 10:04 AM, bienvenue <[hidden email]> wrote:
    >>>>>
    >>>>> Thank for your advice Johan.
    >>>>> Going to follow this hint.
    >>>>>
    >>>>> For information about our problem, we have several virtual machine with the same CentOS / Lasso / Imagick installation.
    >>>>> So we transfert our app on another one and users may continue to use it.
    >>>>>
    >>>>> Here are excerpt from lasso log, as restarting a lasso instances, on 2 machines, one loading image tags correctly, and the one which fails to load them.
    >>>>> Look at lien prefixed by ==>>
    >>>>>
    >>>>> First one : image tags loading allright
    >>>>> ---------------
    >>>>> [08/31/16 18:35:06][6] Loading datasource "SQLiteConnector"
    >>>>> [08/31/16 18:35:06][6] Done loading datasource "SQLiteConnector"
    >>>>> [08/31/16 18:35:06][6] SQLiteConnector using SQLite: 3.6.20
    >>>>> Unable to determine timezone based on /etc/localtime. Ensure that /etc/localtime is a symlink to /usr/share/zoneinfo/<your>/<zone>.
    >>>>> [08/31/16 18:35:06][6] Loading "SQLConnector.so" module...
    >>>>> [08/31/16 18:35:06][6] SQLAPIDS: Oracle datasource disabled due to missing DBMS client libraries.
    >>>>> [08/31/16 18:35:06][6] SQLAPIDS: SQLServer datasource disabled due to missing DBMS client libraries.
    >>>>> [08/31/16 18:35:06][6] SQLAPIDS: Using PostgreSQL client API version: 0.0
    >>>>> [08/31/16 18:35:06][6] Loading datasource "PostgreSQL"
    >>>>> [08/31/16 18:35:06][6] Done loading datasource "PostgreSQL"
    >>>>> [08/31/16 18:35:06][6] SQLAPIDS: Using ODBC client API version: 0.0
    >>>>> [08/31/16 18:35:06][6] Loading datasource "ODBC"
    >>>>> [08/31/16 18:35:06][6] Done loading datasource "ODBC"
    >>>>> [08/31/16 18:35:06][6] SQLAPIDS: Sybase datasource disabled due to missing DBMS client libraries.
    >>>>> [08/31/16 18:35:06][6] Module "SQLConnector.so" loaded successfully.
    >>>>> [08/31/16 18:35:06][6] Loading "MySQLConnector.so" module...
    >>>>> [08/31/16 18:35:06][6] Loading datasource "MySQLDS"
    >>>>> [08/31/16 18:35:06][6] Done loading datasource "MySQLDS"
    >>>>> [08/31/16 18:35:06][6] MySQLConnector using MySQL client: 5.1.73
    >>>>> [08/31/16 18:35:06][6] Module "MySQLConnector.so" loaded successfully.
    >>>>> [08/31/16 18:35:06][6] Loading "OS_Process.so" module...
    >>>>> [08/31/16 18:35:06][6] Module "OS_Process.so" loaded successfully.
    >>>>> [08/31/16 18:35:06][6] Loading "FMSAConnector.so" module...
    >>>>> [08/31/16 18:35:06][6] Loading datasource "FMServerAdvancedDataSource"
    >>>>> [08/31/16 18:35:06][6] Done loading datasource "FMServerAdvancedDataSource"
    >>>>> [08/31/16 18:35:06][6] Module "FMSAConnector.so" loaded successfully.
    >>>>> ==>> [08/31/16 18:35:06][6] Loading "ImageTag.so" module...
    >>>>> ==>> [08/31/16 18:35:06][6] Using ImageMagick 6.5.4-7 2014-02-10 Q16 OpenMP http://www.imagemagick.org
    >>>>> ==>> [08/31/16 18:35:06][6] Module "ImageTag.so" loaded successfully.
    >>>>> [08/31/16 18:35:06][6] Loading "LDAPConnector.so" module...
    >>>>> [08/31/16 18:35:06][6] Module "LDAPConnector.so" loaded successfully.
    >>>>> [08/31/16 18:35:06][6] Loading "LJAPI.so" module...
    >>>>> ---------------
    >>>>> We have in /usr/lib64 :
    >>>>> libMagickCore.so.2.0.0
    >>>>> libMagickCore.so.2 (alias)
    >>>>> libmagic.so.1.0.0
    >>>>> libmagic.so.1 (alias)
    >>>>>
    >>>>> Second one : image tags fail to load....
    >>>>> ---------------
    >>>>> [08/31/16 18:32:24][6] Loading datasource "SQLiteConnector"
    >>>>> [08/31/16 18:32:24][6] Done loading datasource "SQLiteConnector"
    >>>>> [08/31/16 18:32:24][6] SQLiteConnector using SQLite: 3.6.20
    >>>>> Unable to determine timezone based on /etc/localtime. Ensure that /etc/localtime is a symlink to /usr/share/zoneinfo/<your>/<zone>.
    >>>>> [08/31/16 18:32:24][6] Loading "SQLConnector.so" module...
    >>>>> [08/31/16 18:32:24][6] SQLAPIDS: Oracle datasource disabled due to missing DBMS client libraries.
    >>>>> [08/31/16 18:32:24][6] SQLAPIDS: SQLServer datasource disabled due to missing DBMS client libraries.
    >>>>> [08/31/16 18:32:24][6] SQLAPIDS: Using PostgreSQL client API version: 0.0
    >>>>> [08/31/16 18:32:24][6] Loading datasource "PostgreSQL"
    >>>>> [08/31/16 18:32:24][6] Done loading datasource "PostgreSQL"
    >>>>> [08/31/16 18:32:24][6] SQLAPIDS: Using ODBC client API version: 0.0
    >>>>> [08/31/16 18:32:24][6] Loading datasource "ODBC"
    >>>>> [08/31/16 18:32:24][6] Done loading datasource "ODBC"
    >>>>> [08/31/16 18:32:24][6] SQLAPIDS: Sybase datasource disabled due to missing DBMS client libraries.
    >>>>> [08/31/16 18:32:24][6] Module "SQLConnector.so" loaded successfully.
    >>>>> [08/31/16 18:32:24][6] Loading "MySQLConnector.so" module...
    >>>>> [08/31/16 18:32:24][6] Loading datasource "MySQLDS"
    >>>>> [08/31/16 18:32:24][6] Done loading datasource "MySQLDS"
    >>>>> [08/31/16 18:32:24][6] MySQLConnector using MySQL client: 5.1.73
    >>>>> [08/31/16 18:32:24][6] Module "MySQLConnector.so" loaded successfully.
    >>>>> [08/31/16 18:32:24][6] Loading "FMSAConnector.so" module...
    >>>>> [08/31/16 18:32:24][6] Loading datasource "FMServerAdvancedDataSource"
    >>>>> [08/31/16 18:32:24][6] Done loading datasource "FMServerAdvancedDataSource"
    >>>>> [08/31/16 18:32:24][6] Module "FMSAConnector.so" loaded successfully.
    >>>>> ==>> [08/31/16 18:32:24][6] Error from dlopen: libMagickCore.so.4: cannot open shared object file: No such file or directory
    >>>>> [08/31/16 18:32:24][6] Loading "LDAPConnector.so" module...
    >>>>> [08/31/16 18:32:24][6] Module "LDAPConnector.so" loaded successfully.
    >>>>> [08/31/16 18:32:24][6] Loading "LJAPI.so" module...
    >>>>> ---------------
    >>>>> We have in /usr/lib64 :
    >>>>> libMagickCore.so.2.0.0
    >>>>> libMagickCore.so.2 (alias)
    >>>>> libmagickCore.so (alias)
    >>>>> libmagic.so.1.0.0
    >>>>> libmagic.so.1 (alias)
    >>>>>
    >>>>> We have the same  ImageMagick 6.5.4-7 on the 2 VM only the distrib date is different.
    >>>>> May be some hint about the case ?
    >>>>>
    >>>>> Thanks
    >>>>> ---
    >>>>> Jean-Pierre Kocherhans
    >>>>> E SYSTEMES
    >>>>> F 59000 Lille
    >>>>>
    >>>>>
    >>>>>> Le 31 août 2016 à 17:30, Johan Solve <[hidden email]> a écrit :
    >>>>>>
    >>>>>> Make sure you follow the advice from Steffan in the last comment (posted by
    >>>>>> me)
    >>>>>>
    >>>>>>> On 30 August 2016 at 18:28, bienvenue <[hidden email]> wrote:
    >>>>>>>
    >>>>>>> Hi all,
    >>>>>>>
    >>>>>>> ImageMagick and Lasso seem to be a tricky story.
    >>>>>>>
    >>>>>>> Posts about are numerous...
    >>>>>>> ...As this one about installation on CentOS
    >>>>>>> http://lasso.2283332.n4.nabble.com/Lasso-8-6-3-imageMagick-not-loading-
    >>>>>>> td4644637.html
    >>>>>>>
    >>>>>>> Well, we are running Lasso 8.6.+ on a virtual CentOS / Apache machine.
    >>>>>>>
    >>>>>>> In an old app, which has been for years, from update to update, we
    >>>>>>> suddenly had this error this morning :
    >>>>>>> "Image: The image tags have not loaded. This is usually due to ImageMagick
    >>>>>>> or X11 not being installed. at: Image with params:
    >>>>>>> '/folder/path-to-image.gif"
    >>>>>>> Something must have change in the VM, but we don't know what.
    >>>>>>>
    >>>>>>> ImageMagick 6.7 was involved (and running ok). Reading posts, we decided
    >>>>>>> to downgrade to IM 6.5 4 7.
    >>>>>>> The app is throwing the same error.
    >>>>>>> (We notice that aside this installation changed our apache config to run
    >>>>>>> .htm files with Lasso)
    >>>>>>>
    >>>>>>> We checked the /usr/lib64/libMagickCore.so, we have :
    >>>>>>> libMagickCore.so.2.0.0
    >>>>>>> and two aliases :
    >>>>>>> libMagickCore.so
    >>>>>>> libMagickCore.so.2
    >>>>>>>
    >>>>>>> But image tags do not work, calls throw the same error ...
    >>>>>>>
    >>>>>>> To allow users to work with the app, we moved it temporarly to another
    >>>>>>> Lasso VM where the image tag run ok.
    >>>>>>> But we have to fix the problem on this VM.
    >>>>>>>
    >>>>>>> Any hints about the points to check around ?
    >>>>>>> Thank for your advices, welcome...
    >>>>>>> ---
    >>>>>>> Jean-Pierre Kocherhans
    >>>>>>> E SYSTEMES
    >>>>>>> F-59000 LILLE
    >>>>>>>
    >>>>>>
    >>>>>>
    >>>>>>
    >>>>>> --
    >>>>>> Mvh
    >>>>>> Johan Sölve
    >>>>>> ____________________________________
    >>>>>> Montania System AB
    >>>>>> Halmstad   Stockholm
    >>>>>> http://www.montania.se
    >>>>>>
    >>>>>> Johan Sölve
    >>>>>> Mobil +46 709-51 55 70
    >>>>>> [hidden email]
    >>>>>>
    >>>>>> Kristinebergsvägen 17, S-302 41 Halmstad, Sweden
    >>>>>> Telefon +46 35-136800 |  Fax +46 35-136801
    >
    >
    > #############################################################
    >
    > This message is sent to you because you are subscribed to
    >  the mailing list Lasso [hidden email]
    > Official list archives available at http://www.lassotalk.com
    > To unsubscribe, E-mail to: <[hidden email]>
    > Send administrative queries to  <[hidden email]>
   
   
    #############################################################
   
    This message is sent to you because you are subscribed to
      the mailing list Lasso [hidden email]
    Official list archives available at http://www.lassotalk.com
    To unsubscribe, E-mail to: <[hidden email]>
    Send administrative queries to  <[hidden email]>
   
   




#############################################################

This message is sent to you because you are subscribed to
  the mailing list Lasso [hidden email]
Official list archives available at http://www.lassotalk.com
To unsubscribe, E-mail to: <[hidden email]>
Send administrative queries to  <[hidden email]>
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Image: The image tags have not loaded... Again !

bienvenue
I agree with you Seffan,

also we don't even know why suddenly the image tags stop working...
But the fact is that it works now.

Let's wait, monitor and see if the patch is sustainable.
---
Jean-Pierre Kocherhans
E SYSTEMES
F 59000 Lille

Le 1 sept. 2016 à 14:55, Steffan Cline <[hidden email]> a écrit :

> You may dismiss the error by creating a symlink but that does not solve the problem. It only looks as if it did.
>
> Give it a shot and let us know how it works out.
>
>
> Thank you,
> Steffan Cline
> 602-793-0014
>
>
>
>
> On 9/1/16, 3:21 AM, "bienvenue" <[hidden email] on behalf of [hidden email]> wrote:
>
>    SOLVED
>
>    Finaly we re-installed Image Magic (6.5.4.7-7)  from http://bay.uchicago.edu/centos-vault/6.5/updates/x86_64/Packages/ImageMagick-6.5.4.7-7.el6_5.x86_64.rpm,
>    the one in that Lasso Talk post : [Lasso 8.6.3] imageMagick not loading / http://lasso.2283332.n4.nabble.com/Lasso-8-6-3-imageMagick-not-loading-td4644637.html
>
>    It installed in  /usr/lib64 :
>    libMagickCore.so.2.0.0
>    libMagickCore.so.2 (alias)
>    libmagickCore.so (alias)
>    libMagickWand.so.2.0.0
>    libMagickWand.so (alias)
>    libMagickWand.so.2 (alias)
>
>    What we did to make it work is
>    - create symlinks named respectively libMagickCore.so.4 and libMagickWand.so.4 to (respectively again) libMagickCore.so.2.0.0 and libMagickWand.so.2.0.0
>
>    That's it, and image tags load and run as expected...
>
>    Another ressource about the subject : http://www.lassosoft.com/Upgrading-ImageMagick-on-CentOS-5
>    Where Image Magick 6.6.5 is used.
>
>    I should cite that link to an image type replacement from Jason Huck on GitHub.
>    It calls IMagick through OSProcess and command line utilities...
>    That we couldn't use because the -info keyword is not implemented and we use it a lot..
>    https://gist.github.com/jasonhuck/f281afaa528c82a596a9
>
>    Thanks for your involvement in our case.
>    ---
>    Jean-Pierre Kocherhans
>    E SYSTEMES
>    F 59000 Lille
>
>    Le 1 sept. 2016 à 10:05, bienvenue <[hidden email]> a écrit :
>
>> Okay SteFFan ;-)
>>
>> Thank for your advices.
>>
>> One thing is weird as we read in the lasso log :
>> "Error from dlopen: libMagickCore.so.4: cannot open shared object file: No such file or directory"...
>> As we searched that file, libMagickCore.so.4, not found on both VM... Even on the one loading correctly the image tag
>>
>> ...
>> ---
>> Jean-Pierre Kocherhans
>> E SYSTEMES
>> F 59000 Lille
>>
>> Le 31 août 2016 à 20:59, Steffan Cline <[hidden email]> a écrit :
>>
>>> "Steffan" not Stephan. :-)
>>>
>>> You have a couple choices.
>>> 1) use the older RPM that Marc Pope posted to the list and add it to your yum.conf exemptions.
>>>
>>> 2) follow the instructions in my blog post on how to build the different version. I personally prefer this because it doesn't screw with any other packages you may be using that rely on IM. If I
>>> Could figure out how to make RPM install in a different directory you wouldn't need to build it. Perhaps if I get some time I can make one.
>>>
>>> Of course the ultimate goal is to get LS to make a new build that uses all the latest and greatest binaries.
>>>
>>> Thanks,
>>> Steffan Cline
>>> [hidden email]
>>> 602-793-0014
>>>
>>>> On Aug 31, 2016, at 10:44 AM, bienvenue <[hidden email]> wrote:
>>>>
>>>> Yes Stephan,
>>>>
>>>> Same version of Lasso.
>>>> All Lasso licences and VM where upgraded and installed at the same time when we moved from OSX servers...
>>>> Lasso 8.6.3 both running on CentOS release 6.5 (Final)
>>>> ---
>>>> Jean-Pierre Kocherhans
>>>> E SYSTEMES
>>>> F 59000 Lille
>>>>
>>>>> Le 31 août 2016 à 19:36, Steffan Cline <[hidden email]> a écrit :
>>>>>
>>>>> Are these both the same version of lasso loading the image tags?
>>>>>
>>>>> BTW, fix the local time thing. It's an easy symlink to make.
>>>>>
>>>>> Thanks,
>>>>> Steffan Cline
>>>>> [hidden email]
>>>>> 602-793-0014
>>>>>
>>>>>> On Aug 31, 2016, at 10:04 AM, bienvenue <[hidden email]> wrote:
>>>>>>
>>>>>> Thank for your advice Johan.
>>>>>> Going to follow this hint.
>>>>>>
>>>>>> For information about our problem, we have several virtual machine with the same CentOS / Lasso / Imagick installation.
>>>>>> So we transfert our app on another one and users may continue to use it.
>>>>>>
>>>>>> Here are excerpt from lasso log, as restarting a lasso instances, on 2 machines, one loading image tags correctly, and the one which fails to load them.
>>>>>> Look at lien prefixed by ==>>
>>>>>>
>>>>>> First one : image tags loading allright
>>>>>> ---------------
>>>>>> [08/31/16 18:35:06][6] Loading datasource "SQLiteConnector"
>>>>>> [08/31/16 18:35:06][6] Done loading datasource "SQLiteConnector"
>>>>>> [08/31/16 18:35:06][6] SQLiteConnector using SQLite: 3.6.20
>>>>>> Unable to determine timezone based on /etc/localtime. Ensure that /etc/localtime is a symlink to /usr/share/zoneinfo/<your>/<zone>.
>>>>>> [08/31/16 18:35:06][6] Loading "SQLConnector.so" module...
>>>>>> [08/31/16 18:35:06][6] SQLAPIDS: Oracle datasource disabled due to missing DBMS client libraries.
>>>>>> [08/31/16 18:35:06][6] SQLAPIDS: SQLServer datasource disabled due to missing DBMS client libraries.
>>>>>> [08/31/16 18:35:06][6] SQLAPIDS: Using PostgreSQL client API version: 0.0
>>>>>> [08/31/16 18:35:06][6] Loading datasource "PostgreSQL"
>>>>>> [08/31/16 18:35:06][6] Done loading datasource "PostgreSQL"
>>>>>> [08/31/16 18:35:06][6] SQLAPIDS: Using ODBC client API version: 0.0
>>>>>> [08/31/16 18:35:06][6] Loading datasource "ODBC"
>>>>>> [08/31/16 18:35:06][6] Done loading datasource "ODBC"
>>>>>> [08/31/16 18:35:06][6] SQLAPIDS: Sybase datasource disabled due to missing DBMS client libraries.
>>>>>> [08/31/16 18:35:06][6] Module "SQLConnector.so" loaded successfully.
>>>>>> [08/31/16 18:35:06][6] Loading "MySQLConnector.so" module...
>>>>>> [08/31/16 18:35:06][6] Loading datasource "MySQLDS"
>>>>>> [08/31/16 18:35:06][6] Done loading datasource "MySQLDS"
>>>>>> [08/31/16 18:35:06][6] MySQLConnector using MySQL client: 5.1.73
>>>>>> [08/31/16 18:35:06][6] Module "MySQLConnector.so" loaded successfully.
>>>>>> [08/31/16 18:35:06][6] Loading "OS_Process.so" module...
>>>>>> [08/31/16 18:35:06][6] Module "OS_Process.so" loaded successfully.
>>>>>> [08/31/16 18:35:06][6] Loading "FMSAConnector.so" module...
>>>>>> [08/31/16 18:35:06][6] Loading datasource "FMServerAdvancedDataSource"
>>>>>> [08/31/16 18:35:06][6] Done loading datasource "FMServerAdvancedDataSource"
>>>>>> [08/31/16 18:35:06][6] Module "FMSAConnector.so" loaded successfully.
>>>>>> ==>> [08/31/16 18:35:06][6] Loading "ImageTag.so" module...
>>>>>> ==>> [08/31/16 18:35:06][6] Using ImageMagick 6.5.4-7 2014-02-10 Q16 OpenMP http://www.imagemagick.org
>>>>>> ==>> [08/31/16 18:35:06][6] Module "ImageTag.so" loaded successfully.
>>>>>> [08/31/16 18:35:06][6] Loading "LDAPConnector.so" module...
>>>>>> [08/31/16 18:35:06][6] Module "LDAPConnector.so" loaded successfully.
>>>>>> [08/31/16 18:35:06][6] Loading "LJAPI.so" module...
>>>>>> ---------------
>>>>>> We have in /usr/lib64 :
>>>>>> libMagickCore.so.2.0.0
>>>>>> libMagickCore.so.2 (alias)
>>>>>> libmagic.so.1.0.0
>>>>>> libmagic.so.1 (alias)
>>>>>>
>>>>>> Second one : image tags fail to load....
>>>>>> ---------------
>>>>>> [08/31/16 18:32:24][6] Loading datasource "SQLiteConnector"
>>>>>> [08/31/16 18:32:24][6] Done loading datasource "SQLiteConnector"
>>>>>> [08/31/16 18:32:24][6] SQLiteConnector using SQLite: 3.6.20
>>>>>> Unable to determine timezone based on /etc/localtime. Ensure that /etc/localtime is a symlink to /usr/share/zoneinfo/<your>/<zone>.
>>>>>> [08/31/16 18:32:24][6] Loading "SQLConnector.so" module...
>>>>>> [08/31/16 18:32:24][6] SQLAPIDS: Oracle datasource disabled due to missing DBMS client libraries.
>>>>>> [08/31/16 18:32:24][6] SQLAPIDS: SQLServer datasource disabled due to missing DBMS client libraries.
>>>>>> [08/31/16 18:32:24][6] SQLAPIDS: Using PostgreSQL client API version: 0.0
>>>>>> [08/31/16 18:32:24][6] Loading datasource "PostgreSQL"
>>>>>> [08/31/16 18:32:24][6] Done loading datasource "PostgreSQL"
>>>>>> [08/31/16 18:32:24][6] SQLAPIDS: Using ODBC client API version: 0.0
>>>>>> [08/31/16 18:32:24][6] Loading datasource "ODBC"
>>>>>> [08/31/16 18:32:24][6] Done loading datasource "ODBC"
>>>>>> [08/31/16 18:32:24][6] SQLAPIDS: Sybase datasource disabled due to missing DBMS client libraries.
>>>>>> [08/31/16 18:32:24][6] Module "SQLConnector.so" loaded successfully.
>>>>>> [08/31/16 18:32:24][6] Loading "MySQLConnector.so" module...
>>>>>> [08/31/16 18:32:24][6] Loading datasource "MySQLDS"
>>>>>> [08/31/16 18:32:24][6] Done loading datasource "MySQLDS"
>>>>>> [08/31/16 18:32:24][6] MySQLConnector using MySQL client: 5.1.73
>>>>>> [08/31/16 18:32:24][6] Module "MySQLConnector.so" loaded successfully.
>>>>>> [08/31/16 18:32:24][6] Loading "FMSAConnector.so" module...
>>>>>> [08/31/16 18:32:24][6] Loading datasource "FMServerAdvancedDataSource"
>>>>>> [08/31/16 18:32:24][6] Done loading datasource "FMServerAdvancedDataSource"
>>>>>> [08/31/16 18:32:24][6] Module "FMSAConnector.so" loaded successfully.
>>>>>> ==>> [08/31/16 18:32:24][6] Error from dlopen: libMagickCore.so.4: cannot open shared object file: No such file or directory
>>>>>> [08/31/16 18:32:24][6] Loading "LDAPConnector.so" module...
>>>>>> [08/31/16 18:32:24][6] Module "LDAPConnector.so" loaded successfully.
>>>>>> [08/31/16 18:32:24][6] Loading "LJAPI.so" module...
>>>>>> ---------------
>>>>>> We have in /usr/lib64 :
>>>>>> libMagickCore.so.2.0.0
>>>>>> libMagickCore.so.2 (alias)
>>>>>> libmagickCore.so (alias)
>>>>>> libmagic.so.1.0.0
>>>>>> libmagic.so.1 (alias)
>>>>>>
>>>>>> We have the same  ImageMagick 6.5.4-7 on the 2 VM only the distrib date is different.
>>>>>> May be some hint about the case ?
>>>>>>
>>>>>> Thanks
>>>>>> ---
>>>>>> Jean-Pierre Kocherhans
>>>>>> E SYSTEMES
>>>>>> F 59000 Lille
>>>>>>
>>>>>>
>>>>>>> Le 31 août 2016 à 17:30, Johan Solve <[hidden email]> a écrit :
>>>>>>>
>>>>>>> Make sure you follow the advice from Steffan in the last comment (posted by
>>>>>>> me)
>>>>>>>
>>>>>>>> On 30 August 2016 at 18:28, bienvenue <[hidden email]> wrote:
>>>>>>>>
>>>>>>>> Hi all,
>>>>>>>>
>>>>>>>> ImageMagick and Lasso seem to be a tricky story.
>>>>>>>>
>>>>>>>> Posts about are numerous...
>>>>>>>> ...As this one about installation on CentOS
>>>>>>>> http://lasso.2283332.n4.nabble.com/Lasso-8-6-3-imageMagick-not-loading-
>>>>>>>> td4644637.html
>>>>>>>>
>>>>>>>> Well, we are running Lasso 8.6.+ on a virtual CentOS / Apache machine.
>>>>>>>>
>>>>>>>> In an old app, which has been for years, from update to update, we
>>>>>>>> suddenly had this error this morning :
>>>>>>>> "Image: The image tags have not loaded. This is usually due to ImageMagick
>>>>>>>> or X11 not being installed. at: Image with params:
>>>>>>>> '/folder/path-to-image.gif"
>>>>>>>> Something must have change in the VM, but we don't know what.
>>>>>>>>
>>>>>>>> ImageMagick 6.7 was involved (and running ok). Reading posts, we decided
>>>>>>>> to downgrade to IM 6.5 4 7.
>>>>>>>> The app is throwing the same error.
>>>>>>>> (We notice that aside this installation changed our apache config to run
>>>>>>>> .htm files with Lasso)
>>>>>>>>
>>>>>>>> We checked the /usr/lib64/libMagickCore.so, we have :
>>>>>>>> libMagickCore.so.2.0.0
>>>>>>>> and two aliases :
>>>>>>>> libMagickCore.so
>>>>>>>> libMagickCore.so.2
>>>>>>>>
>>>>>>>> But image tags do not work, calls throw the same error ...
>>>>>>>>
>>>>>>>> To allow users to work with the app, we moved it temporarly to another
>>>>>>>> Lasso VM where the image tag run ok.
>>>>>>>> But we have to fix the problem on this VM.
>>>>>>>>
>>>>>>>> Any hints about the points to check around ?
>>>>>>>> Thank for your advices, welcome...
>>>>>>>> ---
>>>>>>>> Jean-Pierre Kocherhans
>>>>>>>> E SYSTEMES
>>>>>>>> F-59000 LILLE
>>>>>>>>
>>>>>>>
>>>>>>>
>>>>>>>
>>>>>>> --
>>>>>>> Mvh
>>>>>>> Johan Sölve
>>>>>>> ____________________________________
>>>>>>> Montania System AB
>>>>>>> Halmstad   Stockholm
>>>>>>> http://www.montania.se
>>>>>>>
>>>>>>> Johan Sölve
>>>>>>> Mobil +46 709-51 55 70
>>>>>>> [hidden email]
>>>>>>>
>>>>>>> Kristinebergsvägen 17, S-302 41 Halmstad, Sweden
>>>>>>> Telefon +46 35-136800 |  Fax +46 35-136801

#############################################################

This message is sent to you because you are subscribed to
  the mailing list Lasso [hidden email]
Official list archives available at http://www.lassotalk.com
To unsubscribe, E-mail to: <[hidden email]>
Send administrative queries to  <[hidden email]>
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Image: The image tags have not loaded... Again !

Jolle Carlestam-2
1 sep. 2016 kl. 17:26 skrev bienvenue <[hidden email]>:
>
> I agree with you Seffan,

”Seffan” and ”Stephan”. STEFFAN really goes by mane names. :-)

HDB
Jolie

#############################################################

This message is sent to you because you are subscribed to
  the mailing list Lasso [hidden email]
Official list archives available at http://www.lassotalk.com
To unsubscribe, E-mail to: <[hidden email]>
Send administrative queries to  <[hidden email]>
Loading...