Fwd: Initializing Lasso 9.3.1 on Windows 2012 Server hangs

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

Fwd: Initializing Lasso 9.3.1 on Windows 2012 Server hangs

Marc Vos-3
Hi list,

Does someone know what the cause can be for the error mentioned below?

Lasso 9.3.1-4
Windows 2012 Server
Apache 2.4

- -
Thanks,
Marc



> Begin forwarded message:
>
> From: Marc Vos <[hidden email]>
> Subject: Re: Initializing Lasso 9.3.1 on Windows 2012 Server hangs
> Date: 28 april 2016 18:14:49 CEST
> To: LassoSoft Support <[hidden email]>
>
> Next wall ...
>
> In Server Manager, when I click on LassoApps, 'LassoLibraries' or 'Modules', I get an error:
>
> Error:
>
> 2016-04-28 18:09:58: /lasso9/lux/server/lassoapps
>
> Die Syntax für den Dateinamen, Verzeichnisnamen oder die Datenträgerbezeichnung ist falsch.
>
> (The syntax for the file name, directory name, or volume label description is incorrect.)
>
> 89:22 dir.lasso
> 521:5 traits.lasso
> 71:11 query.lasso
> 137:9 query.lasso
> 67:9 utilities.lasso
> 71:11 query.lasso
> 71:11 query.lasso
> 71:11 query.lasso
> 80:8 query.lasso
> 53:2 lux/server/lassoapps[html].lasso
> 768:9 defining_lassoapp_lux
> 83:10 lassoapp.lasso
> 656:2 lassoapp.lasso
> 655:32 lassoapp.lasso
> 80:2 lassoapp.lasso
> 177:17 web_response.lasso
> 198:13 web_response.lasso
> 187:4 web_response.lasso
> 183:4 web_response.lasso
> 183:4 web_response.lasso
> 300:19 web_response.lasso
> 182:2 error.lasso
> 182:2 error.lasso
> 176:2 error.lasso
> 175:2 error.lasso
> 182:3 web_response.lasso
> 300:19 web_response.lasso
> 290:3 web_response.lasso
> 287:4 web_response.lasso
> 679:17 fastcgi.lasso
> 182:2 error.lasso
> 182:2 error.lasso
> 176:2 error.lasso
> 175:2 error.lasso
> 678:2 fastcgi.lasso
> 290:16 fastcgi.lasso
> 286:3 fastcgi.lasso
> 278:2 fastcgi.lasso
> 182:2 error.lasso
> 182:2 error.lasso
> 176:2 error.lasso
> 175:2 error.lasso
> 284:2 fastcgi.lasso
> 278:2 fastcgi.lasso
> 17:3 lux/_init.fcgi.lasso
> 17:3 lux/_init.fcgi.lasso
>
> What can that be?
>
> Also, creating an instance hangs. Has probably to do with the above error?
>
> - -
> Thanks,
> Marc
>
>
>
>> On 28 apr. 2016, at 18:00, Marc Vos <[hidden email] <mailto:[hidden email]>> wrote:
>>
>> Hi Eric,
>>
>> Thanks! That was it. Had to reboot the server, but it works now.
>>
>> - -
>> Kind regards,
>> Marc Vos
>>
>> http://nl.linkedin.com/in/mhevos <http://nl.linkedin.com/in/mhevos>
>> http://marc.vos.net/ <http://marc.vos.net/>
>>
>>
>>> On 28 apr. 2016, at 16:05, LassoSoft Support <[hidden email] <mailto:[hidden email]>> wrote:
>>>
>>> You don't need ImageMagick; the custom install has the option to install without the plugin. If the plugin is already installed, just remove ImageTag.dll from the LassoModules folder. That's what's probably causing the hang.
>>>  
>>> Eric Knibbe
>>> Developer
>>>  
>>> LassoSoft Inc.
>>> P: (888) 286-7753
>>> www.lassosoft.com <http://www.lassosoft.com/>
>>>  
>>>
>>>> On Apr 22, 2016, at 10:48 AM, Marc Vos <[hidden email] <mailto:[hidden email]>> wrote:
>>>>
>>>> Hello all,
>>>>
>>>> I have an urgent problem: initializing Lasso 9.3.1 on Windows 2012 Server hangs.
>>>>
>>>> Where can I see in detail what is going on behind 'waiting for localhost' … ?
>>>>
>>>> Do I really need ImageMagick?  Your link on the 2012 server installation instructions page doesn’t resolve and if I do need this, which version?
>>>>
>>>> - -
>>>> Thanks,
>>>> Marc Vos
>>>>
>>>> http://marc.vos.net/ <http://marc.vos.net/>
>>>> http://nl.linkedin.com/in/mhevos <http://nl.linkedin.com/in/mhevos>
>>>>
>>>> <vos-logo75.png>
>>>>
>>>
>>
>


#############################################################

This message is sent to you because you are subscribed to
  the mailing list Lasso [hidden email]
Official list archives available at http://www.lassotalk.com
To unsubscribe, E-mail to: <[hidden email]>
Send administrative queries to  <[hidden email]>
Reply | Threaded
Open this post in threaded view
|

Re: Initializing Lasso 9.3.1 on Windows 2012 Server hangs

Jolle Carlestam-2
29 apr. 2016 kl. 10:41 skrev Marc Vos <[hidden email]>:

>
> Does someone know what the cause can be for the error mentioned below?
>
> Lasso 9.3.1-4
> Windows 2012 Server
> Apache 2.4
>
> Begin forwarded message:
>>
>> From: Marc Vos <[hidden email]>
>> Subject: Re: Initializing Lasso 9.3.1 on Windows 2012 Server hangs
>> Date: 28 april 2016 18:14:49 CEST
>> To: LassoSoft Support <[hidden email]>
>>
>> Next wall ...
>>
>> In Server Manager, when I click on LassoApps, 'LassoLibraries' or 'Modules', I get an error:
>>
>> Error:
>>
>> 2016-04-28 18:09:58: /lasso9/lux/server/lassoapps
>>
>> Die Syntax für den Dateinamen, Verzeichnisnamen oder die Datenträgerbezeichnung ist falsch.
>>
>> (The syntax for the file name, directory name, or volume label description is incorrect.)
>>
>> 89:22 dir.lasso

The fact that the error is in German indicates that it’s the OS responding with an error. Looking at your error stack it’s the dir type that is causing it. At row 89 of dir.lasso we find:
        public forEachEntry() => {
                local(d = dirdesc->open(.realPath)&) // this is row 89
                handle => { #d->close }
                local(curr = #d->read)

making me think that it is .realPath that is ducked up.

Had it been me I would put a logging row before row 89 checking how .realPath looks.

        public forEachEntry() => {
stdoutnl(’realpath ’ + .realPath)
                local(d = dirdesc->open(.realPath)&)
                handle => { #d->close }
                local(curr = #d->read)

You can do this by grabbing the entire code inside dir.lasso, put in a temp lasso page and load that.

The tricky part might be how and where to access the log file. I can do it on Mac and Linux but don’t know how to do it on Windows.

HDB
Jolle

#############################################################

This message is sent to you because you are subscribed to
  the mailing list Lasso [hidden email]
Official list archives available at http://www.lassotalk.com
To unsubscribe, E-mail to: <[hidden email]>
Send administrative queries to  <[hidden email]>
Reply | Threaded
Open this post in threaded view
|

Re: Initializing Lasso 9.3.1 on Windows 2012 Server hangs

Marc Vos-3
Hi Jolle,

I haven’t even got an instance running yet. Hangs on 'Creating instance'.

- -
Marc


> On 29 apr. 2016, at 11:00, Jolle Carlestam <[hidden email]> wrote:
>
> 29 apr. 2016 kl. 10:41 skrev Marc Vos <[hidden email]>:
>>
>> Does someone know what the cause can be for the error mentioned below?
>>
>> Lasso 9.3.1-4
>> Windows 2012 Server
>> Apache 2.4
>>
>> Begin forwarded message:
>>>
>>> From: Marc Vos <[hidden email]>
>>> Subject: Re: Initializing Lasso 9.3.1 on Windows 2012 Server hangs
>>> Date: 28 april 2016 18:14:49 CEST
>>> To: LassoSoft Support <[hidden email]>
>>>
>>> Next wall ...
>>>
>>> In Server Manager, when I click on LassoApps, 'LassoLibraries' or 'Modules', I get an error:
>>>
>>> Error:
>>>
>>> 2016-04-28 18:09:58: /lasso9/lux/server/lassoapps
>>>
>>> Die Syntax für den Dateinamen, Verzeichnisnamen oder die Datenträgerbezeichnung ist falsch.
>>>
>>> (The syntax for the file name, directory name, or volume label description is incorrect.)
>>>
>>> 89:22 dir.lasso
>
> The fact that the error is in German indicates that it’s the OS responding with an error. Looking at your error stack it’s the dir type that is causing it. At row 89 of dir.lasso we find:
> public forEachEntry() => {
> local(d = dirdesc->open(.realPath)&) // this is row 89
> handle => { #d->close }
> local(curr = #d->read)
>
> making me think that it is .realPath that is ducked up.
>
> Had it been me I would put a logging row before row 89 checking how .realPath looks.
>
> public forEachEntry() => {
> stdoutnl(’realpath ’ + .realPath)
> local(d = dirdesc->open(.realPath)&)
> handle => { #d->close }
> local(curr = #d->read)
>
> You can do this by grabbing the entire code inside dir.lasso, put in a temp lasso page and load that.
>
> The tricky part might be how and where to access the log file. I can do it on Mac and Linux but don’t know how to do it on Windows.
>
> HDB
> Jolle
>
> #############################################################
>
> This message is sent to you because you are subscribed to
>  the mailing list Lasso [hidden email]
> Official list archives available at http://www.lassotalk.com
> To unsubscribe, E-mail to: <[hidden email]>
> Send administrative queries to  <[hidden email]>


#############################################################

This message is sent to you because you are subscribed to
  the mailing list Lasso [hidden email]
Official list archives available at http://www.lassotalk.com
To unsubscribe, E-mail to: <[hidden email]>
Send administrative queries to  <[hidden email]>
Reply | Threaded
Open this post in threaded view
|

Re: Initializing Lasso 9.3.1 on Windows 2012 Server hangs

Jolle Carlestam-2
29 apr. 2016 kl. 11:09 skrev Marc Vos <[hidden email]>:
>
> I haven’t even got an instance running yet. Hangs on 'Creating instance'.

This might be a case of Lassosoft chiming in.

HDB
Jolle

#############################################################

This message is sent to you because you are subscribed to
  the mailing list Lasso [hidden email]
Official list archives available at http://www.lassotalk.com
To unsubscribe, E-mail to: <[hidden email]>
Send administrative queries to  <[hidden email]>
Reply | Threaded
Open this post in threaded view
|

Re: Initializing Lasso 9.3.1 on Windows 2012 Server hangs

Marc Vos-3


> On 29 apr. 2016, at 16:36, Jolle Carlestam <[hidden email]> wrote:
>
> 29 apr. 2016 kl. 11:09 skrev Marc Vos <[hidden email]>:
>>
>> I haven’t even got an instance running yet. Hangs on 'Creating instance'.
>
> This might be a case of Lassosoft chiming in.

I really hope that they do !

- -
Marc


#############################################################

This message is sent to you because you are subscribed to
  the mailing list Lasso [hidden email]
Official list archives available at http://www.lassotalk.com
To unsubscribe, E-mail to: <[hidden email]>
Send administrative queries to  <[hidden email]>