[FIXED] Re: mod_jk encoding [was: Re: Page encoding LP8.0.4]

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

[FIXED] Re: mod_jk encoding [was: Re: Page encoding LP8.0.4]

Erlend Garåsen

Suddenly my encoding problems disappeared after Lasso had been
restarted. How strange. The only thing I tried to change prior to the
restart was the indexing/search settings for the FM7 table fields. It
seems that (I do not hope so) one should try to restart Lasso after
changing these settings?

All kinds of characters are now displayed correctly, even the Cyrillic ones.

Erlend



Erlend Gar?sen wrote:

> Petrus N?slund wrote:
>
>> I had some problems with this as well. It seemed like whatever I put
>> in the meta tag, eg <meta http-equiv="Content-Type"
>> content="text/html; charset=UTF-8"> would be messed up in IE on
>> windows. If I added the ldml tag [content_type: 'text/html;
>> charset=UTF-8']
>> it would process fine. But, then I have to be sure that this tag is
>> present in all solutions...
>>
>> Finally, I removed the AddDefaultCharset directive from the httpd.conf
>> (#AddDefaultCharset ISO-8859-1), and this seemed to do the trick. Now,
>> IE will process the page according to what's in the meta tag.
>
>
> I tried to add:
> AddDefaultCharset utf-8
> in case this solved the problem with the double Unicode bytes displayed,
> but unfortunately not.
>
> But maybe the problem is caused by my hacked FMSA. I hacked it because I
> didn't want to use IIS on W2K3, so I'm running the web server connector
> on Linux with Apache (works great). To be able to use Apache instead of
> IIS, I had to download the mod_jk connector from jakarta.apache.org and
> build it for RHEL3. I don't think there is a build option for Unicode (I
> guess it handles Unicode without any build arguments).
>
> I'm not sure this is the core of the problem since searching and
> displaying Norwegian characters with UTF-8 works (it just doesn't handle
> the Cyrillic characters).
>
> So the URL for FMSA in "host detail" is actually localhost on Linux
> since I'm using the mod_jk connector to connect to FMSA (of course I had
> to change a lot of settings and mappings in httpd.conf.)
>
> BTW: If I browse the records using the DatabaseBrowser LassoApp, the
> Cyrillic characters are still incorrectly displayed.
>
> Erlend
>


--
------------------------------
Lasso Support: http://support.omnipilot.com/
Search the list archives: http://www.listsearch.com/lassotalk.lasso
Manage your list subscription:  
http://www.listsearch.com/lassotalk.lasso?manage