Examples Pack Error

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|

Examples Pack Error

Mark Palmer
Hi List,

Lasso 8.5.1b5 on OSX 10.4.7

I thought I'd take a look at the Examples Pack this morning but am  
getting the following error when trying to hit any of the 4 examples.

The tag target already existed and the existing copy is frozen. It  
can not be replaced.
at: tagp with params: 'target', -namespace='ljax_', -
optional='target', -optional='nooutput', -optional='notarget', -
optional='anytarget', -container, \_global_anonymous
at: /examplespack/library.lasso on line: 602 at position: 2
at: library with params: '/examplespack/library.lasso'
at: /examplespack/Collaborate/index.lasso on line: 11 at position: 2
Error Code: -9941

Response:   /examplespack/MessageBoard/index.lasso


I can't see any other instances of the examples pack on the server  
and I have restarted Lasso.

Regards

Mark Palmer
E: [hidden email]
T: 01902 620500
W: www.pageworks.co.uk





------------------------------
Lasso Support: http://support.omnipilot.com/
Search the list archives: http://www.listsearch.com/lassotalk.lasso
Manage your list subscription:  
http://www.listsearch.com/lassotalk.lasso?manage
Reply | Threaded
Open this post in threaded view
|

Large files not uploading

Lee Glickenhaus
Something fishy going on.

I have an upload solution.  Over time, files of all sizes have been
uploaded.  I now notice that large files are not being processed -- click
the submit button and the wheel spins but nothing ever happens.

So far, "large" is about 2 megs though I don't know where the exact cutoff
is.  200k is OK.

LP 8.1 on OS X 10.3 and 10.4 -- anyone have any clues why this might happen?

lee



------------------------------
Lasso Support: http://support.omnipilot.com/
Search the list archives: http://www.listsearch.com/lassotalk.lasso
Manage your list subscription:  
http://www.listsearch.com/lassotalk.lasso?manage
Reply | Threaded
Open this post in threaded view
|

Re: Large files not uploading MORE INFO

Lee Glickenhaus
OK -- its not the upload, its attaching the file to an e mail as part of the
process that's the problem.

The file uploads right quick.

If I remove this line of code in the e mail send:
-Attachments=($path)($doc_name),

its all good.

But with that line present, the system hangs with large files.

Grateful for any insights

Lee


on 8/22/06 12:24 PM, Lee Glickenhaus wrote:

> Something fishy going on.
>
> I have an upload solution.  Over time, files of all sizes have been
> uploaded.  I now notice that large files are not being processed -- click
> the submit button and the wheel spins but nothing ever happens.
>
> So far, "large" is about 2 megs though I don't know where the exact cutoff
> is.  200k is OK.
>
> LP 8.1 on OS X 10.3 and 10.4 -- anyone have any clues why this might happen?
>
> lee



------------------------------
Lasso Support: http://support.omnipilot.com/
Search the list archives: http://www.listsearch.com/lassotalk.lasso
Manage your list subscription:  
http://www.listsearch.com/lassotalk.lasso?manage
Reply | Threaded
Open this post in threaded view
|

Re: Large files not uploading MORE INFO

Bil Corry-3
Lasso uses SQLite to store the message before sending it.  One thought is the max row size is set to something around 2mb.  Have you tried using [email_compose] with [email_immediate] to bypass the queue entirely?


- Bil


Lee Glickenhaus wrote:

> OK -- its not the upload, its attaching the file to an e mail as part of the
> process that's the problem.
>
> The file uploads right quick.
>
> If I remove this line of code in the e mail send:
> -Attachments=($path)($doc_name),
>
> its all good.
>
> But with that line present, the system hangs with large files.
>
> Grateful for any insights
>
> Lee
>
>
> on 8/22/06 12:24 PM, Lee Glickenhaus wrote:
>
>> Something fishy going on.
>>
>> I have an upload solution.  Over time, files of all sizes have been
>> uploaded.  I now notice that large files are not being processed -- click
>> the submit button and the wheel spins but nothing ever happens.
>>
>> So far, "large" is about 2 megs though I don't know where the exact cutoff
>> is.  200k is OK.
>>
>> LP 8.1 on OS X 10.3 and 10.4 -- anyone have any clues why this might happen?
>>
>> lee



------------------------------
Lasso Support: http://support.omnipilot.com/
Search the list archives: http://www.listsearch.com/lassotalk.lasso
Manage your list subscription:  
http://www.listsearch.com/lassotalk.lasso?manage
Reply | Threaded
Open this post in threaded view
|

Re: Large files not uploading MORE INFO

Fletcher Sandbeck
On 2006-08-22 at 10:44 by [hidden email] (Bil Corry):

>Lasso uses SQLite to store the message before sending it.  One thought
>is the max row size is set to something around 2mb.  Have you tried
>using [email_compose] with [email_immediate] to bypass the queue
>entirely?

There's no strict limit with SQLite. It doesn't have a max row size the same way MySQL does.  

However, it does take time for Lasso to encode a "large" email attachment.  I would guess that your page is timing out while Lasso works on processing the attachment.  Using [Email_Compose] and [Email_Immediate] might help or would at least provide more information about what is failing.

We also overhauled the way email attachments are encoded in Lasso 8.5.  If you are able to try with the new version it might be a good reason to upgrade.

[fletcher]
--
Fletcher Sandbeck                         [hidden email]
Director of Product Development       http://www.lassostudio.com
OmniPilot Software, Inc.                http://www.omnipilot.com

------------------------------
Lasso Support: http://support.omnipilot.com/
Search the list archives: http://www.listsearch.com/lassotalk.lasso
Manage your list subscription:  
http://www.listsearch.com/lassotalk.lasso?manage
Reply | Threaded
Open this post in threaded view
|

Re: Large files not uploading MORE INFO

Lee Glickenhaus
on 8/22/06 1:57 PM, Fletcher Sandbeck wrote:

>
> We also overhauled the way email attachments are encoded in Lasso 8.5.  If you
> are able to try with the new version it might be a good reason to upgrade.

Actually, its happening on 8.5 as well (sorry, forgot to mention that
before)

But I'll try [Email_Compose] and [Email_Immediate]

Thanks!

lee



------------------------------
Lasso Support: http://support.omnipilot.com/
Search the list archives: http://www.listsearch.com/lassotalk.lasso
Manage your list subscription:  
http://www.listsearch.com/lassotalk.lasso?manage