Email_Send - Failed to connect to host "smtp.gmail.com" - Also, odd email queue behavior

classic Classic list List threaded Threaded
9 messages Options
Reply | Threaded
Open this post in threaded view
|

Email_Send - Failed to connect to host "smtp.gmail.com" - Also, odd email queue behavior

Tom McFarlane (Lumen Patent Firm)
Lasso 9.2.6   Mac OS X 10.8.5

Hi folks,

A simple lasso test page on my server uses Email_Send to send a short plain text email. There are two issues:

1. Minor issue: After an email is sent, the lasso server queue still shows the message with status "Sending". The message, however, was sent (and delivered) with no error in the log. This is not a show-stopper, but why is the message still in the queue and not automatically deleted after it is sent, or at least show its status as "Sent"?

2. More important issue: When sending from a gmail account with "smtp.gmail.com" as the host, the messages always ends up stuck in the queue with the status "Sending" and the server log has the error "Failed to connect to host". I've tried both ports 465 and 587 with ssl true. I've also tried restarting the instance, but all to no avail. I'm able to send email using the same credentials using an email client running on the same machine as lasso, so there is no issue there. Any insights or suggestions? Is anyone out there able to get Email_Send working with a gmail account?

Thanks!
Tom McFarlane
Lumen Patent Firm

#############################################################
This message is sent to you because you are subscribed to
  the mailing list Lasso
[hidden email]
To unsubscribe, E-mail to: <[hidden email]>
Send administrative queries to  <[hidden email]>
Reply | Threaded
Open this post in threaded view
|

Re: Email_Send - Failed to connect to host "smtp.gmail.com" - Also, odd email queue behavior

stevepiercy
FWIW, I have experienced the same thing, also with Gmail as the
SMTP server.  I asked in LassoChat, and I think it had something
to do with permissions on the SQLite internal database that
manages the queue.  My memory is fuzzy on it.

--steve


On 9/27/13 at 11:54 AM, [hidden email] (Tom McFarlane (Lumen
Patent Firm)) pronounced:

>Lasso 9.2.6   Mac OS X 10.8.5
>
>Hi folks,
>
>A simple lasso test page on my server uses Email_Send to send a
>short plain text email. There are two issues:
>
>1. Minor issue: After an email is sent, the lasso server queue
>still shows the message with status "Sending". The message,
>however, was sent (and delivered) with no error in the log.
>This is not a show-stopper, but why is the message still in the
>queue and not automatically deleted after it is sent, or at
>least show its status as "Sent"?
>
>2. More important issue: When sending from a gmail account with
>"smtp.gmail.com" as the host, the messages always ends up stuck
>in the queue with the status "Sending" and the server log has
>the error "Failed to connect to host". I've tried both ports
>465 and 587 with ssl true. I've also tried restarting the
>instance, but all to no avail. I'm able to send email using the
>same credentials using an email client running on the same
>machine as lasso, so there is no issue there. Any insights or
>suggestions? Is anyone out there able to get Email_Send working
>with a gmail account?
>Thanks!
>Tom McFarlane
>Lumen Patent Firm
>
>#############################################################
>This message is sent to you because you are subscribed to
>the mailing list Lasso
>[hidden email]
>To unsubscribe, E-mail to: <[hidden email]>
>Send administrative queries to  <[hidden email]>

-- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
-- --
Steve Piercy               Web Site Builder              
Soquel, CA
<[hidden email]>                  <http://www.StevePiercy.com/>


#############################################################
This message is sent to you because you are subscribed to
  the mailing list Lasso
[hidden email]
To unsubscribe, E-mail to: <[hidden email]>
Send administrative queries to  <[hidden email]>
Reply | Threaded
Open this post in threaded view
|

Re: Email_Send - Failed to connect to host "smtp.gmail.com" - Also, odd email queue behavior

Tom McFarlane (Lumen Patent Firm)
Thanks, Steve. I'd be curious if anyone out there has been able to get Email_Send to work with smtp.gmail.com

-Tom

On Sep 27, 2013, at 1:55 PM, Steve Piercy - Web Site Builder <[hidden email]> wrote:

> FWIW, I have experienced the same thing, also with Gmail as the SMTP server.  I asked in LassoChat, and I think it had something to do with permissions on the SQLite internal database that manages the queue.  My memory is fuzzy on it.
>
> --steve
>
>
> On 9/27/13 at 11:54 AM, [hidden email] (Tom McFarlane (Lumen Patent Firm)) pronounced:
>
>> Lasso 9.2.6   Mac OS X 10.8.5
>>
>> Hi folks,
>>
>> A simple lasso test page on my server uses Email_Send to send a short plain text email. There are two issues:
>>
>> 1. Minor issue: After an email is sent, the lasso server queue still shows the message with status "Sending". The message, however, was sent (and delivered) with no error in the log. This is not a show-stopper, but why is the message still in the queue and not automatically deleted after it is sent, or at least show its status as "Sent"?
>>
>> 2. More important issue: When sending from a gmail account with "smtp.gmail.com" as the host, the messages always ends up stuck in the queue with the status "Sending" and the server log has the error "Failed to connect to host". I've tried both ports 465 and 587 with ssl true. I've also tried restarting the instance, but all to no avail. I'm able to send email using the same credentials using an email client running on the same machine as lasso, so there is no issue there. Any insights or suggestions? Is anyone out there able to get Email_Send working with a gmail account?
>> Thanks!
>> Tom McFarlane
>> Lumen Patent Firm
>>
>> #############################################################
>> This message is sent to you because you are subscribed to
>> the mailing list Lasso
>> [hidden email]
>> To unsubscribe, E-mail to: <[hidden email]>
>> Send administrative queries to  <[hidden email]>
>
> -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
> Steve Piercy               Web Site Builder               Soquel, CA
> <[hidden email]>                  <http://www.StevePiercy.com/>
>
>
> #############################################################
> This message is sent to you because you are subscribed to
> the mailing list Lasso
> [hidden email]
> To unsubscribe, E-mail to: <[hidden email]>
> Send administrative queries to  <[hidden email]>


#############################################################
This message is sent to you because you are subscribed to
  the mailing list Lasso
[hidden email]
To unsubscribe, E-mail to: <[hidden email]>
Send administrative queries to  <[hidden email]>
Reply | Threaded
Open this post in threaded view
|

Re: Email_Send - Failed to connect to host "smtp.gmail.com" - Also, odd email queue behavior

Justin Dennis-3
In my experience, Gmail does not perform well with email_send. We moved to
an email service provider (sendgrid.com) and have enjoyed trouble free
email ever since. I know that doesn't answer the question, but this move
was such an improvement for us that I had to mention it.

- Justin


On Mon, Sep 30, 2013 at 6:58 PM, Tom McFarlane (Lumen Patent Firm) <
[hidden email]> wrote:

> Thanks, Steve. I'd be curious if anyone out there has been able to get
> Email_Send to work with smtp.gmail.com
>

#############################################################
This message is sent to you because you are subscribed to
  the mailing list Lasso
[hidden email]
To unsubscribe, E-mail to: <[hidden email]>
Send administrative queries to  <[hidden email]>
Reply | Threaded
Open this post in threaded view
|

Re: Email_Send - Failed to connect to host "smtp.gmail.com" - Also, odd email queue behavior

Brad Lindsay
I echo Justin's sentiment and would highly recommend checking out other
services such as Mandril, SendGrid, or Mailgun.

FWIW - I'm seeing the same issue you are, abd I've had problems with
gmail's servers using other language's solutions in the past.

Brad

On 9/30/13, 9:22 PM, Justin Dennis wrote:

> In my experience, Gmail does not perform well with email_send. We moved to
> an email service provider (sendgrid.com) and have enjoyed trouble free
> email ever since. I know that doesn't answer the question, but this move
> was such an improvement for us that I had to mention it.
>
> - Justin
>
>
> On Mon, Sep 30, 2013 at 6:58 PM, Tom McFarlane (Lumen Patent Firm)<
> [hidden email]>  wrote:
>
>> Thanks, Steve. I'd be curious if anyone out there has been able to get
>> Email_Send to work with smtp.gmail.com
>>
>
> #############################################################
> This message is sent to you because you are subscribed to
>    the mailing list Lasso
> [hidden email]
> To unsubscribe, E-mail to:<[hidden email]>
> Send administrative queries to<[hidden email]>

#############################################################
This message is sent to you because you are subscribed to
  the mailing list Lasso
[hidden email]
To unsubscribe, E-mail to: <[hidden email]>
Send administrative queries to  <[hidden email]>
Reply | Threaded
Open this post in threaded view
|

Re: Email_Send - Failed to connect to host "smtp.gmail.com" - Also, odd email queue behavior

Steffan A. Cline
I have clients that use Gmail without any problems. There is a tag at
tagswap that you drop into your startup and it solves the problem. You
also have to go into the gmail control panel and allow the ports etc.


Thanks

Steffan

---------------------------------------------------------------
T E L  6 0 2 . 7 9 3 . 0 0 1 4 | F A X  6 0 2 . 9 7 1 . 1 6 9 4
Steffan A. Cline   [hidden email]
http://www.ExecuChoice.net                 Phoenix, Arizona USA
                 
---------------------------------------------------------------






On 10/1/13 6:17 AM, "Brad Lindsay" <[hidden email]> wrote:

>I echo Justin's sentiment and would highly recommend checking out other
>services such as Mandril, SendGrid, or Mailgun.
>
>FWIW - I'm seeing the same issue you are, abd I've had problems with
>gmail's servers using other language's solutions in the past.
>
>Brad
>
>On 9/30/13, 9:22 PM, Justin Dennis wrote:
>> In my experience, Gmail does not perform well with email_send. We moved
>>to
>> an email service provider (sendgrid.com) and have enjoyed trouble free
>> email ever since. I know that doesn't answer the question, but this move
>> was such an improvement for us that I had to mention it.
>>
>> - Justin
>>
>>
>> On Mon, Sep 30, 2013 at 6:58 PM, Tom McFarlane (Lumen Patent Firm)<
>> [hidden email]>  wrote:
>>
>>> Thanks, Steve. I'd be curious if anyone out there has been able to get
>>> Email_Send to work with smtp.gmail.com
>>>
>>
>> #############################################################
>> This message is sent to you because you are subscribed to
>>    the mailing list Lasso
>> [hidden email]
>> To unsubscribe, E-mail to:<[hidden email]>
>> Send administrative queries to<[hidden email]>
>
>#############################################################
>This message is sent to you because you are subscribed to
>  the mailing list Lasso
>[hidden email]
>To unsubscribe, E-mail to: <[hidden email]>
>Send administrative queries to  <[hidden email]>
>



#############################################################
This message is sent to you because you are subscribed to
  the mailing list Lasso
[hidden email]
To unsubscribe, E-mail to: <[hidden email]>
Send administrative queries to  <[hidden email]>
Reply | Threaded
Open this post in threaded view
|

Re: Email_Send - Failed to connect to host "smtp.gmail.com" - Also, odd email queue behavior

Tom McFarlane (Lumen Patent Firm)
Steffan,

Can you point me to that tag at tagswap that solves this problem? The only tag I see there is [email_pop], but that appears to be specific to receiving mail from gmail pop servers, whereas the problem I'm having is with sending email using gmail smtp servers.

Also, if you could elaborate on the "gmail control panel and allow the ports etc." that would be appreciated. In gmail->settings, I see no port settings under any tab.

Thanks!
Tom

On Oct 1, 2013, at 11:39 AM, Steffan A. Cline <[hidden email]> wrote:

> I have clients that use Gmail without any problems. There is a tag at
> tagswap that you drop into your startup and it solves the problem. You
> also have to go into the gmail control panel and allow the ports etc.
>
>
> Thanks
>
> Steffan
>
> ---------------------------------------------------------------
> T E L  6 0 2 . 7 9 3 . 0 0 1 4 | F A X  6 0 2 . 9 7 1 . 1 6 9 4
> Steffan A. Cline   [hidden email]
> http://www.ExecuChoice.net                 Phoenix, Arizona USA
>
> ---------------------------------------------------------------
>
>
>
>
>
>
> On 10/1/13 6:17 AM, "Brad Lindsay" <[hidden email]> wrote:
>
>> I echo Justin's sentiment and would highly recommend checking out other
>> services such as Mandril, SendGrid, or Mailgun.
>>
>> FWIW - I'm seeing the same issue you are, abd I've had problems with
>> gmail's servers using other language's solutions in the past.
>>
>> Brad
>>
>> On 9/30/13, 9:22 PM, Justin Dennis wrote:
>>> In my experience, Gmail does not perform well with email_send. We moved
>>> to
>>> an email service provider (sendgrid.com) and have enjoyed trouble free
>>> email ever since. I know that doesn't answer the question, but this move
>>> was such an improvement for us that I had to mention it.
>>>
>>> - Justin
>>>
>>>
>>> On Mon, Sep 30, 2013 at 6:58 PM, Tom McFarlane (Lumen Patent Firm)<
>>> [hidden email]>  wrote:
>>>
>>>> Thanks, Steve. I'd be curious if anyone out there has been able to get
>>>> Email_Send to work with smtp.gmail.com
>>>>
>>>
>>> #############################################################
>>> This message is sent to you because you are subscribed to
>>>   the mailing list Lasso
>>> [hidden email]
>>> To unsubscribe, E-mail to:<[hidden email]>
>>> Send administrative queries to<[hidden email]>
>>
>> #############################################################
>> This message is sent to you because you are subscribed to
>> the mailing list Lasso
>> [hidden email]
>> To unsubscribe, E-mail to: <[hidden email]>
>> Send administrative queries to  <[hidden email]>
>>
>
>
>
> #############################################################
> This message is sent to you because you are subscribed to
>  the mailing list Lasso
> [hidden email]
> To unsubscribe, E-mail to: <[hidden email]>
> Send administrative queries to  <[hidden email]>


#############################################################
This message is sent to you because you are subscribed to
  the mailing list Lasso
[hidden email]
To unsubscribe, E-mail to: <[hidden email]>
Send administrative queries to  <[hidden email]>
Reply | Threaded
Open this post in threaded view
|

Re: Email_Send - Failed to connect to host "smtp.gmail.com" - Also, odd email queue behavior

stevepiercy
Also make the distinction between a regular old Gmail account
and the Google business app Gmail.  I think Steffan refers to
the latter.

--steve


On 10/1/13 at 2:51 PM, [hidden email] (Tom McFarlane (Lumen
Patent Firm)) pronounced:

>Steffan,
>
>Can you point me to that tag at tagswap that solves this
>problem? The only tag I see there is [email_pop], but that
>appears to be specific to receiving mail from gmail pop
>servers, whereas the problem I'm having is with sending email
>using gmail smtp servers.
>Also, if you could elaborate on the "gmail control panel and
>allow the ports etc." that would be appreciated. In
>gmail->settings, I see no port settings under any tab.
>
>Thanks!
>Tom
>
>On Oct 1, 2013, at 11:39 AM, Steffan A. Cline <[hidden email]> wrote:
>
>>I have clients that use Gmail without any problems. There is a tag at
>>tagswap that you drop into your startup and it solves the problem. You
>>also have to go into the gmail control panel and allow the ports etc.
>>
>>
>>Thanks
>>
>>Steffan
>>
>>---------------------------------------------------------------
>>T E L  6 0 2 . 7 9 3 . 0 0 1 4 | F A X  6 0 2 . 9 7 1 . 1 6 9 4
>>Steffan A. Cline            [hidden email]
>>http://www.ExecuChoice.net                 Phoenix, Arizona USA
>>
>>---------------------------------------------------------------
>>
>>
>>
>>
>>
>>
>>On 10/1/13 6:17 AM, "Brad Lindsay" <[hidden email]> wrote:
>>
>>> I echo Justin's sentiment and would highly recommend checking out other
>>> services such as Mandril, SendGrid, or Mailgun.
>>>   FWIW - I'm seeing the same issue you are, abd I've had
>>>problems with
>>> gmail's servers using other language's solutions in the past.
>>>   Brad
>>>   On 9/30/13, 9:22 PM, Justin Dennis wrote:
>>>> In my experience, Gmail does not perform well with email_send. We moved
>>>> to
>>>> an email service provider (sendgrid.com) and have enjoyed trouble free
>>>> email ever since. I know that doesn't answer the question, but this move
>>>> was such an improvement for us that I had to mention it.
>>>>   - Justin
>>>>    On Mon, Sep 30, 2013 at 6:58 PM, Tom McFarlane (Lumen
>>>>Patent Firm)<
>>>> [hidden email]>  wrote:
>>>>
>>>>> Thanks, Steve. I'd be curious if anyone out there has been able to get
>>>>> Email_Send to work with smtp.gmail.com
>>>>>
>>>>   #############################################################
>>>> This message is sent to you because you are subscribed to
>>>>   the mailing list Lasso
>>>> [hidden email]
>>>> To unsubscribe, E-mail to:<[hidden email]>
>>>> Send administrative queries to<[hidden email]>
>>>   #############################################################
>>> This message is sent to you because you are subscribed to
>>> the mailing list Lasso
>>> [hidden email]
>>> To unsubscribe, E-mail to: <[hidden email]>
>>> Send administrative queries to  <[hidden email]>
>>>
>>
>>
>>
>>#############################################################
>>This message is sent to you because you are subscribed to
>>the mailing list Lasso
>>[hidden email]
>>To unsubscribe, E-mail to: <[hidden email]>
>>Send administrative queries to  <[hidden email]>
>
>
>#############################################################
>This message is sent to you because you are subscribed to
>the mailing list Lasso
>[hidden email]
>To unsubscribe, E-mail to: <[hidden email]>
>Send administrative queries to  <[hidden email]>

-- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
-- --
Steve Piercy               Web Site Builder              
Soquel, CA
<[hidden email]>                  <http://www.StevePiercy.com/>


#############################################################
This message is sent to you because you are subscribed to
  the mailing list Lasso
[hidden email]
To unsubscribe, E-mail to: <[hidden email]>
Send administrative queries to  <[hidden email]>
Reply | Threaded
Open this post in threaded view
|

Re: Email_Send - Failed to connect to host "smtp.gmail.com" - Also, odd email queue behavior

Steffan A. Cline
I'll have to check my code base later when I have access but I think this
thread played a large part of it.

http://lasso.2283332.n4.nabble.com/email-pop-Connection-to-Gmail-Possible-t
d3140520.html




Thanks

Steffan

---------------------------------------------------------------
T E L  6 0 2 . 7 9 3 . 0 0 1 4 | F A X  6 0 2 . 9 7 1 . 1 6 9 4
Steffan A. Cline   [hidden email]
http://www.ExecuChoice.net                 Phoenix, Arizona USA
                 
---------------------------------------------------------------






On 10/1/13 2:56 PM, "Steve Piercy - Web Site Builder"
<[hidden email]> wrote:

>Also make the distinction between a regular old Gmail account
>and the Google business app Gmail.  I think Steffan refers to
>the latter.
>
>--steve
>
>
>On 10/1/13 at 2:51 PM, [hidden email] (Tom McFarlane (Lumen
>Patent Firm)) pronounced:
>
>>Steffan,
>>
>>Can you point me to that tag at tagswap that solves this
>>problem? The only tag I see there is [email_pop], but that
>>appears to be specific to receiving mail from gmail pop
>>servers, whereas the problem I'm having is with sending email
>>using gmail smtp servers.
>>Also, if you could elaborate on the "gmail control panel and
>>allow the ports etc." that would be appreciated. In
>>gmail->settings, I see no port settings under any tab.
>>
>>Thanks!
>>Tom
>>
>>On Oct 1, 2013, at 11:39 AM, Steffan A. Cline <[hidden email]> wrote:
>>
>>>I have clients that use Gmail without any problems. There is a tag at
>>>tagswap that you drop into your startup and it solves the problem. You
>>>also have to go into the gmail control panel and allow the ports etc.
>>>
>>>
>>>Thanks
>>>
>>>Steffan
>>>
>>>---------------------------------------------------------------
>>>T E L  6 0 2 . 7 9 3 . 0 0 1 4 | F A X  6 0 2 . 9 7 1 . 1 6 9 4
>>>Steffan A. Cline            [hidden email]
>>>http://www.ExecuChoice.net                 Phoenix, Arizona USA
>>>
>>>---------------------------------------------------------------
>>>
>>>
>>>
>>>
>>>
>>>
>>>On 10/1/13 6:17 AM, "Brad Lindsay" <[hidden email]> wrote:
>>>
>>>> I echo Justin's sentiment and would highly recommend checking out
>>>>other
>>>> services such as Mandril, SendGrid, or Mailgun.
>>>>   FWIW - I'm seeing the same issue you are, abd I've had
>>>>problems with
>>>> gmail's servers using other language's solutions in the past.
>>>>   Brad
>>>>   On 9/30/13, 9:22 PM, Justin Dennis wrote:
>>>>> In my experience, Gmail does not perform well with email_send. We
>>>>>moved
>>>>> to
>>>>> an email service provider (sendgrid.com) and have enjoyed trouble
>>>>>free
>>>>> email ever since. I know that doesn't answer the question, but this
>>>>>move
>>>>> was such an improvement for us that I had to mention it.
>>>>>   - Justin
>>>>>    On Mon, Sep 30, 2013 at 6:58 PM, Tom McFarlane (Lumen
>>>>>Patent Firm)<
>>>>> [hidden email]>  wrote:
>>>>>
>>>>>> Thanks, Steve. I'd be curious if anyone out there has been able to
>>>>>>get
>>>>>> Email_Send to work with smtp.gmail.com
>>>>>>
>>>>>   #############################################################
>>>>> This message is sent to you because you are subscribed to
>>>>>   the mailing list Lasso
>>>>> [hidden email]
>>>>> To unsubscribe, E-mail to:<[hidden email]>
>>>>> Send administrative queries to<[hidden email]>
>>>>   #############################################################
>>>> This message is sent to you because you are subscribed to
>>>> the mailing list Lasso
>>>> [hidden email]
>>>> To unsubscribe, E-mail to: <[hidden email]>
>>>> Send administrative queries to  <[hidden email]>
>>>>
>>>
>>>
>>>
>>>#############################################################
>>>This message is sent to you because you are subscribed to
>>>the mailing list Lasso
>>>[hidden email]
>>>To unsubscribe, E-mail to: <[hidden email]>
>>>Send administrative queries to  <[hidden email]>
>>
>>
>>#############################################################
>>This message is sent to you because you are subscribed to
>>the mailing list Lasso
>>[hidden email]
>>To unsubscribe, E-mail to: <[hidden email]>
>>Send administrative queries to  <[hidden email]>
>
>-- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
>-- --
>Steve Piercy               Web Site Builder
>Soquel, CA
><[hidden email]>                  <http://www.StevePiercy.com/>
>
>
>#############################################################
>This message is sent to you because you are subscribed to
>  the mailing list Lasso
>[hidden email]
>To unsubscribe, E-mail to: <[hidden email]>
>Send administrative queries to  <[hidden email]>
>



#############################################################
This message is sent to you because you are subscribed to
  the mailing list Lasso
[hidden email]
To unsubscribe, E-mail to: <[hidden email]>
Send administrative queries to  <[hidden email]>