Curse of the Undead LassoModules

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

Curse of the Undead LassoModules

Ari Denison
Lasso 9.2.6 (developer mode on a test server)
CentOS 6.5

I have a file named my_tags.inc in /var/lasso/instances/default/LassoModules/ it contains definitions for various tags.

I want to update this file, changing some tags and removing others. No matter what I do I can not get the server to recognize my changes. I’ve tried just about everything I can think of.

1. Uploaded new version of my_tags.inc, restarted instance, restarted lassoimd. No change. Old my_tags.inc definitions still loaded.
2. Introduced an intentional error into my_tags.inc. Restarted instance, restarted lassoed. No change. Old my_tags.inc definitions still loaded.
3. Removed my_tags.inc from server entirely. Restarted instance, restarted lassoed. No change. Old my_tags.inc definitions still loaded despite my_tags.inc not being anywhere on server.
4. Restarted server operating system.  Old my_tags.inc definitions still loaded even after restart with no my_tags.inc anywhere on the server!
5. Uninstalled Lasso via Yum. Reinstalled. Old my_tags.inc definitions still loaded.

Obviously I’m doing something very wrong.

Can anyone instruct me on how to exorcise these old definitions from my server?




#############################################################
This message is sent to you because you are subscribed to
  the mailing list Lasso [hidden email]
Official list archives available at http://www.lassotalk.com
To unsubscribe, E-mail to: <[hidden email]>
Send administrative queries to  <[hidden email]>
Reply | Threaded
Open this post in threaded view
|

Re: Curse of the Undead LassoModules

Jolle Carlestam-2
13 mar 2014 kl. 11:08 skrev Ari Denison <[hidden email]>:

> Lasso 9.2.6 (developer mode on a test server)
> CentOS 6.5
>
> I have a file named my_tags.inc in /var/lasso/instances/default/LassoModules/ it contains definitions for various tags.
>
> I want to update this file, changing some tags and removing others. No matter what I do I can not get the server to recognize my changes. I’ve tried just about everything I can think of.
>
> 1. Uploaded new version of my_tags.inc, restarted instance, restarted lassoimd. No change. Old my_tags.inc definitions still loaded.
> 2. Introduced an intentional error into my_tags.inc. Restarted instance, restarted lassoed. No change. Old my_tags.inc definitions still loaded.
> 3. Removed my_tags.inc from server entirely. Restarted instance, restarted lassoed. No change. Old my_tags.inc definitions still loaded despite my_tags.inc not being anywhere on server.
> 4. Restarted server operating system.  Old my_tags.inc definitions still loaded even after restart with no my_tags.inc anywhere on the server!
> 5. Uninstalled Lasso via Yum. Reinstalled. Old my_tags.inc definitions still loaded.
>
> Obviously I’m doing something very wrong.
>
> Can anyone instruct me on how to exorcise these old definitions from my server?

To my knowledge, custom types and methods are not loaded from LassoModules. I would examine what you have in LassoStartup, LassoLibraries and LassoApp. My guess is that there is a file in one of those dirs with the definitions you're trying to alter.

HDB
Jolle
#############################################################
This message is sent to you because you are subscribed to
  the mailing list Lasso [hidden email]
Official list archives available at http://www.lassotalk.com
To unsubscribe, E-mail to: <[hidden email]>
Send administrative queries to  <[hidden email]>
Reply | Threaded
Open this post in threaded view
|

Re: Curse of the Undead LassoModules

Ari Denison
Yup, that was it. And I knew that. Feeling a bit rusty.  

On Mar 12, 2014, at 8:20 PM, Jolle Carlestam <[hidden email]> wrote:

> 13 mar 2014 kl. 11:08 skrev Ari Denison <[hidden email]>:
>
>> Lasso 9.2.6 (developer mode on a test server)
>> CentOS 6.5
>>
>> I have a file named my_tags.inc in /var/lasso/instances/default/LassoModules/ it contains definitions for various tags.
>>
>> I want to update this file, changing some tags and removing others. No matter what I do I can not get the server to recognize my changes. I’ve tried just about everything I can think of.
>>
>> 1. Uploaded new version of my_tags.inc, restarted instance, restarted lassoimd. No change. Old my_tags.inc definitions still loaded.
>> 2. Introduced an intentional error into my_tags.inc. Restarted instance, restarted lassoed. No change. Old my_tags.inc definitions still loaded.
>> 3. Removed my_tags.inc from server entirely. Restarted instance, restarted lassoed. No change. Old my_tags.inc definitions still loaded despite my_tags.inc not being anywhere on server.
>> 4. Restarted server operating system.  Old my_tags.inc definitions still loaded even after restart with no my_tags.inc anywhere on the server!
>> 5. Uninstalled Lasso via Yum. Reinstalled. Old my_tags.inc definitions still loaded.
>>
>> Obviously I’m doing something very wrong.
>>
>> Can anyone instruct me on how to exorcise these old definitions from my server?
>
> To my knowledge, custom types and methods are not loaded from LassoModules. I would examine what you have in LassoStartup, LassoLibraries and LassoApp. My guess is that there is a file in one of those dirs with the definitions you're trying to alter.
>
> HDB
> Jolle
> #############################################################
> This message is sent to you because you are subscribed to
>  the mailing list Lasso [hidden email]
> Official list archives available at http://www.lassotalk.com
> To unsubscribe, E-mail to: <[hidden email]>
> Send administrative queries to  <[hidden email]>

#############################################################
This message is sent to you because you are subscribed to
  the mailing list Lasso [hidden email]
Official list archives available at http://www.lassotalk.com
To unsubscribe, E-mail to: <[hidden email]>
Send administrative queries to  <[hidden email]>
Reply | Threaded
Open this post in threaded view
|

Re: Curse of the Undead LassoModules

Brad Lindsay
In reply to this post by Jolle Carlestam-2
On 3/12/14, 9:20 PM, Jolle Carlestam wrote:
> To my knowledge, custom types and methods are not loaded from LassoModules. I would examine what you have in LassoStartup, LassoLibraries and LassoApp. My guess is that there is a file in one of those dirs with the definitions you're trying to alter.

I echo what Jolle said about the file being in a different folder. I'm
not exactly sure what the behavior is for the various folders, but
here's what the folders are generally expecting:

LassoModules:
    Custom C/C++ compiled LCAPI libraries

LassoLibraries:
     Custom Lasso libraries that have been compiled

LassoStartup
     Custom Lasso code that hasn't been compiled ahead of time.

Brad
#############################################################
This message is sent to you because you are subscribed to
  the mailing list Lasso [hidden email]
Official list archives available at http://www.lassotalk.com
To unsubscribe, E-mail to: <[hidden email]>
Send administrative queries to  <[hidden email]>