Cannot start Lasso 9 Instance

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

Cannot start Lasso 9 Instance

stevepiercy
I cannot restart LIM.  I don't know where to look for clues.

$sudo lassoim restart/var/lasso/home/SQLiteDBs/
Loading instancemanager
Starting fastcgi server on socket /var/lasso/home/lasso9.im.fastcgi.sock
Launching instance default staticarray(1, /usr/sbin/lassoserver,
staticarray(-flisten, lasso.fastcgi.sock),
staticarray(TERM=xterm-color, __CF_USER_TEXT_ENCODING=0x0:0:0,
PATH=/Library/Frameworks/Python.framework/Versions/2.7/bin:/Users/stevepiercy/.venvburrito/bin:/usr/local/mysql/bin:/usr/local/bin:/usr/local/sbin:/opt/subversion/bin:/opt/local/bin:/opt/local/sbin:/usr/bin:/bin:/usr/sbin:/sbin:/usr/X11/bin:/usr/bin:/bin:/usr/sbin:/sbin:/usr/local/bin:/usr/X11/bin:/opt/local/bin:/usr/local/git/bin,
LANG=en_US.UTF-8, DISPLAY=:0.0, HOME=/Users/stevepiercy,
SHELL=/bin/bash, LASSO9_HOME=/var/lasso/instances/default/,
LASSO9_MASTER_HOME=/var/lasso/home/, LASSO9_NO_SERVICE=1), _lasso)

$sudo tail -F -50 /private/var/lasso/lasso.out.txt

Launching instance default staticarray(1, /usr/sbin/lassoserver,
staticarray(-flisten, lasso.fastcgi.sock),
staticarray(PATH=/opt/local/bin:/opt/local/sbin:/usr/bin:/bin:/usr/sbin:/sbin:/usr/local/bin:/usr/X11/bin,
LASSO9_HOME=/var/lasso/instances/default/,
LASSO9_MASTER_HOME=/var/lasso/home/, LASSO9_NO_SERVICE=1), _lasso)

I checked the permissions of the instance SQLite dbs, but I
don't see anything amiss:

/private/var/lasso/instances/default $sudo ls -al SQLiteDBs/
total 768
drwx------  11 lasso  _lasso     374 May 27 10:28 .
drwxr-xr-x  11 lasso  _lasso     374 May 25 15:47 ..
-rw-r--r--   1 lasso  _lasso  290816 May 14 06:23 database_registry
-rw-r--r--   1 lasso  _lasso   10240 May 14 05:27 lasso_email
-rw-r--r--   1 lasso  _lasso    4096 May 14 05:27 lasso_internal
-rw-r--r--   1 lasso  _lasso   39936 May 26 14:08 lasso_logbook
-rw-r--r--   1 lasso  _lasso   21504 May 27 10:28 lasso_session
-rw-r--r--   1 lasso  _lasso    4096 May 14 05:27 lassoapps_settings
-rw-r--r--   1 lasso  _lasso    2048 May 14 05:27 mysql_session_driver_data
-rw-r--r--   1 lasso  _lasso    2048 May 14 05:27 odbc_session_driver_data
-rw-r--r--   1 lasso  _lasso    7168 May 14 05:27 security_auth_registry

Both lasso and _lasso have the same id 14550.

LIM and Lasso 9 was working just fine prior to a restart this
morning.  So should I try a reinstall of Lasso 9, just restart
my machine, sacrifice a chicken...?

--steve

-- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
-- --
Steve Piercy               Web Site Builder              
Soquel, CA
<[hidden email]>                  <http://www.StevePiercy.com/>

#############################################################
This message is sent to you because you are subscribed to
  the mailing list Lasso
[hidden email]
To unsubscribe, E-mail to: <[hidden email]>
Send administrative queries to  <[hidden email]>
Reply | Threaded
Open this post in threaded view
|

Re: Cannot start Lasso 9 Instance

Jonathan Guthrie-3
For a start you're looking at the IM log not the instance log. Try using the UI to restart the instance because by restarting the IM you're not really doing what I suspect you think you are doing.


--
Jono

On 2012-05-28, at 12:19 AM, Steve Piercy - Web Site Builder <[hidden email]> wrote:

> I cannot restart LIM.  I don't know where to look for clues.
>
> $sudo lassoim restart/var/lasso/home/SQLiteDBs/
> Loading instancemanager
> Starting fastcgi server on socket /var/lasso/home/lasso9.im.fastcgi.sock
> Launching instance default staticarray(1, /usr/sbin/lassoserver, staticarray(-flisten, lasso.fastcgi.sock), staticarray(TERM=xterm-color, __CF_USER_TEXT_ENCODING=0x0:0:0, PATH=/Library/Frameworks/Python.framework/Versions/2.7/bin:/Users/stevepiercy/.venvburrito/bin:/usr/local/mysql/bin:/usr/local/bin:/usr/local/sbin:/opt/subversion/bin:/opt/local/bin:/opt/local/sbin:/usr/bin:/bin:/usr/sbin:/sbin:/usr/X11/bin:/usr/bin:/bin:/usr/sbin:/sbin:/usr/local/bin:/usr/X11/bin:/opt/local/bin:/usr/local/git/bin, LANG=en_US.UTF-8, DISPLAY=:0.0, HOME=/Users/stevepiercy, SHELL=/bin/bash, LASSO9_HOME=/var/lasso/instances/default/, LASSO9_MASTER_HOME=/var/lasso/home/, LASSO9_NO_SERVICE=1), _lasso)
>
> $sudo tail -F -50 /private/var/lasso/lasso.out.txt
>
> Launching instance default staticarray(1, /usr/sbin/lassoserver, staticarray(-flisten, lasso.fastcgi.sock), staticarray(PATH=/opt/local/bin:/opt/local/sbin:/usr/bin:/bin:/usr/sbin:/sbin:/usr/local/bin:/usr/X11/bin, LASSO9_HOME=/var/lasso/instances/default/, LASSO9_MASTER_HOME=/var/lasso/home/, LASSO9_NO_SERVICE=1), _lasso)
>
> I checked the permissions of the instance SQLite dbs, but I don't see anything amiss:
>
> /private/var/lasso/instances/default $sudo ls -al SQLiteDBs/
> total 768
> drwx------  11 lasso  _lasso     374 May 27 10:28 .
> drwxr-xr-x  11 lasso  _lasso     374 May 25 15:47 ..
> -rw-r--r--   1 lasso  _lasso  290816 May 14 06:23 database_registry
> -rw-r--r--   1 lasso  _lasso   10240 May 14 05:27 lasso_email
> -rw-r--r--   1 lasso  _lasso    4096 May 14 05:27 lasso_internal
> -rw-r--r--   1 lasso  _lasso   39936 May 26 14:08 lasso_logbook
> -rw-r--r--   1 lasso  _lasso   21504 May 27 10:28 lasso_session
> -rw-r--r--   1 lasso  _lasso    4096 May 14 05:27 lassoapps_settings
> -rw-r--r--   1 lasso  _lasso    2048 May 14 05:27 mysql_session_driver_data
> -rw-r--r--   1 lasso  _lasso    2048 May 14 05:27 odbc_session_driver_data
> -rw-r--r--   1 lasso  _lasso    7168 May 14 05:27 security_auth_registry
>
> Both lasso and _lasso have the same id 14550.
>
> LIM and Lasso 9 was working just fine prior to a restart this morning.  So should I try a reinstall of Lasso 9, just restart my machine, sacrifice a chicken...?
>
> --steve
>
> -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
> Steve Piercy               Web Site Builder               Soquel, CA
> <[hidden email]>                  <http://www.StevePiercy.com/>
>
> #############################################################
> This message is sent to you because you are subscribed to
> the mailing list Lasso
> [hidden email]
> To unsubscribe, E-mail to: <[hidden email]>
> Send administrative queries to  <[hidden email]>
#############################################################
This message is sent to you because you are subscribed to
  the mailing list Lasso
[hidden email]
To unsubscribe, E-mail to: <[hidden email]>
Send administrative queries to  <[hidden email]>
Reply | Threaded
Open this post in threaded view
|

Re: Cannot start Lasso 9 Instance

stevepiercy
Actually it's both, and I left off "and Instance Manager" in the
subject.  I cannot restart the LIM or the default instance.  ISE
500 for all in the browser.

In terminal:
----------------------------------
$sudo lassoim restart
Password:
/var/lasso/home/SQLiteDBs/
Loading instancemanager
Starting fastcgi server on socket /var/lasso/home/lasso9.im.fastcgi.sock
Launching instance default staticarray(1, /usr/sbin/lassoserver,
staticarray(-flisten, lasso.fastcgi.sock),
staticarray(TERM=xterm-color, __CF_USER_TEXT_ENCODING=0x0:0:0,
PATH=/Library/Frameworks/Python.framework/Versions/2.7/bin:/Users/stevepiercy/.venvburrito/bin:/usr/local/mysql/bin:/usr/local/bin:/usr/local/sbin:/opt/subversion/bin:/opt/local/bin:/opt/local/sbin:/usr/bin:/bin:/usr/sbin:/sbin:/usr/X11/bin:/usr/bin:/bin:/usr/sbin:/sbin:/usr/local/bin:/usr/X11/bin:/opt/local/bin:/usr/local/git/bin,
LANG=en_US.UTF-8, DISPLAY=:0.0, HOME=/Users/stevepiercy,
SHELL=/bin/bash, LASSO9_HOME=/var/lasso/instances/default/,
LASSO9_MASTER_HOME=/var/lasso/home/, LASSO9_NO_SERVICE=1), _lasso)
----------------------------------

The last line repeats every 2 seconds.

Permissions on SQLite dbs looks OK, as indicated below.

I am running 8 and 9 side by side via installers, and followed
the LS article to do so.  8 runs just fine.

*scratching head*

--steve


On 5/28/12 at 12:40 AM, [hidden email] (Jonathan Guthrie) pronounced:

>For a start you're looking at the IM log not the instance log.
>Try using the UI to restart the instance because by restarting
>the IM you're not really doing what I suspect you think you are doing.
>
>--
>Jono
>
>On 2012-05-28, at 12:19 AM, Steve Piercy - Web Site Builder <[hidden email]> wrote:
>
>>I cannot restart LIM.  I don't know where to look for clues.
>>
>>$sudo lassoim restart/var/lasso/home/SQLiteDBs/
>>Loading instancemanager
>>Starting fastcgi server on socket /var/lasso/home/lasso9.im.fastcgi.sock
>>Launching instance default staticarray(1, /usr/sbin/lassoserver, staticarray(-flisten,
>lasso.fastcgi.sock), staticarray(TERM=xterm-color,
>__CF_USER_TEXT_ENCODING=0x0:0:0, PATH=/Library/Frameworks/Python.framework/Versions/2.7/bin:/Users/stevepiercy/.venvburrito/
>bin:/usr/local/mysql/bin:/usr/local/bin:/usr/local/sbin:/opt/subversion/bin:/opt/local/bin:/
>opt/local/sbin:/usr/bin:/bin:/usr/sbin:/sbin:/usr/X11/bin:/usr/bin:/bin:/usr/sbin:/sbin:/usr
>/local/bin:/usr/X11/bin:/opt/local/bin:/usr/local/git/bin,
>LANG=en_US.UTF-8, DISPLAY=:0.0, HOME=/Users/stevepiercy,
>SHELL=/bin/bash, LASSO9_HOME=/var/lasso/instances/default/,
>LASSO9_MASTER_HOME=/var/lasso/home/, LASSO9_NO_SERVICE=1), _lasso)
>>
>>$sudo tail -F -50 /private/var/lasso/lasso.out.txt
>>
>>Launching instance default staticarray(1, /usr/sbin/lassoserver, staticarray(-flisten,
>lasso.fastcgi.sock), staticarray(PATH=/opt/local/bin:/opt/local/sbin:/usr/bin:/bin:/usr/sbin:/sbin:/usr/local/bin
>:/usr/X11/bin, LASSO9_HOME=/var/lasso/instances/default/,
>LASSO9_MASTER_HOME=/var/lasso/home/, LASSO9_NO_SERVICE=1), _lasso)
>>
>>I checked the permissions of the instance SQLite dbs, but I don't see anything amiss:
>>
>>/private/var/lasso/instances/default $sudo ls -al SQLiteDBs/
>>total 768
>>drwx------  11 lasso  _lasso     374 May 27 10:28 .
>>drwxr-xr-x  11 lasso  _lasso     374 May 25 15:47 ..
>>-rw-r--r--   1 lasso  _lasso  290816 May 14 06:23 database_registry
>>-rw-r--r--   1 lasso  _lasso   10240 May 14 05:27 lasso_email
>>-rw-r--r--   1 lasso  _lasso    4096 May 14 05:27 lasso_internal
>>-rw-r--r--   1 lasso  _lasso   39936 May 26 14:08 lasso_logbook
>>-rw-r--r--   1 lasso  _lasso   21504 May 27 10:28 lasso_session
>>-rw-r--r--   1 lasso  _lasso    4096 May 14 05:27 lassoapps_settings
>>-rw-r--r--   1 lasso  _lasso    2048 May 14 05:27 mysql_session_driver_data
>>-rw-r--r--   1 lasso  _lasso    2048 May 14 05:27 odbc_session_driver_data
>>-rw-r--r--   1 lasso  _lasso    7168 May 14 05:27 security_auth_registry
>>
>>Both lasso and _lasso have the same id 14550.
>>
>>LIM and Lasso 9 was working just fine prior to a restart this morning.  So should I try a
>reinstall of Lasso 9, just restart my machine, sacrifice a chicken...?
>>
>>--steve
>>
>>-- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
>>Steve Piercy               Web Site Builder               Soquel, CA
>><[hidden email]>                  <http://www.StevePiercy.com/>
>>
>>#############################################################
>>This message is sent to you because you are subscribed to
>>the mailing list Lasso
>>[hidden email]
>>To unsubscribe, E-mail to: <[hidden email]>
>>Send administrative queries to  <[hidden email]>
>#############################################################
>This message is sent to you because you are subscribed to
>the mailing list Lasso
>[hidden email]
>To unsubscribe, E-mail to: <[hidden email]>
>Send administrative queries to  <[hidden email]>

-- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
-- --
Steve Piercy               Web Site Builder              
Soquel, CA
<[hidden email]>                  <http://www.StevePiercy.com/>

#############################################################
This message is sent to you because you are subscribed to
  the mailing list Lasso
[hidden email]
To unsubscribe, E-mail to: <[hidden email]>
Send administrative queries to  <[hidden email]>
Reply | Threaded
Open this post in threaded view
|

Re: Cannot start Lasso 9 Instance

Eric Knibbe
Check Console.app for crash reports. Could be that you've unearthed a 10.5-specific issue.
‐‐‐‐‐‐‐‐‐‐✂‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐
Eric3
 

On 2012-05-28, at 10:17 AM, Steve Piercy - Web Site Builder wrote:

> Actually it's both, and I left off "and Instance Manager" in the subject.  I cannot restart the LIM or the default instance.  ISE 500 for all in the browser.
>
> In terminal:
> ----------------------------------
> $sudo lassoim restart
> Password:
> /var/lasso/home/SQLiteDBs/
> Loading instancemanager
> Starting fastcgi server on socket /var/lasso/home/lasso9.im.fastcgi.sock
> Launching instance default staticarray(1, /usr/sbin/lassoserver, staticarray(-flisten, lasso.fastcgi.sock), staticarray(TERM=xterm-color, __CF_USER_TEXT_ENCODING=0x0:0:0, PATH=/Library/Frameworks/Python.framework/Versions/2.7/bin:/Users/stevepiercy/.venvburrito/bin:/usr/local/mysql/bin:/usr/local/bin:/usr/local/sbin:/opt/subversion/bin:/opt/local/bin:/opt/local/sbin:/usr/bin:/bin:/usr/sbin:/sbin:/usr/X11/bin:/usr/bin:/bin:/usr/sbin:/sbin:/usr/local/bin:/usr/X11/bin:/opt/local/bin:/usr/local/git/bin, LANG=en_US.UTF-8, DISPLAY=:0.0, HOME=/Users/stevepiercy, SHELL=/bin/bash, LASSO9_HOME=/var/lasso/instances/default/, LASSO9_MASTER_HOME=/var/lasso/home/, LASSO9_NO_SERVICE=1), _lasso)
> ----------------------------------
>
> The last line repeats every 2 seconds.
>
> Permissions on SQLite dbs looks OK, as indicated below.
>
> I am running 8 and 9 side by side via installers, and followed the LS article to do so.  8 runs just fine.
>
> *scratching head*
>
> --steve
>
>
> On 5/28/12 at 12:40 AM, [hidden email] (Jonathan Guthrie) pronounced:
>
>> For a start you're looking at the IM log not the instance log. Try using the UI to restart the instance because by restarting the IM you're not really doing what I suspect you think you are doing.
>>
>> --
>> Jono
>>
>> On 2012-05-28, at 12:19 AM, Steve Piercy - Web Site Builder <[hidden email]> wrote:
>>
>>> I cannot restart LIM.  I don't know where to look for clues.
>>>
>>> $sudo lassoim restart/var/lasso/home/SQLiteDBs/
>>> Loading instancemanager
>>> Starting fastcgi server on socket /var/lasso/home/lasso9.im.fastcgi.sock
>>> Launching instance default staticarray(1, /usr/sbin/lassoserver, staticarray(-flisten,
>> lasso.fastcgi.sock), staticarray(TERM=xterm-color, __CF_USER_TEXT_ENCODING=0x0:0:0, PATH=/Library/Frameworks/Python.framework/Versions/2.7/bin:/Users/stevepiercy/.venvburrito/
>> bin:/usr/local/mysql/bin:/usr/local/bin:/usr/local/sbin:/opt/subversion/bin:/opt/local/bin:/
>> opt/local/sbin:/usr/bin:/bin:/usr/sbin:/sbin:/usr/X11/bin:/usr/bin:/bin:/usr/sbin:/sbin:/usr
>> /local/bin:/usr/X11/bin:/opt/local/bin:/usr/local/git/bin, LANG=en_US.UTF-8, DISPLAY=:0.0, HOME=/Users/stevepiercy, SHELL=/bin/bash, LASSO9_HOME=/var/lasso/instances/default/, LASSO9_MASTER_HOME=/var/lasso/home/, LASSO9_NO_SERVICE=1), _lasso)
>>>
>>> $sudo tail -F -50 /private/var/lasso/lasso.out.txt
>>>
>>> Launching instance default staticarray(1, /usr/sbin/lassoserver, staticarray(-flisten,
>> lasso.fastcgi.sock), staticarray(PATH=/opt/local/bin:/opt/local/sbin:/usr/bin:/bin:/usr/sbin:/sbin:/usr/local/bin
>> :/usr/X11/bin, LASSO9_HOME=/var/lasso/instances/default/, LASSO9_MASTER_HOME=/var/lasso/home/, LASSO9_NO_SERVICE=1), _lasso)
>>>
>>> I checked the permissions of the instance SQLite dbs, but I don't see anything amiss:
>>>
>>> /private/var/lasso/instances/default $sudo ls -al SQLiteDBs/
>>> total 768
>>> drwx------  11 lasso  _lasso     374 May 27 10:28 .
>>> drwxr-xr-x  11 lasso  _lasso     374 May 25 15:47 ..
>>> -rw-r--r--   1 lasso  _lasso  290816 May 14 06:23 database_registry
>>> -rw-r--r--   1 lasso  _lasso   10240 May 14 05:27 lasso_email
>>> -rw-r--r--   1 lasso  _lasso    4096 May 14 05:27 lasso_internal
>>> -rw-r--r--   1 lasso  _lasso   39936 May 26 14:08 lasso_logbook
>>> -rw-r--r--   1 lasso  _lasso   21504 May 27 10:28 lasso_session
>>> -rw-r--r--   1 lasso  _lasso    4096 May 14 05:27 lassoapps_settings
>>> -rw-r--r--   1 lasso  _lasso    2048 May 14 05:27 mysql_session_driver_data
>>> -rw-r--r--   1 lasso  _lasso    2048 May 14 05:27 odbc_session_driver_data
>>> -rw-r--r--   1 lasso  _lasso    7168 May 14 05:27 security_auth_registry
>>>
>>> Both lasso and _lasso have the same id 14550.
>>>
>>> LIM and Lasso 9 was working just fine prior to a restart this morning.  So should I try a
>> reinstall of Lasso 9, just restart my machine, sacrifice a chicken...?
>>>
>>> --steve
>>>
>>> -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
>>> Steve Piercy               Web Site Builder               Soquel, CA
>>> <[hidden email]>                  <http://www.StevePiercy.com/>
>>>
>>> #############################################################
>>> This message is sent to you because you are subscribed to
>>> the mailing list Lasso
>>> [hidden email]
>>> To unsubscribe, E-mail to: <[hidden email]>
>>> Send administrative queries to  <[hidden email]>
>> #############################################################
>> This message is sent to you because you are subscribed to
>> the mailing list Lasso
>> [hidden email]
>> To unsubscribe, E-mail to: <[hidden email]>
>> Send administrative queries to  <[hidden email]>
>
> -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
> Steve Piercy               Web Site Builder               Soquel, CA
> <[hidden email]>                  <http://www.StevePiercy.com/>
>
> #############################################################
> This message is sent to you because you are subscribed to
> the mailing list Lasso
> [hidden email]
> To unsubscribe, E-mail to: <[hidden email]>
> Send administrative queries to  <[hidden email]>

#############################################################
This message is sent to you because you are subscribed to
  the mailing list Lasso
[hidden email]
To unsubscribe, E-mail to: <[hidden email]>
Send administrative queries to  <[hidden email]>
Reply | Threaded
Open this post in threaded view
|

Re: Cannot start Lasso 9 Instance

stevepiercy
This turned out to be something I should not have done,
specifically creating a project in /private/var/lasso/home.  
Don't do that!

--steve


On 5/28/12 at 8:56 PM, [hidden email] (Eric Knibbe) pronounced:

>Check Console.app for crash reports. Could be that you've unearthed a 10.5-specific issue.
>‐‐‐‐‐‐‐‐‐‐✂‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐
>Eric3
>
>
>On 2012-05-28, at 10:17 AM, Steve Piercy - Web Site Builder wrote:
>
>>Actually it's both, and I left off "and Instance Manager" in the subject.  I cannot
>restart the LIM or the default instance.  ISE 500 for all in the browser.
>>
>>In terminal:
>>----------------------------------
>>$sudo lassoim restart
>>Password:
>>/var/lasso/home/SQLiteDBs/
>>Loading instancemanager
>>Starting fastcgi server on socket /var/lasso/home/lasso9.im.fastcgi.sock
>>Launching instance default staticarray(1, /usr/sbin/lassoserver, staticarray(-flisten,
>lasso.fastcgi.sock), staticarray(TERM=xterm-color,
>__CF_USER_TEXT_ENCODING=0x0:0:0, PATH=/Library/Frameworks/Python.framework/Versions/2.7/bin:/Users/stevepiercy/.venvburrito/
>bin:/usr/local/mysql/bin:/usr/local/bin:/usr/local/sbin:/opt/subversion/bin:/opt/local/bin:/
>opt/local/sbin:/usr/bin:/bin:/usr/sbin:/sbin:/usr/X11/bin:/usr/bin:/bin:/usr/sbin:/sbin:/usr
>/local/bin:/usr/X11/bin:/opt/local/bin:/usr/local/git/bin,
>LANG=en_US.UTF-8, DISPLAY=:0.0, HOME=/Users/stevepiercy,
>SHELL=/bin/bash, LASSO9_HOME=/var/lasso/instances/default/,
>LASSO9_MASTER_HOME=/var/lasso/home/, LASSO9_NO_SERVICE=1), _lasso)
>>----------------------------------
>>
>>The last line repeats every 2 seconds.
>>
>>Permissions on SQLite dbs looks OK, as indicated below.
>>
>>I am running 8 and 9 side by side via installers, and followed the LS article to do so.  8
>runs just fine.
>>
>>*scratching head*
>>
>>--steve
>>
>>
>>On 5/28/12 at 12:40 AM, [hidden email] (Jonathan Guthrie) pronounced:
>>
>>> For a start you're looking at the IM log not the instance log. Try using the UI to
>restart the instance because by restarting the IM you're not
>really doing what I suspect you think you are doing.
>>>   --
>>> Jono
>>>   On 2012-05-28, at 12:19 AM, Steve Piercy - Web Site
>>>Builder <[hidden email]> wrote:
>>>
>>>> I cannot restart LIM.  I don't know where to look for clues.
>>>>   $sudo lassoim restart/var/lasso/home/SQLiteDBs/
>>>> Loading instancemanager
>>>> Starting fastcgi server on socket /var/lasso/home/lasso9.im.fastcgi.sock
>>>> Launching instance default staticarray(1, /usr/sbin/lassoserver, staticarray(-flisten,
>>> lasso.fastcgi.sock), staticarray(TERM=xterm-color, __CF_USER_TEXT_ENCODING=0x0:0:0,
>PATH=/Library/Frameworks/Python.framework/Versions/2.7/bin:/Users/stevepiercy/.venvburrito/
>>>
>bin:/usr/local/mysql/bin:/usr/local/bin:/usr/local/sbin:/opt/subversion/bin:/opt/local/bin:/
>>>
>opt/local/sbin:/usr/bin:/bin:/usr/sbin:/sbin:/usr/X11/bin:/usr/bin:/bin:/usr/sbin:/sbin:/usr
>>> /local/bin:/usr/X11/bin:/opt/local/bin:/usr/local/git/bin, LANG=en_US.UTF-8,
>DISPLAY=:0.0, HOME=/Users/stevepiercy, SHELL=/bin/bash,
>LASSO9_HOME=/var/lasso/instances/default/,
>LASSO9_MASTER_HOME=/var/lasso/home/, LASSO9_NO_SERVICE=1), _lasso)
>>>>   $sudo tail -F -50 /private/var/lasso/lasso.out.txt
>>>>   Launching instance default staticarray(1,
>>>>/usr/sbin/lassoserver, staticarray(-flisten,
>>> lasso.fastcgi.sock),
>staticarray(PATH=/opt/local/bin:/opt/local/sbin:/usr/bin:/bin:/usr/sbin:/sbin:/usr/local/bin
>>> :/usr/X11/bin, LASSO9_HOME=/var/lasso/instances/default/,
>LASSO9_MASTER_HOME=/var/lasso/home/, LASSO9_NO_SERVICE=1), _lasso)
>>>>   I checked the permissions of the instance SQLite dbs, but
>>>>I don't see anything amiss:
>>>>   /private/var/lasso/instances/default $sudo ls -al SQLiteDBs/
>>>> total 768
>>>> drwx------  11 lasso  _lasso     374 May 27 10:28 .
>>>> drwxr-xr-x  11 lasso  _lasso     374 May 25 15:47 ..
>>>> -rw-r--r--   1 lasso  _lasso  290816 May 14 06:23 database_registry
>>>> -rw-r--r--   1 lasso  _lasso   10240 May 14 05:27 lasso_email
>>>> -rw-r--r--   1 lasso  _lasso    4096 May 14 05:27 lasso_internal
>>>> -rw-r--r--   1 lasso  _lasso   39936 May 26 14:08 lasso_logbook
>>>> -rw-r--r--   1 lasso  _lasso   21504 May 27 10:28 lasso_session
>>>> -rw-r--r--   1 lasso  _lasso    4096 May 14 05:27 lassoapps_settings
>>>> -rw-r--r--   1 lasso  _lasso    2048 May 14 05:27 mysql_session_driver_data
>>>> -rw-r--r--   1 lasso  _lasso    2048 May 14 05:27 odbc_session_driver_data
>>>> -rw-r--r--   1 lasso  _lasso    7168 May 14 05:27 security_auth_registry
>>>>   Both lasso and _lasso have the same id 14550.
>>>>   LIM and Lasso 9 was working just fine prior to a restart
>>>>this morning.  So should I try
>a
>>> reinstall of Lasso 9, just restart my machine, sacrifice a chicken...?
>>>>   --steve
>>>>   -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
>>>>-- -- -- --
>>>> Steve Piercy               Web Site Builder               Soquel, CA
>>>> <[hidden email]>                  <http://www.StevePiercy.com/>
>>>>   #############################################################
>>>> This message is sent to you because you are subscribed to
>>>> the mailing list Lasso
>>>> [hidden email]
>>>> To unsubscribe, E-mail to: <[hidden email]>
>>>> Send administrative queries to  <[hidden email]>
>>> #############################################################
>>> This message is sent to you because you are subscribed to
>>> the mailing list Lasso
>>> [hidden email]
>>> To unsubscribe, E-mail to: <[hidden email]>
>>> Send administrative queries to  <[hidden email]>
>>
>>-- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
>>Steve Piercy               Web Site Builder               Soquel, CA
>><[hidden email]>                  <http://www.StevePiercy.com/>
>>
>>#############################################################
>>This message is sent to you because you are subscribed to
>>the mailing list Lasso
>>[hidden email]
>>To unsubscribe, E-mail to: <[hidden email]>
>>Send administrative queries to  <[hidden email]>
>
>#############################################################
>This message is sent to you because you are subscribed to
>the mailing list Lasso
>[hidden email]
>To unsubscribe, E-mail to: <[hidden email]>
>Send administrative queries to  <[hidden email]>

-- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
-- --
Steve Piercy               Web Site Builder              
Soquel, CA
<[hidden email]>                  <http://www.StevePiercy.com/>

#############################################################
This message is sent to you because you are subscribed to
  the mailing list Lasso
[hidden email]
To unsubscribe, E-mail to: <[hidden email]>
Send administrative queries to  <[hidden email]>