8.6 upgrade, possible license issue

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

8.6 upgrade, possible license issue

maxwellk2
First, thank you LassoSoft, over the weekend my 8.6 upgrade under Mac OS X Server 10.5 went off without a hitch. Just download, double-click, restart Lasso, and everything's been running perfect since - this is the LassoSoft I know and love. Also, where 8.5.6 was silently crashing and recovering multiple times per day (I'm sure because of my less than optimal coding abilities) 8.6 appears to be rock solid.

This evening a client emailed me a screen shot of their browser with an odd Lasso error:

        Error Message: This edition of Lasso can only be accessed from 5 different IP addresses. Etc, etc...
        Error Code: -609

I know what the message means, but code -609 is "The specified database was not found.", which I also deal with from time to time. I confirmed this by hitting the site from a new unique IP address and got the same error, in retrospect I neglected to check to see if the error was occurring with any other sites, but I'm sure I would have heard from other clients.

Resetting that site appears to have resolved the issue, hitting the site from six different IP addresses and no more error. But the event has me curious about how licenses and instances now work and if the error is related.

My license covers 10 instances, and my CLD should cover 3 more. My server had 14 sites/instances configured and after the install all the SiteAdmin.LassoApp screens were fully accessible. After seeing the error above I've since removed 4 extraneous development sites just incase the error was caused by exceeding my instance count.

Any ideas or clarification?

Thanks,
Max

____________________________________________
Maxwell Klein Consulting, Inc.
Database Development & Web Integration
[hidden email] ~ www.maxkdev.com
415-902-7623 ~ 800-948-5510 fax


#############################################################
This message is sent to you because you are subscribed to
  the mailing list <[hidden email]>.
To unsubscribe, E-mail to: <[hidden email]>
To switch to the DIGEST mode, E-mail to <[hidden email]>
To switch to the INDEX mode, E-mail to <[hidden email]>
Send administrative queries to  <[hidden email]>

Reply | Threaded
Open this post in threaded view
|

Re: 8.6 upgrade, possible license issue

jasonhuck
Just a guess, but I suspect you can't combine instances from two
different licenses on a single installation of Lasso, since there's no
way for the licensing mechanism to know what you're doing. The only
way that could work is if Lasso accepted multiple serial numbers, or
you were issued a special serial number which represents the
combination of the two separate licenses.

- jason




On Mon, Apr 11, 2011 at 9:32 PM, Maxwell Klein <[hidden email]> wrote:

> First, thank you LassoSoft, over the weekend my 8.6 upgrade under Mac OS X Server 10.5 went off without a hitch. Just download, double-click, restart Lasso, and everything's been running perfect since - this is the LassoSoft I know and love. Also, where 8.5.6 was silently crashing and recovering multiple times per day (I'm sure because of my less than optimal coding abilities) 8.6 appears to be rock solid.
>
> This evening a client emailed me a screen shot of their browser with an odd Lasso error:
>
>        Error Message: This edition of Lasso can only be accessed from 5 different IP addresses. Etc, etc...
>        Error Code: -609
>
> I know what the message means, but code -609 is "The specified database was not found.", which I also deal with from time to time. I confirmed this by hitting the site from a new unique IP address and got the same error, in retrospect I neglected to check to see if the error was occurring with any other sites, but I'm sure I would have heard from other clients.
>
> Resetting that site appears to have resolved the issue, hitting the site from six different IP addresses and no more error. But the event has me curious about how licenses and instances now work and if the error is related.
>
> My license covers 10 instances, and my CLD should cover 3 more. My server had 14 sites/instances configured and after the install all the SiteAdmin.LassoApp screens were fully accessible. After seeing the error above I've since removed 4 extraneous development sites just incase the error was caused by exceeding my instance count.
>
> Any ideas or clarification?
>
> Thanks,
> Max
>
> ____________________________________________
> Maxwell Klein Consulting, Inc.
> Database Development & Web Integration
> [hidden email] ~ www.maxkdev.com
> 415-902-7623 ~ 800-948-5510 fax
>
>
> #############################################################
> This message is sent to you because you are subscribed to
>  the mailing list <[hidden email]>.
> To unsubscribe, E-mail to: <[hidden email]>
> To switch to the DIGEST mode, E-mail to <[hidden email]>
> To switch to the INDEX mode, E-mail to <[hidden email]>
> Send administrative queries to  <[hidden email]>
>
>

#############################################################
This message is sent to you because you are subscribed to
  the mailing list <[hidden email]>.
To unsubscribe, E-mail to: <[hidden email]>
To switch to the DIGEST mode, E-mail to <[hidden email]>
To switch to the INDEX mode, E-mail to <[hidden email]>
Send administrative queries to  <[hidden email]>

Reply | Threaded
Open this post in threaded view
|

Re: 8.6 upgrade, possible license issue

maxwellk2
During the 8.6 install I did half expect to see input fields for multiple licenses. But you are correct Jason, the Perpetual license didn't 'phone home' and see other available instances, I should have entered my CLD license instead, which would have resolved the issue.

Thanks,
Max


On Apr 11, 2011, at 6:41 PM, Jason Huck wrote:

> Just a guess, but I suspect you can't combine instances from two
> different licenses on a single installation of Lasso, since there's no
> way for the licensing mechanism to know what you're doing. The only
> way that could work is if Lasso accepted multiple serial numbers, or
> you were issued a special serial number which represents the
> combination of the two separate licenses.
>
> - jason
>
>
>
>
> On Mon, Apr 11, 2011 at 9:32 PM, Maxwell Klein <[hidden email]> wrote:
>> First, thank you LassoSoft, over the weekend my 8.6 upgrade under Mac OS X Server 10.5 went off without a hitch. Just download, double-click, restart Lasso, and everything's been running perfect since - this is the LassoSoft I know and love. Also, where 8.5.6 was silently crashing and recovering multiple times per day (I'm sure because of my less than optimal coding abilities) 8.6 appears to be rock solid.
>>
>> This evening a client emailed me a screen shot of their browser with an odd Lasso error:
>>
>>        Error Message: This edition of Lasso can only be accessed from 5 different IP addresses. Etc, etc...
>>        Error Code: -609
>>
>> I know what the message means, but code -609 is "The specified database was not found.", which I also deal with from time to time. I confirmed this by hitting the site from a new unique IP address and got the same error, in retrospect I neglected to check to see if the error was occurring with any other sites, but I'm sure I would have heard from other clients.
>>
>> Resetting that site appears to have resolved the issue, hitting the site from six different IP addresses and no more error. But the event has me curious about how licenses and instances now work and if the error is related.
>>
>> My license covers 10 instances, and my CLD should cover 3 more. My server had 14 sites/instances configured and after the install all the SiteAdmin.LassoApp screens were fully accessible. After seeing the error above I've since removed 4 extraneous development sites just incase the error was caused by exceeding my instance count.
>>
>> Any ideas or clarification?
>>
>> Thanks,
>> Max
>>
>> ____________________________________________
>> Maxwell Klein Consulting, Inc.
>> Database Development & Web Integration
>> [hidden email] ~ www.maxkdev.com
>> 415-902-7623 ~ 800-948-5510 fax
>>
>>
>> #############################################################
>> This message is sent to you because you are subscribed to
>>  the mailing list <[hidden email]>.
>> To unsubscribe, E-mail to: <[hidden email]>
>> To switch to the DIGEST mode, E-mail to <[hidden email]>
>> To switch to the INDEX mode, E-mail to <[hidden email]>
>> Send administrative queries to  <[hidden email]>
>>
>>
>
> #############################################################
> This message is sent to you because you are subscribed to
>  the mailing list <[hidden email]>.
> To unsubscribe, E-mail to: <[hidden email]>
> To switch to the DIGEST mode, E-mail to <[hidden email]>
> To switch to the INDEX mode, E-mail to <[hidden email]>
> Send administrative queries to  <[hidden email]>
>


#############################################################
This message is sent to you because you are subscribed to
  the mailing list <[hidden email]>.
To unsubscribe, E-mail to: <[hidden email]>
To switch to the DIGEST mode, E-mail to <[hidden email]>
To switch to the INDEX mode, E-mail to <[hidden email]>
Send administrative queries to  <[hidden email]>